aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-05-21 15:30:04 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-21 15:30:04 +0200
commit81923802883c19ae5e86006320ab3d3151f3727d (patch)
tree71f1d4d8c8fa173faa8bfe4b20bd75a4e55a25c0
parent38c150612cc9be488527e342db92d5c74093213f (diff)
downloadupstream-81923802883c19ae5e86006320ab3d3151f3727d.tar.gz
upstream-81923802883c19ae5e86006320ab3d3151f3727d.tar.bz2
upstream-81923802883c19ae5e86006320ab3d3151f3727d.zip
OpenWrt v23.05: set branch defaults
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
-rw-r--r--feeds.conf.default12
-rw-r--r--include/version.mk4
-rw-r--r--package/base-files/image-config.in2
3 files changed, 7 insertions, 11 deletions
diff --git a/feeds.conf.default b/feeds.conf.default
index 50ae67cb9d..f062f8545e 100644
--- a/feeds.conf.default
+++ b/feeds.conf.default
@@ -1,8 +1,4 @@
-src-git-full packages https://git.openwrt.org/feed/packages.git
-src-git-full luci https://git.openwrt.org/project/luci.git
-src-git-full routing https://git.openwrt.org/feed/routing.git
-src-git-full telephony https://git.openwrt.org/feed/telephony.git
-#src-git-full video https://github.com/openwrt/video.git
-#src-git-full targets https://github.com/openwrt/targets.git
-#src-git-full oldpackages http://git.openwrt.org/packages.git
-#src-link custom /usr/src/openwrt/custom-feed
+src-git-full packages https://git.openwrt.org/feed/packages.git;openwrt-23.05
+src-git-full luci https://git.openwrt.org/project/luci.git;openwrt-23.05
+src-git-full routing https://git.openwrt.org/feed/routing.git;openwrt-23.05
+src-git-full telephony https://git.openwrt.org/feed/telephony.git;openwrt-23.05
diff --git a/include/version.mk b/include/version.mk
index f39e35cd09..924bf83541 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -23,13 +23,13 @@ PKG_CONFIG_DEPENDS += \
sanitize = $(call tolower,$(subst _,-,$(subst $(space),-,$(1))))
VERSION_NUMBER:=$(call qstrip,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),SNAPSHOT)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),23.05-SNAPSHOT)
VERSION_CODE:=$(call qstrip,$(CONFIG_VERSION_CODE))
VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),$(REVISION))
VERSION_REPO:=$(call qstrip,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),https://downloads.openwrt.org/snapshots)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),https://downloads.openwrt.org/releases/23.05-SNAPSHOT)
VERSION_DIST:=$(call qstrip,$(CONFIG_VERSION_DIST))
VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
diff --git a/package/base-files/image-config.in b/package/base-files/image-config.in
index 2de2130b84..9a72863813 100644
--- a/package/base-files/image-config.in
+++ b/package/base-files/image-config.in
@@ -190,7 +190,7 @@ if VERSIONOPT
config VERSION_REPO
string
prompt "Release repository"
- default "https://downloads.openwrt.org/snapshots"
+ default "https://downloads.openwrt.org/releases/23.05-SNAPSHOT"
help
This is the repository address embedded in the image, it defaults
to the trunk snapshot repo; the url may contain the following placeholders: