aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2019-08-16 12:24:13 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2019-08-16 12:40:26 +0200
commit812bad9b13ecefadfd238696e4f5cec7a9dc763d (patch)
tree0b1d91d05a356b1571473c5721043b8c2788125a
parent51ffce069424f86e894369cee5cd327dd503db5f (diff)
downloadupstream-812bad9b13ecefadfd238696e4f5cec7a9dc763d.tar.gz
upstream-812bad9b13ecefadfd238696e4f5cec7a9dc763d.tar.bz2
upstream-812bad9b13ecefadfd238696e4f5cec7a9dc763d.zip
brcm63xx: do not build images for 16 MiB RAM devices by default
OpenWrt will run out of RAM while booting with the default package set, so let's not provide images that will likely fail. They can still be built manually through source or IB if needed. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
-rw-r--r--target/linux/brcm63xx/image/bcm63xx.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index 0f213bb154..95cd5a9f82 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -99,6 +99,7 @@ define Device/96345GW2-generic
DEVICE_DTS := bcm96345GW2
CFE_BOARD_ID := 96345GW2
CFE_CHIP_ID := 6345
+ DEFAULT := n
endef
TARGET_DEVICES += 96345GW2-generic
@@ -250,6 +251,7 @@ define Device/AR1004G
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += AR1004G
@@ -263,6 +265,7 @@ define Device/F5D7633
BLOCK_SIZE := 0x20000
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += F5D7633
@@ -341,6 +344,7 @@ define Device/BTV2110
CFE_EXTRAS += --layoutver 5
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += BTV2110
@@ -353,6 +357,7 @@ define Device/BTV2500V
CFE_EXTRAS += --layoutver 5
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += BTV2500V
@@ -404,6 +409,7 @@ define Device/CT-536_CT-5621
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += CT-536_CT-5621
@@ -415,6 +421,7 @@ define Device/CT-5365
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += CT-5365
@@ -488,6 +495,7 @@ define Device/DSL2640B-B
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += DSL2640B-B
@@ -499,6 +507,7 @@ define Device/DSL2640U
CFE_CHIP_ID := 6338
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += DSL2640U
@@ -582,6 +591,7 @@ define Device/DV-201AMR
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += DV-201AMR
@@ -596,6 +606,7 @@ define Device/RTA770BW
CFE_EXTRAS += --layoutver 5
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += RTA770BW
@@ -609,6 +620,7 @@ define Device/RTA770W
CFE_EXTRAS += --layoutver 5
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += RTA770W
@@ -621,6 +633,7 @@ define Device/RTA1025W_16
CFE_EXTRAS += --layoutver 5
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += RTA1025W_16
@@ -631,6 +644,7 @@ define Device/RTA1320_16M
CFE_BOARD_ID := RTA1320_16M
CFE_CHIP_ID := 6338
CFE_EXTRAS += --layoutver 5
+ DEFAULT := n
endef
TARGET_DEVICES += RTA1320_16M
@@ -751,6 +765,7 @@ define Device/livebox
DEVICE_DTS := livebox-blue-5g
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB1_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += livebox
@@ -773,6 +788,7 @@ define Device/DG834GT_PN
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(ATH5K_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += DG834GT_PN
@@ -785,6 +801,7 @@ define Device/DG834GTv4
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += DG834GTv4
@@ -922,6 +939,7 @@ define Device/FAST2404
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += FAST2404
@@ -944,6 +962,7 @@ define Device/FAST2604
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += FAST2604
@@ -1055,6 +1074,7 @@ define Device/SPW500V
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += SPW500V
@@ -1092,6 +1112,7 @@ define Device/CPVA502PLUS
CFE_EXTRAS += --signature "Telsey Tlc" --signature2 "99.99.999"
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += CPVA502PLUS
@@ -1117,6 +1138,7 @@ define Device/MAGIC
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(RT63_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += MAGIC
@@ -1131,6 +1153,7 @@ define Device/TD-W8900GB
IMAGE_OFFSET := 0x20000
DEVICE_PACKAGES := \
$(B43_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += TD-W8900GB
@@ -1143,6 +1166,7 @@ define Device/USR9108
CFE_CHIP_ID := 6348
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB1_PACKAGES)
+ DEFAULT := n
endef
TARGET_DEVICES += USR9108