aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-01-09 22:43:06 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-01-09 22:43:06 +0000
commit8067116c10bdf7c34f292ae64c4b6ed6193d3182 (patch)
tree7dae708ea37c49e3f2d769cabc64ec8eb4096c5e
parent6322a8be780d28e7d4ba22869ae7f3b72b819bbc (diff)
downloadupstream-8067116c10bdf7c34f292ae64c4b6ed6193d3182.tar.gz
upstream-8067116c10bdf7c34f292ae64c4b6ed6193d3182.tar.bz2
upstream-8067116c10bdf7c34f292ae64c4b6ed6193d3182.zip
kernel: deactivate ext4 SElinux support and extended attributes support in general config. This effects the build in kmod-fs-ext4 and when it is build into the kernel in the x86 target.
Thank you Philip Prindeville SVN-Revision: 24951
-rw-r--r--package/kernel/modules/fs.mk4
-rw-r--r--target/linux/generic/config-2.6.302
-rw-r--r--target/linux/generic/config-2.6.313
-rw-r--r--target/linux/generic/config-2.6.321
-rw-r--r--target/linux/generic/config-2.6.342
-rw-r--r--target/linux/generic/config-2.6.351
-rw-r--r--target/linux/generic/config-2.6.361
-rw-r--r--target/linux/generic/config-2.6.371
8 files changed, 11 insertions, 4 deletions
diff --git a/package/kernel/modules/fs.mk b/package/kernel/modules/fs.mk
index e5714aab64..846bc8233f 100644
--- a/package/kernel/modules/fs.mk
+++ b/package/kernel/modules/fs.mk
@@ -112,10 +112,6 @@ define KernelPackage/fs-ext4
SUBMENU:=$(FS_MENU)
TITLE:=EXT4 filesystem support
KCONFIG:= \
- CONFIG_EXT4DEV_COMPAT=n \
- CONFIG_EXT4_FS_XATTR=y \
- CONFIG_EXT4_FS_POSIX_ACL=y \
- CONFIG_EXT4_FS_SECURITY=y \
CONFIG_EXT4_FS \
CONFIG_JBD2
DEPENDS:= $(if $(DUMP)$(CONFIG_FS_MBCACHE),+kmod-fs-mbcache)
diff --git a/target/linux/generic/config-2.6.30 b/target/linux/generic/config-2.6.30
index 6e7d6a7965..87e8c6dded 100644
--- a/target/linux/generic/config-2.6.30
+++ b/target/linux/generic/config-2.6.30
@@ -521,6 +521,8 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT4DEV_COMPAT is not set
# CONFIG_EXT4DEV_FS is not set
# CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
+# CONFIG_EXT4_FS_XATTR is not set
CONFIG_EXTRA_FIRMWARE=""
CONFIG_EXTRA_TARGETS=""
# CONFIG_FAIR_GROUP_SCHED is not set
diff --git a/target/linux/generic/config-2.6.31 b/target/linux/generic/config-2.6.31
index e664748f53..96f955eeee 100644
--- a/target/linux/generic/config-2.6.31
+++ b/target/linux/generic/config-2.6.31
@@ -502,8 +502,11 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT3_DEFAULTS_TO_ORDERED is not set
# CONFIG_EXT3_FS is not set
# CONFIG_EXT3_FS_XATTR is not set
+# CONFIG_EXT4DEV_COMPAT is not set
# CONFIG_EXT4DEV_FS is not set
# CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
+# CONFIG_EXT4_FS_XATTR is not set
CONFIG_EXTRA_FIRMWARE=""
CONFIG_EXTRA_TARGETS=""
# CONFIG_EZX_PCAP is not set
diff --git a/target/linux/generic/config-2.6.32 b/target/linux/generic/config-2.6.32
index 2e7756c532..5e3733ae64 100644
--- a/target/linux/generic/config-2.6.32
+++ b/target/linux/generic/config-2.6.32
@@ -552,6 +552,7 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT4DEV_FS is not set
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
# CONFIG_EXT4_FS_XATTR is not set
CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXTRA_FIRMWARE=""
diff --git a/target/linux/generic/config-2.6.34 b/target/linux/generic/config-2.6.34
index 7f176181a4..9209458ee2 100644
--- a/target/linux/generic/config-2.6.34
+++ b/target/linux/generic/config-2.6.34
@@ -569,6 +569,8 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT4DEV_FS is not set
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
+# CONFIG_EXT4_FS_XATTR is not set
CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXTRA_FIRMWARE=""
CONFIG_EXTRA_TARGETS=""
diff --git a/target/linux/generic/config-2.6.35 b/target/linux/generic/config-2.6.35
index 8e1b16de74..8f64f3414b 100644
--- a/target/linux/generic/config-2.6.35
+++ b/target/linux/generic/config-2.6.35
@@ -594,6 +594,7 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT4DEV_FS is not set
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
# CONFIG_EXT4_FS_XATTR is not set
CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXTRA_FIRMWARE=""
diff --git a/target/linux/generic/config-2.6.36 b/target/linux/generic/config-2.6.36
index 0bc1175f4e..45dbde073c 100644
--- a/target/linux/generic/config-2.6.36
+++ b/target/linux/generic/config-2.6.36
@@ -565,6 +565,7 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT3_FS_XATTR is not set
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
# CONFIG_EXT4_FS_XATTR is not set
CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXTRA_FIRMWARE=""
diff --git a/target/linux/generic/config-2.6.37 b/target/linux/generic/config-2.6.37
index 7e7685ae02..b8fa6009eb 100644
--- a/target/linux/generic/config-2.6.37
+++ b/target/linux/generic/config-2.6.37
@@ -564,6 +564,7 @@ CONFIG_EXPERIMENTAL=y
# CONFIG_EXT3_FS_XATTR is not set
# CONFIG_EXT4_DEBUG is not set
# CONFIG_EXT4_FS is not set
+# CONFIG_EXT4_FS_SECURITY is not set
# CONFIG_EXT4_FS_XATTR is not set
CONFIG_EXT4_USE_FOR_EXT23=y
CONFIG_EXTRA_FIRMWARE=""