aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-22 04:03:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-22 04:03:35 +0000
commit804bfa954d66373e71b8224f4df2b5f09481f797 (patch)
treedc8059ae7a813b1ffda8f972a69a3a5de9474ca2
parentccd12544f65912a0c2016ae4c94528e7ad84eef1 (diff)
downloadupstream-804bfa954d66373e71b8224f4df2b5f09481f797.tar.gz
upstream-804bfa954d66373e71b8224f4df2b5f09481f797.tar.bz2
upstream-804bfa954d66373e71b8224f4df2b5f09481f797.zip
ignore profiles with custom kernel configs in the image builder itself
SVN-Revision: 6342
-rwxr-xr-xscripts/metadata.pl7
-rw-r--r--target/imagebuilder/files/Makefile5
2 files changed, 8 insertions, 4 deletions
diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index 4a05628a54..063524a67b 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -149,9 +149,10 @@ sub gen_target_mk() {
define Profile/$conf\_$profile->{id}
ID:=$profile->{id}
NAME:=$profile->{name}
- PACKAGES:=".join(" ", @{$profile->{packages}})."
- endef";
- $profiles_eval .= "
+ PACKAGES:=".join(" ", @{$profile->{packages}})."\n";
+ $profile->{kconfig} and $profiles_def .= " KCONFIG:=1\n";
+ $profiles_def .= " endef";
+ $profiles_eval .= "
\$(eval \$(call AddProfile,$conf\_$profile->{id}))"
}
print "
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index b36e2f2e31..8b386a33c6 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -34,6 +34,7 @@ IPKG:= \
define Profile/Default
ID:=
NAME:=
+ KCONFIG:=
PACKAGES:=
endef
@@ -46,8 +47,10 @@ define AddProfile
endif
$(ID)_NAME:=$(NAME)
$(ID)_PACKAGES:=$(PACKAGES)
- PROFILE_LIST += \
+ ifneq ($(KCONFIG),)
+ PROFILE_LIST += \
echo '$(ID):'; [ -z '$(NAME)' ] || echo ' $(NAME)'; echo ' Packages: $(PACKAGES)';
+ endif
endif
endef