aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEtienne Haarsma <bladeoner112@gmail.com>2017-11-26 12:34:38 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-11-26 15:10:36 +0100
commit7f3dab2fc34e9b6c15d74ebf8e1d74ef601677e3 (patch)
tree8cbc6fae4a42b846360e5c6467f0ddb8896f5c8f
parentd3f40aabba83818106ce840dba9f7e76a06e721d (diff)
downloadupstream-7f3dab2fc34e9b6c15d74ebf8e1d74ef601677e3.tar.gz
upstream-7f3dab2fc34e9b6c15d74ebf8e1d74ef601677e3.tar.bz2
upstream-7f3dab2fc34e9b6c15d74ebf8e1d74ef601677e3.zip
kernel: bump 4.4 to 4.4.102
Refreshed all patches. Removed upstream ramips patch: 0063-set-CM_GCR_BASE_CMDEFTGT_MEM-according-to-datasheet.patch Compile-tested: ar71xx Run-tested: ar71xx Signed-off-by: Etienne Haarsma <bladeoner112@gmail.com> Tested-by: Stijn Segers <francesco.borromini@inventati.org>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch6
-rw-r--r--target/linux/brcm2708/patches-4.4/0029-Add-dwc_otg-driver.patch2
-rw-r--r--target/linux/brcm2708/patches-4.4/0111-mm-Remove-the-PFN-busy-warning.patch2
-rw-r--r--target/linux/gemini/patches-4.4/150-gemini-pata.patch2
-rw-r--r--target/linux/generic/patches-4.4/093-MIPS-store-the-appended-dtb-address-in-a-variable.patch2
-rw-r--r--target/linux/generic/patches-4.4/103-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch2
-rw-r--r--target/linux/generic/patches-4.4/214-spidev_h_portability.patch2
-rw-r--r--target/linux/generic/patches-4.4/630-packet_socket_type.patch16
-rw-r--r--target/linux/generic/patches-4.4/701-phy_extension.patch2
-rw-r--r--target/linux/generic/patches-4.4/702-phy_add_aneg_done_function.patch2
-rw-r--r--target/linux/generic/patches-4.4/703-phy-add-detach-callback-to-struct-phy_driver.patch2
-rw-r--r--target/linux/generic/patches-4.4/710-phy-add-mdio_register_board_info.patch2
-rw-r--r--target/linux/generic/patches-4.4/902-debloat_proc.patch4
-rw-r--r--target/linux/imx6/patches-4.4/203-net-igb-add-phy-read-write-functions-that-accept-phy.patch4
-rw-r--r--target/linux/imx6/patches-4.4/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch6
-rw-r--r--target/linux/ipq806x/patches-4.4/400-dsa-add-qca.patch2
-rw-r--r--target/linux/lantiq/patches-4.4/0026-NET-multi-phy-support.patch2
-rw-r--r--target/linux/mediatek/patches-4.4/0001-NET-multi-phy-support.patch2
-rw-r--r--target/linux/mvebu/patches-4.4/125-phy-provide-a-hook-for-link-up-link-down-events.patch2
-rw-r--r--target/linux/mvebu/patches-4.4/128-phy-export-phy_speed_to_str-for-phylink.patch2
-rw-r--r--target/linux/mvebu/patches-4.4/130-phylink-add-phylink-infrastructure.patch4
-rw-r--r--target/linux/oxnas/patches-4.4/500-oxnas-sata.patch2
-rw-r--r--target/linux/ramips/patches-4.4/0013-owrt-hack-fix-mt7688-cache-issue.patch4
-rw-r--r--target/linux/ramips/patches-4.4/0034-NET-multi-phy-support.patch2
-rw-r--r--target/linux/ramips/patches-4.4/0063-set-CM_GCR_BASE_CMDEFTGT_MEM-according-to-datasheet.patch12
-rw-r--r--target/linux/x86/patches-4.4/100-fix_cs5535_clockevt.patch2
27 files changed, 42 insertions, 54 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 6b4a22484e..b36b6394ab 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -3,10 +3,10 @@
LINUX_RELEASE?=1
LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .93
+LINUX_VERSION-4.4 = .102
LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.93 = ed349314f16e78a6571b5f8884f6452782aef6c26b81bcc7ccdac44ecd917c36
+LINUX_KERNEL_HASH-4.4.102 = ede2c22a559e1d894161d53e1d634ee969380a159642aafc0c9c268daf8eaafe
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch b/target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch
index 5bedf5dc9e..8789b644a6 100644
--- a/target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch
+++ b/target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch
@@ -276,7 +276,7 @@
t = ip6gre_tunnel_lookup(skb->dev, &ipv6h->daddr, &ipv6h->saddr,
key, greh->protocol);
-@@ -479,11 +479,11 @@ static int ip6gre_rcv(struct sk_buff *sk
+@@ -482,11 +482,11 @@ static int ip6gre_rcv(struct sk_buff *sk
offset += 4;
}
if (flags&GRE_KEY) {
@@ -290,7 +290,7 @@
offset += 4;
}
}
-@@ -745,7 +745,7 @@ static netdev_tx_t ip6gre_xmit2(struct s
+@@ -748,7 +748,7 @@ static netdev_tx_t ip6gre_xmit2(struct s
if (tunnel->parms.o_flags&GRE_SEQ) {
++tunnel->o_seqno;
@@ -299,7 +299,7 @@
ptr--;
}
if (tunnel->parms.o_flags&GRE_KEY) {
-@@ -841,7 +841,7 @@ static inline int ip6gre_xmit_ipv6(struc
+@@ -844,7 +844,7 @@ static inline int ip6gre_xmit_ipv6(struc
dsfield = ipv6_get_dsfield(ipv6h);
if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
diff --git a/target/linux/brcm2708/patches-4.4/0029-Add-dwc_otg-driver.patch b/target/linux/brcm2708/patches-4.4/0029-Add-dwc_otg-driver.patch
index 0310041353..8e9657abcf 100644
--- a/target/linux/brcm2708/patches-4.4/0029-Add-dwc_otg-driver.patch
+++ b/target/linux/brcm2708/patches-4.4/0029-Add-dwc_otg-driver.patch
@@ -659,7 +659,7 @@ dwc_otg: Remove duplicate gadget probe/unregister function
}
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
-@@ -4975,7 +4975,7 @@ static void port_event(struct usb_hub *h
+@@ -4978,7 +4978,7 @@ static void port_event(struct usb_hub *h
if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
u16 status = 0, unused;
diff --git a/target/linux/brcm2708/patches-4.4/0111-mm-Remove-the-PFN-busy-warning.patch b/target/linux/brcm2708/patches-4.4/0111-mm-Remove-the-PFN-busy-warning.patch
index 3a80486870..bdb38a0e24 100644
--- a/target/linux/brcm2708/patches-4.4/0111-mm-Remove-the-PFN-busy-warning.patch
+++ b/target/linux/brcm2708/patches-4.4/0111-mm-Remove-the-PFN-busy-warning.patch
@@ -14,7 +14,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
-@@ -6816,8 +6816,6 @@ int alloc_contig_range(unsigned long sta
+@@ -6831,8 +6831,6 @@ int alloc_contig_range(unsigned long sta
/* Make sure the range is really isolated. */
if (test_pages_isolated(outer_start, end, false)) {
diff --git a/target/linux/gemini/patches-4.4/150-gemini-pata.patch b/target/linux/gemini/patches-4.4/150-gemini-pata.patch
index 3da05c5193..1054be08b5 100644
--- a/target/linux/gemini/patches-4.4/150-gemini-pata.patch
+++ b/target/linux/gemini/patches-4.4/150-gemini-pata.patch
@@ -123,7 +123,7 @@
.length = SZ_512K,
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
-@@ -564,6 +564,16 @@ config PATA_EP93XX
+@@ -567,6 +567,16 @@ config PATA_EP93XX
If unsure, say N.
diff --git a/target/linux/generic/patches-4.4/093-MIPS-store-the-appended-dtb-address-in-a-variable.patch b/target/linux/generic/patches-4.4/093-MIPS-store-the-appended-dtb-address-in-a-variable.patch
index 764c1cb830..d868d210aa 100644
--- a/target/linux/generic/patches-4.4/093-MIPS-store-the-appended-dtb-address-in-a-variable.patch
+++ b/target/linux/generic/patches-4.4/093-MIPS-store-the-appended-dtb-address-in-a-variable.patch
@@ -119,7 +119,7 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
/* Set the SP after an empty pt_regs. */
--- a/arch/mips/kernel/setup.c
+++ b/arch/mips/kernel/setup.c
-@@ -814,6 +814,10 @@ void __init setup_arch(char **cmdline_p)
+@@ -886,6 +886,10 @@ void __init setup_arch(char **cmdline_p)
unsigned long kernelsp[NR_CPUS];
unsigned long fw_arg0, fw_arg1, fw_arg2, fw_arg3;
diff --git a/target/linux/generic/patches-4.4/103-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch b/target/linux/generic/patches-4.4/103-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
index 6c9b12c2e1..a53be2d15c 100644
--- a/target/linux/generic/patches-4.4/103-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
+++ b/target/linux/generic/patches-4.4/103-Fix-alloc_node_mem_map-with-ARCH_PFN_OFFSET-calcu.patch
@@ -75,7 +75,7 @@ Signed-off-by: Tobias Wolf <dev-NTEO@vplace.de>
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
-@@ -5357,7 +5357,7 @@ static void __init_refok alloc_node_mem_
+@@ -5372,7 +5372,7 @@ static void __init_refok alloc_node_mem_
mem_map = NODE_DATA(0)->node_mem_map;
#if defined(CONFIG_HAVE_MEMBLOCK_NODE_MAP) || defined(CONFIG_FLATMEM)
if (page_to_pfn(mem_map) != pgdat->node_start_pfn)
diff --git a/target/linux/generic/patches-4.4/214-spidev_h_portability.patch b/target/linux/generic/patches-4.4/214-spidev_h_portability.patch
index dbee090547..39fa32ffa2 100644
--- a/target/linux/generic/patches-4.4/214-spidev_h_portability.patch
+++ b/target/linux/generic/patches-4.4/214-spidev_h_portability.patch
@@ -1,6 +1,6 @@
--- a/include/uapi/linux/spi/spidev.h
+++ b/include/uapi/linux/spi/spidev.h
-@@ -111,7 +111,7 @@ struct spi_ioc_transfer {
+@@ -112,7 +112,7 @@ struct spi_ioc_transfer {
/* not all platforms use <asm-generic/ioctl.h> or _IOC_TYPECHECK() ... */
#define SPI_MSGSIZE(N) \
diff --git a/target/linux/generic/patches-4.4/630-packet_socket_type.patch b/target/linux/generic/patches-4.4/630-packet_socket_type.patch
index 8c6b7a37b5..a427165f41 100644
--- a/target/linux/generic/patches-4.4/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-4.4/630-packet_socket_type.patch
@@ -26,7 +26,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
#define PACKET_FANOUT_LB 1
--- a/net/packet/af_packet.c
+++ b/net/packet/af_packet.c
-@@ -1776,6 +1776,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1784,6 +1784,7 @@ static int packet_rcv_spkt(struct sk_buf
{
struct sock *sk;
struct sockaddr_pkt *spkt;
@@ -34,7 +34,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
/*
* When we registered the protocol we saved the socket in the data
-@@ -1783,6 +1784,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1791,6 +1792,7 @@ static int packet_rcv_spkt(struct sk_buf
*/
sk = pt->af_packet_priv;
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
/*
* Yank back the headers [hope the device set this
-@@ -1795,7 +1797,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1803,7 +1805,7 @@ static int packet_rcv_spkt(struct sk_buf
* so that this procedure is noop.
*/
@@ -51,7 +51,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
goto out;
if (!net_eq(dev_net(dev), sock_net(sk)))
-@@ -1998,12 +2000,12 @@ static int packet_rcv(struct sk_buff *sk
+@@ -2006,12 +2008,12 @@ static int packet_rcv(struct sk_buff *sk
int skb_len = skb->len;
unsigned int snaplen, res;
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -2123,12 +2125,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -2131,12 +2133,12 @@ static int tpacket_rcv(struct sk_buff *s
BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h2)) != 32);
BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h3)) != 48);
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -3115,6 +3117,7 @@ static int packet_create(struct net *net
+@@ -3127,6 +3129,7 @@ static int packet_create(struct net *net
mutex_init(&po->pg_vec_lock);
po->rollover = NULL;
po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt;
-@@ -3744,6 +3747,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3756,6 +3759,16 @@ packet_setsockopt(struct socket *sock, i
po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
return 0;
}
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
default:
return -ENOPROTOOPT;
}
-@@ -3796,6 +3809,13 @@ static int packet_getsockopt(struct sock
+@@ -3809,6 +3822,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR:
val = po->has_vnet_hdr;
break;
diff --git a/target/linux/generic/patches-4.4/701-phy_extension.patch b/target/linux/generic/patches-4.4/701-phy_extension.patch
index a1c48b7a3a..6cb3fdfd44 100644
--- a/target/linux/generic/patches-4.4/701-phy_extension.patch
+++ b/target/linux/generic/patches-4.4/701-phy_extension.patch
@@ -53,7 +53,7 @@
* @phydev: the phy_device struct
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -800,6 +800,7 @@ void phy_start_machine(struct phy_device
+@@ -796,6 +796,7 @@ void phy_start_machine(struct phy_device
void phy_stop_machine(struct phy_device *phydev);
int phy_ethtool_sset(struct phy_device *phydev, struct ethtool_cmd *cmd);
int phy_ethtool_gset(struct phy_device *phydev, struct ethtool_cmd *cmd);
diff --git a/target/linux/generic/patches-4.4/702-phy_add_aneg_done_function.patch b/target/linux/generic/patches-4.4/702-phy_add_aneg_done_function.patch
index f16efa495e..2a75fb02e5 100644
--- a/target/linux/generic/patches-4.4/702-phy_add_aneg_done_function.patch
+++ b/target/linux/generic/patches-4.4/702-phy_add_aneg_done_function.patch
@@ -1,6 +1,6 @@
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -501,6 +501,12 @@ struct phy_driver {
+@@ -497,6 +497,12 @@ struct phy_driver {
/* Determines the negotiated speed and duplex */
int (*read_status)(struct phy_device *phydev);
diff --git a/target/linux/generic/patches-4.4/703-phy-add-detach-callback-to-struct-phy_driver.patch b/target/linux/generic/patches-4.4/703-phy-add-detach-callback-to-struct-phy_driver.patch
index 5babfdf5e2..4ef3b781fa 100644
--- a/target/linux/generic/patches-4.4/703-phy-add-detach-callback-to-struct-phy_driver.patch
+++ b/target/linux/generic/patches-4.4/703-phy-add-detach-callback-to-struct-phy_driver.patch
@@ -12,7 +12,7 @@
phy_suspend(phydev);
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -519,6 +519,12 @@ struct phy_driver {
+@@ -515,6 +515,12 @@ struct phy_driver {
*/
int (*did_interrupt)(struct phy_device *phydev);
diff --git a/target/linux/generic/patches-4.4/710-phy-add-mdio_register_board_info.patch b/target/linux/generic/patches-4.4/710-phy-add-mdio_register_board_info.patch
index bd15df2384..4886dd0e3a 100644
--- a/target/linux/generic/patches-4.4/710-phy-add-mdio_register_board_info.patch
+++ b/target/linux/generic/patches-4.4/710-phy-add-mdio_register_board_info.patch
@@ -46,7 +46,7 @@
phy_device_free(phydev);
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -839,6 +839,23 @@ void mdio_bus_exit(void);
+@@ -835,6 +835,23 @@ void mdio_bus_exit(void);
extern struct bus_type mdio_bus_type;
diff --git a/target/linux/generic/patches-4.4/902-debloat_proc.patch b/target/linux/generic/patches-4.4/902-debloat_proc.patch
index 98e78183de..b59ecf2a0a 100644
--- a/target/linux/generic/patches-4.4/902-debloat_proc.patch
+++ b/target/linux/generic/patches-4.4/902-debloat_proc.patch
@@ -133,7 +133,7 @@
}
--- a/mm/vmstat.c
+++ b/mm/vmstat.c
-@@ -1553,10 +1553,12 @@ static int __init setup_vmstat(void)
+@@ -1555,10 +1555,12 @@ static int __init setup_vmstat(void)
cpu_notifier_register_done();
#endif
#ifdef CONFIG_PROC_FS
@@ -173,7 +173,7 @@
goto err;
--- a/net/core/sock.c
+++ b/net/core/sock.c
-@@ -3042,6 +3042,8 @@ static __net_initdata struct pernet_oper
+@@ -3044,6 +3044,8 @@ static __net_initdata struct pernet_oper
static int __init proto_init(void)
{
diff --git a/target/linux/imx6/patches-4.4/203-net-igb-add-phy-read-write-functions-that-accept-phy.patch b/target/linux/imx6/patches-4.4/203-net-igb-add-phy-read-write-functions-that-accept-phy.patch
index 45a4a8b3d0..0ce4a0d4c6 100644
--- a/target/linux/imx6/patches-4.4/203-net-igb-add-phy-read-write-functions-that-accept-phy.patch
+++ b/target/linux/imx6/patches-4.4/203-net-igb-add-phy-read-write-functions-that-accept-phy.patch
@@ -16,7 +16,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
--- a/drivers/net/ethernet/intel/igb/e1000_82575.c
+++ b/drivers/net/ethernet/intel/igb/e1000_82575.c
-@@ -2154,7 +2154,7 @@ static s32 igb_read_phy_reg_82580(struct
+@@ -2165,7 +2165,7 @@ static s32 igb_read_phy_reg_82580(struct
if (ret_val)
goto out;
@@ -25,7 +25,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
hw->phy.ops.release(hw);
-@@ -2179,7 +2179,7 @@ static s32 igb_write_phy_reg_82580(struc
+@@ -2190,7 +2190,7 @@ static s32 igb_write_phy_reg_82580(struc
if (ret_val)
goto out;
diff --git a/target/linux/imx6/patches-4.4/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch b/target/linux/imx6/patches-4.4/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch
index bbd972177b..1d3dcb29ab 100644
--- a/target/linux/imx6/patches-4.4/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch
+++ b/target/linux/imx6/patches-4.4/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch
@@ -23,7 +23,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
--- a/drivers/net/ethernet/intel/igb/e1000_82575.c
+++ b/drivers/net/ethernet/intel/igb/e1000_82575.c
-@@ -613,13 +613,25 @@ static s32 igb_get_invariants_82575(stru
+@@ -624,13 +624,25 @@ static s32 igb_get_invariants_82575(stru
switch (link_mode) {
case E1000_CTRL_EXT_LINK_MODE_1000BASE_KX:
hw->phy.media_type = e1000_media_type_internal_serdes;
@@ -49,7 +49,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
}
/* fall through for I2C based SGMII */
case E1000_CTRL_EXT_LINK_MODE_PCIE_SERDES:
-@@ -636,8 +648,11 @@ static s32 igb_get_invariants_82575(stru
+@@ -647,8 +659,11 @@ static s32 igb_get_invariants_82575(stru
hw->phy.media_type = e1000_media_type_copper;
dev_spec->sgmii_active = true;
}
@@ -259,7 +259,7 @@ Signed-off-by: Tim Harvey <tharvey@gateworks.com>
/* start the watchdog. */
hw->mac.get_link_status = 1;
schedule_work(&adapter->watchdog_task);
-@@ -7102,21 +7240,41 @@ void igb_alloc_rx_buffers(struct igb_rin
+@@ -7104,21 +7242,41 @@ void igb_alloc_rx_buffers(struct igb_rin
static int igb_mii_ioctl(struct net_device *netdev, struct ifreq *ifr, int cmd)
{
struct igb_adapter *adapter = netdev_priv(netdev);
diff --git a/target/linux/ipq806x/patches-4.4/400-dsa-add-qca.patch b/target/linux/ipq806x/patches-4.4/400-dsa-add-qca.patch
index c369ab914a..fd9f573493 100644
--- a/target/linux/ipq806x/patches-4.4/400-dsa-add-qca.patch
+++ b/target/linux/ipq806x/patches-4.4/400-dsa-add-qca.patch
@@ -788,7 +788,7 @@ Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
#define DSA_MAX_SWITCHES 4
--- a/net/dsa/Kconfig
+++ b/net/dsa/Kconfig
-@@ -26,6 +26,9 @@ config NET_DSA_HWMON
+@@ -27,6 +27,9 @@ config NET_DSA_HWMON
via the hwmon sysfs interface and exposes the onboard sensors.
# tagging formats
diff --git a/target/linux/lantiq/patches-4.4/0026-NET-multi-phy-support.patch b/target/linux/lantiq/patches-4.4/0026-NET-multi-phy-support.patch
index 3c2347979b..0cbd437beb 100644
--- a/target/linux/lantiq/patches-4.4/0026-NET-multi-phy-support.patch
+++ b/target/linux/lantiq/patches-4.4/0026-NET-multi-phy-support.patch
@@ -43,7 +43,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
}
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -377,6 +377,7 @@ struct phy_device {
+@@ -373,6 +373,7 @@ struct phy_device {
bool is_pseudo_fixed_link;
bool has_fixups;
bool suspended;
diff --git a/target/linux/mediatek/patches-4.4/0001-NET-multi-phy-support.patch b/target/linux/mediatek/patches-4.4/0001-NET-multi-phy-support.patch
index 717e2a5239..d10615414e 100644
--- a/target/linux/mediatek/patches-4.4/0001-NET-multi-phy-support.patch
+++ b/target/linux/mediatek/patches-4.4/0001-NET-multi-phy-support.patch
@@ -43,7 +43,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
}
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -377,6 +377,7 @@ struct phy_device {
+@@ -373,6 +373,7 @@ struct phy_device {
bool is_pseudo_fixed_link;
bool has_fixups;
bool suspended;
diff --git a/target/linux/mvebu/patches-4.4/125-phy-provide-a-hook-for-link-up-link-down-events.patch b/target/linux/mvebu/patches-4.4/125-phy-provide-a-hook-for-link-up-link-down-events.patch
index a27e6baec3..0a0157be9d 100644
--- a/target/linux/mvebu/patches-4.4/125-phy-provide-a-hook-for-link-up-link-down-events.patch
+++ b/target/linux/mvebu/patches-4.4/125-phy-provide-a-hook-for-link-up-link-down-events.patch
@@ -173,7 +173,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -433,6 +433,7 @@ struct phy_device {
+@@ -429,6 +429,7 @@ struct phy_device {
u8 mdix;
diff --git a/target/linux/mvebu/patches-4.4/128-phy-export-phy_speed_to_str-for-phylink.patch b/target/linux/mvebu/patches-4.4/128-phy-export-phy_speed_to_str-for-phylink.patch
index 1b79259dac..c43607029c 100644
--- a/target/linux/mvebu/patches-4.4/128-phy-export-phy_speed_to_str-for-phylink.patch
+++ b/target/linux/mvebu/patches-4.4/128-phy-export-phy_speed_to_str-for-phylink.patch
@@ -34,7 +34,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
case PHY_##_state: \
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -816,6 +816,7 @@ int phy_ethtool_gset(struct phy_device *
+@@ -812,6 +812,7 @@ int phy_ethtool_gset(struct phy_device *
int phy_ethtool_ioctl(struct phy_device *phydev, void *useraddr);
int phy_mii_ioctl(struct phy_device *phydev, struct ifreq *ifr, int cmd);
int phy_start_interrupts(struct phy_device *phydev);
diff --git a/target/linux/mvebu/patches-4.4/130-phylink-add-phylink-infrastructure.patch b/target/linux/mvebu/patches-4.4/130-phylink-add-phylink-infrastructure.patch
index 0d340c8278..141ea07d2a 100644
--- a/target/linux/mvebu/patches-4.4/130-phylink-add-phylink-infrastructure.patch
+++ b/target/linux/mvebu/patches-4.4/130-phylink-add-phylink-infrastructure.patch
@@ -914,7 +914,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
+MODULE_LICENSE("GPL");
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -147,6 +147,7 @@ static inline const char *phy_modes(phy_
+@@ -143,6 +143,7 @@ static inline const char *phy_modes(phy_
#define MII_ADDR_C45 (1<<30)
struct device;
@@ -922,7 +922,7 @@ Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
struct sk_buff;
/*
-@@ -429,6 +430,7 @@ struct phy_device {
+@@ -425,6 +426,7 @@ struct phy_device {
struct mutex lock;
diff --git a/target/linux/oxnas/patches-4.4/500-oxnas-sata.patch b/target/linux/oxnas/patches-4.4/500-oxnas-sata.patch
index 3891dc1bc2..b833b635aa 100644
--- a/target/linux/oxnas/patches-4.4/500-oxnas-sata.patch
+++ b/target/linux/oxnas/patches-4.4/500-oxnas-sata.patch
@@ -1,6 +1,6 @@
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
-@@ -429,6 +429,13 @@ config SATA_VITESSE
+@@ -432,6 +432,13 @@ config SATA_VITESSE
If unsure, say N.
diff --git a/target/linux/ramips/patches-4.4/0013-owrt-hack-fix-mt7688-cache-issue.patch b/target/linux/ramips/patches-4.4/0013-owrt-hack-fix-mt7688-cache-issue.patch
index c9bba2a9dd..37d377de0c 100644
--- a/target/linux/ramips/patches-4.4/0013-owrt-hack-fix-mt7688-cache-issue.patch
+++ b/target/linux/ramips/patches-4.4/0013-owrt-hack-fix-mt7688-cache-issue.patch
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/arch/mips/kernel/setup.c
+++ b/arch/mips/kernel/setup.c
-@@ -696,7 +696,6 @@ static void __init arch_mem_init(char **
+@@ -768,7 +768,6 @@ static void __init arch_mem_init(char **
crashk_res.end - crashk_res.start + 1,
BOOTMEM_DEFAULT);
#endif
@@ -18,7 +18,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
sparse_init();
plat_swiotlb_setup();
paging_init();
-@@ -809,6 +808,7 @@ void __init setup_arch(char **cmdline_p)
+@@ -881,6 +880,7 @@ void __init setup_arch(char **cmdline_p)
prefill_possible_map();
cpu_cache_init();
diff --git a/target/linux/ramips/patches-4.4/0034-NET-multi-phy-support.patch b/target/linux/ramips/patches-4.4/0034-NET-multi-phy-support.patch
index b6ab65a553..4a248ae284 100644
--- a/target/linux/ramips/patches-4.4/0034-NET-multi-phy-support.patch
+++ b/target/linux/ramips/patches-4.4/0034-NET-multi-phy-support.patch
@@ -43,7 +43,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
}
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -377,6 +377,7 @@ struct phy_device {
+@@ -373,6 +373,7 @@ struct phy_device {
bool is_pseudo_fixed_link;
bool has_fixups;
bool suspended;
diff --git a/target/linux/ramips/patches-4.4/0063-set-CM_GCR_BASE_CMDEFTGT_MEM-according-to-datasheet.patch b/target/linux/ramips/patches-4.4/0063-set-CM_GCR_BASE_CMDEFTGT_MEM-according-to-datasheet.patch
deleted file mode 100644
index 55fd70131d..0000000000
--- a/target/linux/ramips/patches-4.4/0063-set-CM_GCR_BASE_CMDEFTGT_MEM-according-to-datasheet.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/arch/mips/include/asm/mips-cm.h
-+++ b/arch/mips/include/asm/mips-cm.h
-@@ -238,8 +238,7 @@ BUILD_CM_Cx_R_(tcid_8_priority, 0x80)
- #define CM_GCR_BASE_GCRBASE_MSK (_ULCAST_(0x1ffff) << 15)
- #define CM_GCR_BASE_CMDEFTGT_SHF 0
- #define CM_GCR_BASE_CMDEFTGT_MSK (_ULCAST_(0x3) << 0)
--#define CM_GCR_BASE_CMDEFTGT_DISABLED 0
--#define CM_GCR_BASE_CMDEFTGT_MEM 1
-+#define CM_GCR_BASE_CMDEFTGT_MEM 0
- #define CM_GCR_BASE_CMDEFTGT_IOCU0 2
- #define CM_GCR_BASE_CMDEFTGT_IOCU1 3
-
diff --git a/target/linux/x86/patches-4.4/100-fix_cs5535_clockevt.patch b/target/linux/x86/patches-4.4/100-fix_cs5535_clockevt.patch
index c49ddca7d6..c3a7fce9ce 100644
--- a/target/linux/x86/patches-4.4/100-fix_cs5535_clockevt.patch
+++ b/target/linux/x86/patches-4.4/100-fix_cs5535_clockevt.patch
@@ -1,6 +1,6 @@
--- a/drivers/clocksource/cs5535-clockevt.c
+++ b/drivers/clocksource/cs5535-clockevt.c
-@@ -129,7 +129,8 @@ static irqreturn_t mfgpt_tick(int irq, v
+@@ -130,7 +130,8 @@ static irqreturn_t mfgpt_tick(int irq, v
cs5535_mfgpt_write(cs5535_event_clock, MFGPT_REG_SETUP,
MFGPT_SETUP_CNTEN | MFGPT_SETUP_CMP2);