aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-11-09 18:53:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-11-09 18:53:23 +0000
commit7ea7acad21ee1a065684125bffa4079ed86cac3d (patch)
treecafa8ba22a8237d1197760c94d6baac858e7a5c4
parentb592d36cb119ce407f6b82fe800892d9775188e0 (diff)
downloadupstream-7ea7acad21ee1a065684125bffa4079ed86cac3d.tar.gz
upstream-7ea7acad21ee1a065684125bffa4079ed86cac3d.tar.bz2
upstream-7ea7acad21ee1a065684125bffa4079ed86cac3d.zip
Enable iso9660 and udf kernel modules (#930)
SVN-Revision: 5485
-rw-r--r--package/kernel/modules/fs.mk22
-rw-r--r--target/linux/aruba-2.6/config8
-rw-r--r--target/linux/au1000-2.6/config8
-rw-r--r--target/linux/brcm-2.6/config8
-rw-r--r--target/linux/brcm63xx-2.6/config8
-rw-r--r--target/linux/ixp4xx-2.6/config8
-rw-r--r--target/linux/magicbox-2.6/config8
-rw-r--r--target/linux/rb532-2.6/config8
-rw-r--r--target/linux/rdc-2.6/config8
-rw-r--r--target/linux/sibyte-2.6/config8
-rw-r--r--target/linux/uml-2.6/config5
-rw-r--r--target/linux/x86-2.6/config8
12 files changed, 85 insertions, 22 deletions
diff --git a/package/kernel/modules/fs.mk b/package/kernel/modules/fs.mk
index dd29fc7b37..63bd9ffedb 100644
--- a/package/kernel/modules/fs.mk
+++ b/package/kernel/modules/fs.mk
@@ -53,6 +53,28 @@ define KernelPackage/fs-hfsplus
endef
$(eval $(call KernelPackage,fs-hfsplus))
+define KernelPackage/fs-isofs
+ TITLE:=ISO9660 filesystem support
+ DESCRIPTION:=Kernel module for ISO9660 filesystem support
+ DEPENDS:=+kmod-nls-base
+ KCONFIG:=$(CONFIG_ISO9660_FS)
+ SUBMENU:=$(FSMENU)
+ AUTOLOAD:=$(call AutoLoad,30,isofs)
+ FILES:=$(MODULES_DIR)/kernel/fs/isofs/isofs.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,fs-isofs))
+
+define KernelPackage/fs-udf
+ TITLE:=UDF filesystem support
+ DESCRIPTION:=Kernel module for UDF filesystem support
+ DEPENDS:=+kmod-nls-base
+ KCONFIG:=$(CONFIG_UDF_FS)
+ SUBMENU:=$(FSMENU)
+ AUTOLOAD:=$(call AutoLoad,30,udf)
+ FILES:=$(MODULES_DIR)/kernel/fs/udf/udf.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,fs-udf))
+
define KernelPackage/fs-nfs
TITLE:=NFS filesystem support
DESCRIPTION:=Kernel module for NFS support
diff --git a/target/linux/aruba-2.6/config b/target/linux/aruba-2.6/config
index 87808a05e8..2f15809db9 100644
--- a/target/linux/aruba-2.6/config
+++ b/target/linux/aruba-2.6/config
@@ -1341,8 +1341,12 @@ CONFIG_MINIX_FS=m
#
# CD-ROM/DVD Filesystems
#
-# CONFIG_ISO9660_FS is not set
-# CONFIG_UDF_FS is not set
+CONFIG_ISO9660_FS=m
+CONFIG_JOLIET=y
+CONFIG_ZISOFS=y
+CONFIG_ZISOFS_FS=m
+CONFIG_UDF_FS=m
+CONFIG_UDF_NLS=y
#
# DOS/FAT/NT Filesystems
diff --git a/target/linux/au1000-2.6/config b/target/linux/au1000-2.6/config
index a61ca766a7..cbef01f233 100644
--- a/target/linux/au1000-2.6/config
+++ b/target/linux/au1000-2.6/config
@@ -1401,8 +1401,12 @@ CONFIG_DNOTIFY=y
#
# CD-ROM/DVD Filesystems
#
-# CONFIG_ISO9660_FS is not set
-# CONFIG_UDF_FS is not set
+CONFIG_ISO9660_FS=m
+CONFIG_JOLIET=y
+CONFIG_ZISOFS=y
+CONFIG_ZISOFS_FS=m
+CONFIG_UDF_FS=m
+CONFIG_UDF_NLS=y
#
# DOS/FAT/NT Filesystems
diff --git a/target/linux/brcm-2.6/config b/target/linux/brcm-2.6/config
index f9a93138db..013fe28b85 100644
--- a/target/linux/brcm-2.6/config
+++ b/target/linux/brcm-2.6/config
@@ -1525,8 +1525,12 @@ CONFIG_INOTIFY=y
#
# CD-ROM/DVD Filesystems
#
-# CONFIG_ISO9660_FS is not set
-# CONFIG_UDF_FS is not set
+CONFIG_ISO9660_FS=m
+CONFIG_JOLIET=y
+CONFIG_ZISOFS=y
+CONFIG_ZISOFS_FS=m
+CONFIG_UDF_FS=m
+CONFIG_UDF_NLS=y
#
# DOS/FAT/NT Filesystems
diff --git a/target/linux/brcm63xx-2.6/config b/target/linux/brcm63xx-2.6/config
index af535a9025..69392d3290 100644
--- a/target/linux/brcm63xx-2.6/config
+++ b/target/linux/brcm63xx-2.6/config
@@ -1413,8 +1413,12 @@ CONFIG_DNOTIFY=y
#
# CD-ROM/DVD Filesystems
#
-# CONFIG_ISO9660_FS is not set
-# CONFIG_UDF_FS is not set
+CONFIG_ISO9660_FS=m
+CONFIG_JOLIET=y
+CONFIG_ZISOFS=y
+CONFIG_ZISOFS_FS=m
+CONFIG_UDF_FS=m
+CONFIG_UDF_NLS=y
#
# DOS/FAT/NT Filesystems
diff --git a/target/linux/ixp4xx-2.6/config b/target/linux/ixp4xx-2.6/config
index 3e24c07b54..2b6f2ae164 100644
--- a/target/linux/ixp4xx-2.6/config
+++ b/target/linux/ixp4xx-2.6/config
@@ -1175,8 +1175,12 @@ CONFIG_DNOTIFY=y
#
# CD-ROM/DVD Filesystems
#
-# CONFIG_ISO9660_FS is not set
-# CONFIG_UDF_FS is not set
+CONFIG_ISO9660_FS=m
+CONFIG_JOLIET=y
+CONFIG_ZISOFS=y
+CONFIG_ZISOFS_FS=m
+CONFIG_UDF_FS=m
+CONFIG_UDF_NLS=y
#
# DOS/FAT/NT Filesystems
diff --git a/target/linux/magicbox-2.6/config b/target/linux/magicbox-2.6/config
index b3a00fc3c0..af6e02b973 100644
--- a/target/linux/magicbox-2.6/config
+++ b/target/linux/magicbox-2.6/config
@@ -960,8 +960,12 @@ CONFIG_MINIX_FS=m
#
# CD-ROM/DVD Filesystems
#
-# CONFIG_ISO9660_FS is not set
-# CONFIG_UDF_FS is not set
+CONFIG_ISO9660_FS=m
+CONFIG_JOLIET=y
+CONFIG_ZISOFS=y
+CONFIG_ZISOFS_FS=m
+CONFIG_UDF_FS=m
+CONFIG_UDF_NLS=y
#
# DOS/FAT/NT Filesystems
diff --git a/target/linux/rb532-2.6/config b/target/linux/rb532-2.6/config
index 3f081699a1..87ca4b1c56 100644
--- a/target/linux/rb532-2.6/config
+++ b/target/linux/rb532-2.6/config
@@ -1083,8 +1083,12 @@ CONFIG_INOTIFY=y
#
# CD-ROM/DVD Filesystems
#
-# CONFIG_ISO9660_FS is not set
-# CONFIG_UDF_FS is not set
+CONFIG_ISO9660_FS=m
+CONFIG_JOLIET=y
+CONFIG_ZISOFS=y
+CONFIG_ZISOFS_FS=m
+CONFIG_UDF_FS=m
+CONFIG_UDF_NLS=y
#
# DOS/FAT/NT Filesystems
diff --git a/target/linux/rdc-2.6/config b/target/linux/rdc-2.6/config
index 4932d1f1d2..9f97870b3d 100644
--- a/target/linux/rdc-2.6/config
+++ b/target/linux/rdc-2.6/config
@@ -1244,8 +1244,12 @@ CONFIG_INOTIFY=y
#
# CD-ROM/DVD Filesystems
#
-# CONFIG_ISO9660_FS is not set
-# CONFIG_UDF_FS is not set
+CONFIG_ISO9660_FS=m
+CONFIG_JOLIET=y
+CONFIG_ZISOFS=y
+CONFIG_ZISOFS_FS=m
+CONFIG_UDF_FS=m
+CONFIG_UDF_NLS=y
#
# DOS/FAT/NT Filesystems
diff --git a/target/linux/sibyte-2.6/config b/target/linux/sibyte-2.6/config
index 64566712a4..17a6a8fc23 100644
--- a/target/linux/sibyte-2.6/config
+++ b/target/linux/sibyte-2.6/config
@@ -1091,8 +1091,12 @@ CONFIG_INOTIFY=y
#
# CD-ROM/DVD Filesystems
#
-# CONFIG_ISO9660_FS is not set
-# CONFIG_UDF_FS is not set
+CONFIG_ISO9660_FS=m
+CONFIG_JOLIET=y
+CONFIG_ZISOFS=y
+CONFIG_ZISOFS_FS=m
+CONFIG_UDF_FS=m
+CONFIG_UDF_NLS=y
#
# DOS/FAT/NT Filesystems
diff --git a/target/linux/uml-2.6/config b/target/linux/uml-2.6/config
index 076cac0fb3..fe6d614bf4 100644
--- a/target/linux/uml-2.6/config
+++ b/target/linux/uml-2.6/config
@@ -647,9 +647,10 @@ CONFIG_AUTOFS4_FS=m
#
# CD-ROM/DVD Filesystems
#
-CONFIG_ISO9660_FS=y
+CONFIG_ISO9660_FS=m
CONFIG_JOLIET=y
-# CONFIG_ZISOFS is not set
+CONFIG_ZISOFS=y
+CONFIG_ZISOFS_FS=m
CONFIG_UDF_FS=m
CONFIG_UDF_NLS=y
diff --git a/target/linux/x86-2.6/config b/target/linux/x86-2.6/config
index 3b5c0f2ecb..89011654db 100644
--- a/target/linux/x86-2.6/config
+++ b/target/linux/x86-2.6/config
@@ -1851,8 +1851,12 @@ CONFIG_INOTIFY=y
#
# CD-ROM/DVD Filesystems
#
-# CONFIG_ISO9660_FS is not set
-# CONFIG_UDF_FS is not set
+CONFIG_ISO9660_FS=m
+CONFIG_JOLIET=y
+CONFIG_ZISOFS=y
+CONFIG_ZISOFS_FS=m
+CONFIG_UDF_FS=m
+CONFIG_UDF_NLS=y
#
# DOS/FAT/NT Filesystems