aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-07-27 17:44:56 +0000
committerJonas Gorski <jogo@openwrt.org>2014-07-27 17:44:56 +0000
commit7de23d1c3c3fb9990bcbf826f39acf7f976e6f42 (patch)
tree7e1a31b1676ad4a8dd5bab5557cb000883563d05
parentdec33c39bfc8ddd67b91c4222c1ac6bbb0e418f0 (diff)
downloadupstream-7de23d1c3c3fb9990bcbf826f39acf7f976e6f42.tar.gz
upstream-7de23d1c3c3fb9990bcbf826f39acf7f976e6f42.tar.bz2
upstream-7de23d1c3c3fb9990bcbf826f39acf7f976e6f42.zip
brcm63xx: Add support for Huawei HG520v
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41851 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rwxr-xr-xtarget/linux/brcm63xx/base-files/etc/uci-defaults/02_network3
-rwxr-xr-xtarget/linux/brcm63xx/base-files/lib/brcm63xx.sh5
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile3
-rw-r--r--target/linux/brcm63xx/patches-3.10/565-board_hw520.patch60
-rw-r--r--target/linux/brcm63xx/patches-3.14/565-board_hw520.patch60
5 files changed, 130 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network b/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
index 964f5baa2a..97ef3e82f2 100755
--- a/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
+++ b/target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
@@ -70,7 +70,8 @@ HW556*)
;;
NB4-* |\
-DVG3810BN)
+DVG3810BN |\
+HW6358GW_B)
ucidef_set_interfaces_lan_wan "eth1.1" "eth0"
ucidef_add_switch "eth1" "1" "1"
ucidef_add_switch_vlan "eth1" "1" "0 1 2 3 4 5t"
diff --git a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
index 1029fe36aa..d5784db750 100755
--- a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
+++ b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
@@ -131,6 +131,11 @@ brcm63xx_detect() {
brcm63xx_has_reset_button="true"
ifname=eth0
;;
+ HW6358GW_B)
+ status_led="HW520:green:net"
+ brcm63xx_has_reset_button="true"
+ ifname="eth0"
+ ;;
NB6)
brcm63xx_has_reset_button="true"
ifname=eth0
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 680cf975db..dbda363795 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -310,6 +310,9 @@ define Image/Build
# T-Com Speedport W 500V
$(call Image/Build/CFEFIXUP,$(1),96348GW,SPW500V,6348,SPW500V)
+ # Huawei HW520
+ $(call Image/Build/CFE,$(1),HW6358GW_B,6358,HW520,EchoLife_HG520v)
+
#HW553
$(call Image/Build/CFEHW553,$(1),HW553,6358,0x20000,HW553)
diff --git a/target/linux/brcm63xx/patches-3.10/565-board_hw520.patch b/target/linux/brcm63xx/patches-3.10/565-board_hw520.patch
new file mode 100644
index 0000000000..d1b1641322
--- /dev/null
+++ b/target/linux/brcm63xx/patches-3.10/565-board_hw520.patch
@@ -0,0 +1,60 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -3428,6 +3428,49 @@ static struct board_info __initdata boar
+ .num_spis = ARRAY_SIZE(ct6373_spi_devices),
+ };
+
++static struct board_info __initdata board_HW520 = {
++ .name = "HW6358GW_B",
++ .expected_cpu_id = 0x6358,
++
++ .has_uart0 = 1,
++ .has_pci = 1,
++ .has_ohci0 = 1,
++ .has_ehci0 = 1,
++
++ .has_enet0 = 1,
++ .enet0 = {
++ .has_phy = 1,
++ .use_internal_phy = 1,
++ },
++
++ .has_enet1 = 1,
++ .enet1 = {
++ .has_phy = 1,
++ .phy_id = 0,
++ .force_speed_100 = 1,
++ .force_duplex_full = 1,
++ },
++
++ .leds = {
++ {
++ .name = "HW520:green:net",
++ .gpio = 32,
++ .active_low = 1,
++ },
++ },
++
++ .buttons = {
++ {
++ .desc = "reset",
++ .gpio = 37,
++ .active_low = 1,
++ .type = EV_KEY,
++ .code = KEY_RESTART,
++ .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++ },
++ },
++};
++
+ static struct board_info __initdata board_HW553 = {
+ .name = "HW553",
+ .expected_cpu_id = 0x6358,
+@@ -5175,6 +5218,7 @@ static const struct board_info __initcon
+ &board_nb4_fxc_r1,
+ &board_nb4_fxc_r2,
+ &board_ct6373_1,
++ &board_HW520,
+ &board_HW553,
+ &board_HW556,
+ &board_HW556_A,
diff --git a/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch b/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
new file mode 100644
index 0000000000..aae5845d27
--- /dev/null
+++ b/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
@@ -0,0 +1,60 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -3438,6 +3438,49 @@ static struct board_info __initdata boar
+ .num_spis = ARRAY_SIZE(ct6373_spi_devices),
+ };
+
++static struct board_info __initdata board_HW520 = {
++ .name = "HW6358GW_B",
++ .expected_cpu_id = 0x6358,
++
++ .has_uart0 = 1,
++ .has_pci = 1,
++ .has_ohci0 = 1,
++ .has_ehci0 = 1,
++
++ .has_enet0 = 1,
++ .enet0 = {
++ .has_phy = 1,
++ .use_internal_phy = 1,
++ },
++
++ .has_enet1 = 1,
++ .enet1 = {
++ .has_phy = 1,
++ .phy_id = 0,
++ .force_speed_100 = 1,
++ .force_duplex_full = 1,
++ },
++
++ .leds = {
++ {
++ .name = "HW520:green:net",
++ .gpio = 32,
++ .active_low = 1,
++ },
++ },
++
++ .buttons = {
++ {
++ .desc = "reset",
++ .gpio = 37,
++ .active_low = 1,
++ .type = EV_KEY,
++ .code = KEY_RESTART,
++ .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++ },
++ },
++};
++
+ static struct board_info __initdata board_HW553 = {
+ .name = "HW553",
+ .expected_cpu_id = 0x6358,
+@@ -5185,6 +5228,7 @@ static const struct board_info __initcon
+ &board_nb4_fxc_r1,
+ &board_nb4_fxc_r2,
+ &board_ct6373_1,
++ &board_HW520,
+ &board_HW553,
+ &board_HW556,
+ &board_HW556_A,