aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-11 01:29:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-11 01:29:11 +0000
commit7cb42738e6d60df76ca64ee3d569e28454521c97 (patch)
tree3b10186c049d6ffaed5c4d17847a37e0279554fb
parent6ca6d317b38fcef792e4564b69d9a5aefc98c85d (diff)
downloadupstream-7cb42738e6d60df76ca64ee3d569e28454521c97.tar.gz
upstream-7cb42738e6d60df76ca64ee3d569e28454521c97.tar.bz2
upstream-7cb42738e6d60df76ca64ee3d569e28454521c97.zip
package/index: filter out the libc package from the index
SVN-Revision: 32187
-rwxr-xr-xscripts/ipkg-make-index.sh1
-rw-r--r--target/imagebuilder/files/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/scripts/ipkg-make-index.sh b/scripts/ipkg-make-index.sh
index 31b4327da3..cbfa450c0a 100755
--- a/scripts/ipkg-make-index.sh
+++ b/scripts/ipkg-make-index.sh
@@ -14,6 +14,7 @@ for pkg in `find $pkg_dir -name '*.ipk' | sort`; do
name="${pkg##*/}"
name="${name%%_*}"
[[ "$name" = "kernel" ]] && continue
+ [[ "$name" = "libc" ]] && continue
echo "Generating index for package $pkg" >&2
file_size=$(ls -l $pkg | awk '{print $5}')
md5sum=$(md5sum $pkg | awk '{print $1}')
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index 803252b4b6..b0d0698acd 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -126,6 +126,7 @@ package_index: FORCE
package_install: FORCE
@echo
@echo Installing packages...
+ $(OPKG) install $(PACKAGE_DIR)/libc_*.ipk
$(OPKG) install $(PACKAGE_DIR)/kernel_*.ipk
$(OPKG) install $(BUILD_PACKAGES)
rm -f $(TARGET_DIR)/usr/lib/opkg/lists/*