aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-11-25 14:35:49 +0100
committerDaniel Golle <daniel@makrotopia.org>2018-11-25 15:24:49 +0100
commit7c4251d88172489a3cdb94529f0d99bf2ab904d8 (patch)
treef07b8de079559ab0d6a6a76873d9cc3cdd6ab5ce
parent51c094e7032b45522cc7060858196881e161e615 (diff)
downloadupstream-7c4251d88172489a3cdb94529f0d99bf2ab904d8.tar.gz
upstream-7c4251d88172489a3cdb94529f0d99bf2ab904d8.tar.bz2
upstream-7c4251d88172489a3cdb94529f0d99bf2ab904d8.zip
ramips: select kmod-mt76x0e for TP-Link ArcherC20i and wr902ac-v3
Both devices come with a MediaTek MT7610E 5GHz 802.11ac 1T1R radio which wasn't supported at the time the devices were added to OpenWrt. Now that we got it, include kmod-mt76x0e in images for those devices. Reported-by: Arian Sanusi <openwrt@semioptimal.net> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--target/linux/ramips/image/mt7620.mk1
-rw-r--r--target/linux/ramips/image/mt76x8.mk2
2 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index b0d2b2a8f9..b5d73f60c7 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -49,6 +49,7 @@ define Device/ArcherC20i
TPLINK_HWID := 0xc2000001
TPLINK_HWREV := 58
IMAGES += factory.bin
+ DEVICE_PACKAGES := kmod-mt76x0e
DEVICE_TITLE := TP-Link ArcherC20i
endef
TARGET_DEVICES += ArcherC20i
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 16fbad2bbc..6bedb4f7d4 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -283,7 +283,7 @@ define Device/tplink_tl-wr902ac-v3
TPLINK_HWREV := 0x89
TPLINK_HWREVADD := 0x1
TPLINK_HVERSION := 3
- DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := kmod-mt76x0e kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += tplink_tl-wr902ac-v3