aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2017-11-07 09:45:52 +0100
committerFelix Fietkau <nbd@nbd.name>2017-12-08 19:41:18 +0100
commit7b5c989ab9bcd0c1346b7b90b8433216f7b20b71 (patch)
treebbafa6432bc6385d66f880602819878b2f076c18
parentbf5cef47b38c0b119dc84a78919944e21d5c4092 (diff)
downloadupstream-7b5c989ab9bcd0c1346b7b90b8433216f7b20b71.tar.gz
upstream-7b5c989ab9bcd0c1346b7b90b8433216f7b20b71.tar.bz2
upstream-7b5c989ab9bcd0c1346b7b90b8433216f7b20b71.zip
merge: targets: update image generation and targets
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
-rw-r--r--include/image-commands.mk6
-rw-r--r--include/image.mk2
-rw-r--r--package/boot/uboot-layerscape-armv8_32b/Makefile2
-rwxr-xr-xscripts/brcmImage.pl2
-rwxr-xr-xscripts/qemustart12
-rw-r--r--target/imagebuilder/Config.in2
-rw-r--r--target/linux/apm821xx/image/Makefile2
-rw-r--r--target/linux/ar71xx/image/generic.mk4
-rw-r--r--target/linux/ar71xx/image/legacy.mk4
-rw-r--r--target/linux/ar71xx/image/tp-link.mk2
-rw-r--r--target/linux/armvirt/README16
-rw-r--r--target/linux/brcm63xx/image/bcm63xx.mk6
-rw-r--r--target/linux/lantiq/image/Makefile2
-rw-r--r--target/linux/mcs814x/image/Makefile2
-rw-r--r--target/linux/mvebu/image/cfbase-boot.script4
-rw-r--r--target/linux/mvebu/image/cfpro-boot.script4
-rw-r--r--target/linux/uml/README5
-rw-r--r--target/linux/x86/image/grub-iso.cfg2
-rw-r--r--target/linux/x86/image/grub.cfg4
-rw-r--r--target/sdk/Config.in4
-rw-r--r--target/sdk/files/README.SDK4
-rw-r--r--target/toolchain/Config.in6
22 files changed, 49 insertions, 48 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 8db046bdea..5f0ac6164d 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -7,7 +7,7 @@ define Build/uImage
mkimage -A $(LINUX_KARCH) \
-O linux -T kernel \
-C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION))' -d $@ $@.new
+ -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION))' -d $@ $@.new
mv $@.new $@
endef
@@ -60,7 +60,7 @@ endef
define Build/netgear-dni
$(STAGING_DIR_HOST)/bin/mkdniimg \
- -B $(NETGEAR_BOARD_ID) -v LEDE.$(REVISION) \
+ -B $(NETGEAR_BOARD_ID) -v OpenWrt.$(REVISION) \
$(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
-r "$(1)" \
-i $@ -o $@.new
@@ -83,7 +83,7 @@ define Build/append-uImage-fakeroot-hdr
rm -f $@.fakeroot
$(STAGING_DIR_HOST)/bin/mkimage \
-A $(LINUX_KARCH) -O linux -T filesystem -C none \
- -n '$(call toupper,$(LINUX_KARCH)) LEDE fakeroot' \
+ -n '$(call toupper,$(LINUX_KARCH)) OpenWrt fakeroot' \
-s \
$@.fakeroot
cat $@.fakeroot >> $@
diff --git a/include/image.mk b/include/image.mk
index f4d0a157cd..605cb06672 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -136,7 +136,7 @@ endef
define Image/BuildKernel/MkuImage
mkimage -A $(ARCH) -O linux -T kernel -C $(1) -a $(2) -e $(3) \
- -n '$(call toupper,$(ARCH)) LEDE Linux-$(LINUX_VERSION)' -d $(4) $(5)
+ -n '$(call toupper,$(ARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $(4) $(5)
endef
define Image/BuildKernel/MkFIT
diff --git a/package/boot/uboot-layerscape-armv8_32b/Makefile b/package/boot/uboot-layerscape-armv8_32b/Makefile
index 0f1ee08fc1..8427bee845 100644
--- a/package/boot/uboot-layerscape-armv8_32b/Makefile
+++ b/package/boot/uboot-layerscape-armv8_32b/Makefile
@@ -12,7 +12,7 @@ PKG_VERSION:=2017.09
PKG_RELEASE:=1
# Layerscape ARMv8 platforms use 64-bit u-boot to support both 32-bit and 64-bit
-# kernel/rootfs. Since LEDE could only provide 32-bit toolchain for 32-bit targets,
+# kernel/rootfs. Since OpenWrt could only provide 32-bit toolchain for 32-bit targets,
# 64-bit u-boot images git tree is provided here whose source code actually is
# uboot-layerscape's source code.
PKG_SOURCE_PROTO:=git
diff --git a/scripts/brcmImage.pl b/scripts/brcmImage.pl
index aab86d6d91..60a59f2bf5 100755
--- a/scripts/brcmImage.pl
+++ b/scripts/brcmImage.pl
@@ -33,7 +33,7 @@ use Compress::Zlib;
my $version = "0.1";
my %arg = (
o => 'bcm963xx_fs_kernel',
- b => 'LEDE',
+ b => 'OpenWrt',
c => '6348',
s => 64,
f => 0xbfc00000,
diff --git a/scripts/qemustart b/scripts/qemustart
index 5cadd7d6a8..6c2254e3af 100755
--- a/scripts/qemustart
+++ b/scripts/qemustart
@@ -107,8 +107,8 @@ Examples
$SELF malta le64
$SELF malta be-glibc
$SELF armvirt 32 \\
- --kernel bin/targets/armvirt/32/lede-armvirt-32-zImage \\
- --rootfs bin/targets/armvirt/32/lede-armvirt-32-root.ext4
+ --kernel bin/targets/armvirt/32/openwrt-armvirt-32-zImage \\
+ --rootfs bin/targets/armvirt/32/openwrt-armvirt-32-root.ext4
EOF
}
@@ -158,12 +158,12 @@ start_qemu_armvirt() {
32)
qemu_exe="qemu-system-arm"
cpu="cortex-a15"
- [ -n "$kernel" ] || kernel="$o_bindir/lede-$o_target-${o_subtarget%-*}-zImage-initramfs"
+ [ -n "$kernel" ] || kernel="$o_bindir/openwrt-$o_target-${o_subtarget%-*}-zImage-initramfs"
;;
64)
qemu_exe="qemu-system-aarch64"
cpu="cortex-a57"
- [ -n "$kernel" ] || kernel="$o_bindir/lede-$o_target-${o_subtarget%-*}-Image-initramfs"
+ [ -n "$kernel" ] || kernel="$o_bindir/openwrt-$o_target-${o_subtarget%-*}-Image-initramfs"
;;
*)
__errmsg "target $o_target: unknown subtarget $o_subtarget"
@@ -199,7 +199,7 @@ start_qemu_malta() {
[ "$(echo "$o_subtarget" | grep -o '^..')" = "le" ] && isel="el"
qemu_exe="qemu-system-mips$is64$isel"
- [ -n "$kernel" ] || kernel="$o_bindir/lede-malta-${o_subtarget%-*}-vmlinux-initramfs.elf"
+ [ -n "$kernel" ] || kernel="$o_bindir/openwrt-malta-${o_subtarget%-*}-vmlinux-initramfs.elf"
# NOTE: order of wan, lan -device arguments matters as it will affect which
# one will be actually used as the wan, lan network interface inside the
@@ -216,7 +216,7 @@ start_qemu_x86() {
local qemu_exe
[ -n "$rootfs" ] || {
- rootfs="$o_bindir/lede-$o_target-${o_subtarget%-*}-combined-ext4.img"
+ rootfs="$o_bindir/openwrt-$o_target-${o_subtarget%-*}-combined-ext4.img"
if [ ! -f "$rootfs" -a -s "$rootfs.gz" ]; then
gunzip "$rootfs.gz"
fi
diff --git a/target/imagebuilder/Config.in b/target/imagebuilder/Config.in
index 49bb741f73..c1a5212f6d 100644
--- a/target/imagebuilder/Config.in
+++ b/target/imagebuilder/Config.in
@@ -1,5 +1,5 @@
config IB
- bool "Build the LEDE Image Builder"
+ bool "Build the OpenWrt Image Builder"
depends on !EXTERNAL_TOOLCHAIN
default BUILDBOT
help
diff --git a/target/linux/apm821xx/image/Makefile b/target/linux/apm821xx/image/Makefile
index 6ed183c376..ee85292d57 100644
--- a/target/linux/apm821xx/image/Makefile
+++ b/target/linux/apm821xx/image/Makefile
@@ -116,7 +116,7 @@ define Build/create-uImage-dtb
# flat_dt target expect FIT image - which WNDR4700's uboot doesn't support
-$(STAGING_DIR_HOST)/bin/mkimage -A $(LINUX_KARCH) \
-O linux -T kernel -C none \
- -n '$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' \
+ -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' \
-d $(IMAGE_KERNEL).dtb $@.new
@mv $@.new $@
endef
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index eb6d6e5342..c0d9fdd0d6 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -12,7 +12,7 @@ define Build/mkwrggimg
$(STAGING_DIR_HOST)/bin/mkwrggimg -b \
-i $@ -o $@.imghdr -d /dev/mtdblock/1 \
-m $(BOARDNAME) -s $(DAP_SIGNATURE) \
- -v LEDE -B $(REVISION)
+ -v OpenWrt -B $(REVISION)
mv $@.imghdr $@
endef
@@ -66,7 +66,7 @@ define Build/uImageHiWiFi
mkimage -A $(LINUX_KARCH) \
-O linux -T kernel \
-C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' -d $@ $@.new
+ -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
@mv $@.new $@
endef
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index 701116be43..01d7e50631 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -485,11 +485,11 @@ define Image/Build/Belkin
$(eval rootsize=$(call mtdpartsize,rootfs,$(4)))
$(call Sysupgrade/RKuImage,$(1),$(2),$(kernsize),$(rootsize))
if [ -e "$(call sysupname,$(1),$(2))" ]; then \
- edimax_fw_header -m $(5) -v "$(shell echo -n LEDE$(REVISION) | cut -c -13)" \
+ edimax_fw_header -m $(5) -v "$(shell echo -n OpenWrt$(REVISION) | cut -c -13)" \
-n "uImage" \
-i $(KDIR_TMP)/vmlinux-$(2).uImage \
-o $(KDIR_TMP)/$(2)-uImage; \
- edimax_fw_header -m $(5) -v "$(shell echo -n LEDE$(REVISION) | cut -c -13)" \
+ edimax_fw_header -m $(5) -v "$(shell echo -n OpenWrt$(REVISION) | cut -c -13)" \
-n "rootfs" \
-i $(KDIR)/root.$(1) \
-o $(KDIR_TMP)/$(2)-rootfs; \
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index 8dd42d23d0..f21d0d7f79 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -39,7 +39,7 @@ define Build/uImageArcher
mkimage -A $(LINUX_KARCH) \
-O linux -T kernel \
-C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n '$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' -d $@ $@.new
+ -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
@mv $@.new $@
endef
diff --git a/target/linux/armvirt/README b/target/linux/armvirt/README
index fba71a62f2..ae0d2ada62 100644
--- a/target/linux/armvirt/README
+++ b/target/linux/armvirt/README
@@ -4,18 +4,18 @@ QEMU ARM virt machine.
Run with qemu-system-arm
# boot with initramfs embedded in
- qemu-system-arm -nographic -M virt -m 64 -kernel lede-armvirt-32-zImage-initramfs
+ qemu-system-arm -nographic -M virt -m 64 -kernel openwrt-armvirt-32-zImage-initramfs
# boot with accel=kvm
qemu-system-arm -nographic -M virt,accel=kvm -cpu host -m 64 -kernel
- lede-armvirt-32-zImage-initramfs
+ openwrt-armvirt-32-zImage-initramfs
# boot with a separate rootfs
- qemu-system-arm -nographic -M virt -m 64 -kernel lede-armvirt-32-zImage \
- -drive file=lede-armvirt-32-root.ext4,format=raw,if=virtio -append 'root=/dev/vda rootwait'
+ qemu-system-arm -nographic -M virt -m 64 -kernel openwrt-armvirt-32-zImage \
+ -drive file=openwrt-armvirt-32-root.ext4,format=raw,if=virtio -append 'root=/dev/vda rootwait'
# boot with local dir as rootfs
- qemu-system-arm -nographic -M virt -m 64 -kernel lede-armvirt-32-zImage \
+ qemu-system-arm -nographic -M virt -m 64 -kernel openwrt-armvirt-32-zImage \
-fsdev local,id=rootdev,path=root-armvirt/,security_model=none \
-device virtio-9p-pci,fsdev=rootdev,mount_tag=/dev/root \
-append 'rootflags=trans=virtio,version=9p2000.L,cache=loose rootfstype=9p'
@@ -23,10 +23,10 @@ Run with qemu-system-arm
Run with kvmtool
# start a named machine
- lkvm run -k lede-armvirt-32-zImage -i lede-armvirt-32-rootfs.cpio --name armvirt0
+ lkvm run -k openwrt-armvirt-32-zImage -i openwrt-armvirt-32-rootfs.cpio --name armvirt0
# start with virtio-9p rootfs
- lkvm run -k lede-armvirt-32-zImage -d root-armvirt/
+ lkvm run -k openwrt-armvirt-32-zImage -d root-armvirt/
# stop "armvirt0"
lkvm stop --name armvirt0
@@ -37,4 +37,4 @@ Run with kvmtool
The multi-platform ARMv8 target can be used with QEMU:
qemu-system-aarch64 -machine virt -cpu cortex-a57 -nographic \
- -kernel lede-armvirt-64-Image-initramfs \
+ -kernel openwrt-armvirt-64-Image-initramfs \
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index 6ad15a25e7..4e90eb0504 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -978,7 +978,7 @@ define Device/NEUFBOX4-SER
DEVICE_DTS := nb4-ser-r0
CFE_BOARD_ID := 96358VW
CFE_CHIP_ID := 6358
- CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
+ CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef
@@ -990,7 +990,7 @@ define Device/NEUFBOX4-FXC
DEVICE_DTS := nb4-fxc-r1
CFE_BOARD_ID := 96358VW
CFE_CHIP_ID := 6358
- CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
+ CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef
@@ -1002,7 +1002,7 @@ define Device/NEUFBOX6
DEVICE_DTS := nb6-ser-r0
CFE_BOARD_ID := NB6-SER-r0
CFE_CHIP_ID := 6362
- CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
+ CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 9326c62d42..f6795ee61a 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -39,7 +39,7 @@ endef
define Build/fullimage
mkimage -A mips -O linux -C lzma -T filesystem -a 0x00 \
- -e 0x00 -n 'LEDE RootFS' \
+ -e 0x00 -n 'OpenWrt RootFS' \
-d $(IMAGE_ROOTFS) $(IMAGE_ROOTFS).new
cat $(IMAGE_KERNEL) $(IMAGE_ROOTFS).new > $@.tmp
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 7be7f8cd99..3afd660c14 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -20,7 +20,7 @@ UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
define Image/Build/MkuImage
mkimage -A arm -O linux -T kernel -a $(LOADADDR) -C none -e $(LOADADDR) \
- -n 'ARM LEDE Linux-$(LINUX_VERSION)' -d $(1) $(2);
+ -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(1) $(2);
endef
define Image/Build/DTB
diff --git a/target/linux/mvebu/image/cfbase-boot.script b/target/linux/mvebu/image/cfbase-boot.script
index 5f9bcd70ba..89fa1dc578 100644
--- a/target/linux/mvebu/image/cfbase-boot.script
+++ b/target/linux/mvebu/image/cfbase-boot.script
@@ -9,8 +9,8 @@ setenv fdtfile armada-388-clearfog-base.dtb
# generate bootargs for rootfs on MMC
if test "${devtype}" = "mmc"; then
- setexpr lede_rootpart ${distro_bootpart} + 1
- setenv bootargs ${bootargs} root=/dev/mmcblk${devnum}p${lede_rootpart} rootfstype=auto rootwait
+ setexpr openwrt_rootpart ${distro_bootpart} + 1
+ setenv bootargs ${bootargs} root=/dev/mmcblk${devnum}p${openwrt_rootpart} rootfstype=auto rootwait
fi
# here one could add logic for other rootfs device types such as scsi and usb
diff --git a/target/linux/mvebu/image/cfpro-boot.script b/target/linux/mvebu/image/cfpro-boot.script
index e1523f8fb3..1588c1546e 100644
--- a/target/linux/mvebu/image/cfpro-boot.script
+++ b/target/linux/mvebu/image/cfpro-boot.script
@@ -5,8 +5,8 @@
# generate bootargs for rootfs on MMC
if test "${devtype}" = "mmc"; then
- setexpr lede_rootpart ${distro_bootpart} + 1
- setenv bootargs ${bootargs} root=/dev/mmcblk${devnum}p${lede_rootpart} rootfstype=auto rootwait
+ setexpr openwrt_rootpart ${distro_bootpart} + 1
+ setenv bootargs ${bootargs} root=/dev/mmcblk${devnum}p${openwrt_rootpart} rootfstype=auto rootwait
fi
# here one could add logic for other rootfs device types such as scsi and usb
diff --git a/target/linux/uml/README b/target/linux/uml/README
index d7cba1de9c..aa7bad91ae 100644
--- a/target/linux/uml/README
+++ b/target/linux/uml/README
@@ -1,4 +1,4 @@
-LEDE inside a user mode linux. Why would we even want this many ask?
+OpenWrt inside a user mode linux. Why would we even want this many ask?
There are potentially a lot of reasons, one obvious one to me, it allows
folks to 'kick the tires' without actually flashing up any hardware. It's
@@ -17,7 +17,8 @@ build it all
In your bin directory you will find a kernel and an ext4 root file system
when it's finished. Just run it like this:-
-bin/targets/uml/generic/lede-uml-vmlinux ubd0=bin/targets/uml/generic/lede-uml-ext4.img
+bin/targets/uml/generic/lede-uml-vmlinux
+ubd0=bin/targets/uml/generic/openwrt-uml-ext4.img
The uml will start, and eventually the serial console of the uml will be at your
console prompt. If you would like it in xterms, substitute con=xterm and con0=xterm.
diff --git a/target/linux/x86/image/grub-iso.cfg b/target/linux/x86/image/grub-iso.cfg
index 32ee687c68..3d47a95a4b 100644
--- a/target/linux/x86/image/grub-iso.cfg
+++ b/target/linux/x86/image/grub-iso.cfg
@@ -5,6 +5,6 @@ set default="0"
set timeout="@TIMEOUT@"
set root='(cd)'
-menuentry "LEDE" {
+menuentry "OpenWrt" {
linux /boot/vmlinuz @CMDLINE@ noinitrd
}
diff --git a/target/linux/x86/image/grub.cfg b/target/linux/x86/image/grub.cfg
index acca036a2e..9ec6b2d39c 100644
--- a/target/linux/x86/image/grub.cfg
+++ b/target/linux/x86/image/grub.cfg
@@ -5,9 +5,9 @@ set default="0"
set timeout="@TIMEOUT@"
set root='(@ROOT@)'
-menuentry "LEDE" {
+menuentry "OpenWrt" {
linux /boot/vmlinuz @CMDLINE@ noinitrd
}
-menuentry "LEDE (failsafe)" {
+menuentry "OpenWrt (failsafe)" {
linux /boot/vmlinuz failsafe=true @CMDLINE@ noinitrd
}
diff --git a/target/sdk/Config.in b/target/sdk/Config.in
index 095759d064..0c8a61d247 100644
--- a/target/sdk/Config.in
+++ b/target/sdk/Config.in
@@ -1,10 +1,10 @@
config SDK
- bool "Build the LEDE SDK"
+ bool "Build the OpenWrt SDK"
depends on !EXTERNAL_TOOLCHAIN
default BUILDBOT
help
This is essentially a stripped-down version of the buildroot
with a precompiled toolchain. It can be used to develop and
- test packages for LEDE before including them in the buildroot
+ test packages for OpenWrt before including them in the buildroot
diff --git a/target/sdk/files/README.SDK b/target/sdk/files/README.SDK
index 6f04f94d2c..6699dffcfb 100644
--- a/target/sdk/files/README.SDK
+++ b/target/sdk/files/README.SDK
@@ -1,7 +1,7 @@
-This is the LEDE SDK. It contains a stripped-down version of
+This is the OpenWrt SDK. It contains a stripped-down version of
the buildroot. You can use it to test/develop packages without
having to compile your own toolchain or any of the libraries
-included with LEDE.
+included with OpenWrt.
To use it, just put your buildroot-compatible package directory
(including its dependencies) in the subdir 'package/' and run
diff --git a/target/toolchain/Config.in b/target/toolchain/Config.in
index e377c20a1b..5a6ecefebb 100644
--- a/target/toolchain/Config.in
+++ b/target/toolchain/Config.in
@@ -1,8 +1,8 @@
config MAKE_TOOLCHAIN
- bool "Package the LEDE-based Toolchain"
+ bool "Package the OpenWrt-based Toolchain"
depends on !EXTERNAL_TOOLCHAIN
help
Package the created toolchain as a tarball under the bin/ directory as
- LEDE-Toolchain-$(BOARD)-for-$(ARCH)$(ARCH_SUFFIX)-gcc-$(GCCV)$(DIR_SUFFIX).
+ OpenWrt-Toolchain-$(BOARD)-for-$(ARCH)$(ARCH_SUFFIX)-gcc-$(GCCV)$(DIR_SUFFIX).
For example, a toolchain for the MIPS architecture might be named
- LEDE-Toolchain-malta-for-mipsel_mips32-gcc-4.8-linaro_uClibc-0.9.33.2.tar.bz2.
+ OpenWrt-Toolchain-malta-for-mipsel_mips32-gcc-4.8-linaro_uClibc-0.9.33.2.tar.bz2.