aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-02-27 19:52:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-02-27 19:52:43 +0000
commit7b1f833ffcf173143f49cee1f49a62c5bce00536 (patch)
treeeb8ab968e5ae2145c188a6292688fa826628f81d
parent3fd1dd08fbcbb78b34efefd32c3032e5c99108d6 (diff)
downloadupstream-7b1f833ffcf173143f49cee1f49a62c5bce00536.tar.gz
upstream-7b1f833ffcf173143f49cee1f49a62c5bce00536.tar.bz2
upstream-7b1f833ffcf173143f49cee1f49a62c5bce00536.zip
kernel: when disabling common quirks, disable them in the usb subsystem as well - bios handover is useless for most platforms
SVN-Revision: 25768
-rw-r--r--target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch12
-rw-r--r--target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch12
2 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch b/target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch
new file mode 100644
index 0000000000..49954bb567
--- /dev/null
+++ b/target/linux/generic/patches-2.6.37/031-pci_disable_usb_common_quirks.patch
@@ -0,0 +1,12 @@
+--- a/drivers/usb/host/Makefile
++++ b/drivers/usb/host/Makefile
+@@ -16,7 +16,9 @@ xhci-hcd-y += xhci-ring.o xhci-hub.o xhc
+
+ obj-$(CONFIG_USB_WHCI_HCD) += whci/
+
++ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
+ obj-$(CONFIG_PCI) += pci-quirks.o
++endif
+
+ obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
+ obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
diff --git a/target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch b/target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch
new file mode 100644
index 0000000000..49954bb567
--- /dev/null
+++ b/target/linux/generic/patches-2.6.38/031-pci_disable_usb_common_quirks.patch
@@ -0,0 +1,12 @@
+--- a/drivers/usb/host/Makefile
++++ b/drivers/usb/host/Makefile
+@@ -16,7 +16,9 @@ xhci-hcd-y += xhci-ring.o xhci-hub.o xhc
+
+ obj-$(CONFIG_USB_WHCI_HCD) += whci/
+
++ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
+ obj-$(CONFIG_PCI) += pci-quirks.o
++endif
+
+ obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
+ obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o