aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiang Yongquan <woxwchc@foxmail.com>2021-01-11 23:09:23 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-01-27 23:14:30 +0100
commit799fca7602fffd17bedea972c3fa8f0e6141c265 (patch)
tree75ce7d112dd7fc4fbcd6fa93ce28c5ea3213dcf5
parent9c29165a4cc1ab4a341ec93c60239d01535305b3 (diff)
downloadupstream-799fca7602fffd17bedea972c3fa8f0e6141c265.tar.gz
upstream-799fca7602fffd17bedea972c3fa8f0e6141c265.tar.bz2
upstream-799fca7602fffd17bedea972c3fa8f0e6141c265.zip
sunxi: add support for linksprite pcDuino3 nano board
Specifications: - SoC: Allwinner A20 @ 1Ghz - DRAM: 1GiB DDR3 @ 408MHz (K4B4G1646Q-HYK0) - NAND: 4GB MLC NAND (H27UBG8T2BTR-BC) - Ethernet: 10/100/1000Mbps Ethernet (Realtek RTL8211E) Flash instructions: dd if=openwrt-sunxi-cortexa7-linksprite_pcduino3-nano-ext4-sdcard.img of=/dev/sdX Signed-off-by: Jiang Yongquan <woxwchc@foxmail.com> [Remove CONFIG_REALTEK_PHY from sunxi/cortexa53 config] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/boot/uboot-sunxi/Makefile7
-rw-r--r--target/linux/sunxi/config-5.41
-rw-r--r--target/linux/sunxi/cortexa53/config-5.41
-rw-r--r--target/linux/sunxi/image/cortexa7.mk8
4 files changed, 16 insertions, 1 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index 859a06019b..38147339a4 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -142,6 +142,12 @@ define U-Boot/Linksprite_pcDuino3
BUILD_DEVICES:=linksprite_pcduino3
endef
+define U-Boot/Linksprite_pcDuino3_Nano
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=Linksprite pcDuino3 Nano
+ BUILD_DEVICES:=linksprite_pcduino3-nano
+endef
+
define U-Boot/Lamobo_R1
BUILD_SUBTARGET:=cortexa7
NAME:=Lamobo R1
@@ -317,6 +323,7 @@ UBOOT_TARGETS := \
OLIMEX_A13_SOM \
Linksprite_pcDuino \
Linksprite_pcDuino3 \
+ Linksprite_pcDuino3_Nano \
Lamobo_R1 \
nanopi_m1_plus \
zeropi \
diff --git a/target/linux/sunxi/config-5.4 b/target/linux/sunxi/config-5.4
index 7318d5a3e9..fba86b86ee 100644
--- a/target/linux/sunxi/config-5.4
+++ b/target/linux/sunxi/config-5.4
@@ -443,6 +443,7 @@ CONFIG_PWM_SYSFS=y
CONFIG_RATIONAL=y
CONFIG_RCU_NEED_SEGCBLIST=y
CONFIG_RCU_STALL_COMMON=y
+CONFIG_REALTEK_PHY=y
CONFIG_REFCOUNT_FULL=y
CONFIG_REGMAP=y
CONFIG_REGMAP_I2C=y
diff --git a/target/linux/sunxi/cortexa53/config-5.4 b/target/linux/sunxi/cortexa53/config-5.4
index 6e1ef22129..203ab9fa38 100644
--- a/target/linux/sunxi/cortexa53/config-5.4
+++ b/target/linux/sunxi/cortexa53/config-5.4
@@ -134,7 +134,6 @@ CONFIG_PINCTRL_SUN50I_H6=y
CONFIG_PINCTRL_SUN50I_H6_R=y
CONFIG_QUEUED_RWLOCKS=y
CONFIG_QUEUED_SPINLOCKS=y
-CONFIG_REALTEK_PHY=y
CONFIG_RODATA_FULL_DEFAULT_ENABLED=y
# CONFIG_SND_SUN50I_CODEC_ANALOG is not set
CONFIG_SOUND_OSS_CORE_PRECLAIM=y
diff --git a/target/linux/sunxi/image/cortexa7.mk b/target/linux/sunxi/image/cortexa7.mk
index d491dbc338..baa3e56b44 100644
--- a/target/linux/sunxi/image/cortexa7.mk
+++ b/target/linux/sunxi/image/cortexa7.mk
@@ -107,6 +107,14 @@ define Device/linksprite_pcduino3
endef
TARGET_DEVICES += linksprite_pcduino3
+define Device/linksprite_pcduino3-nano
+ DEVICE_VENDOR := LinkSprite
+ DEVICE_MODEL := pcDuino3 Nano
+ DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-sunxi
+ SOC := sun7i-a20
+endef
+TARGET_DEVICES += linksprite_pcduino3-nano
+
define Device/mele_m9
DEVICE_VENDOR := Mele
DEVICE_MODEL := M9