aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-03-17 19:45:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-03-17 19:45:55 +0000
commit743e9e70091ccbf3eefc5419c6432fe06be30c7d (patch)
tree65b90b5c3b38cbe6da29f9b30400e6af9ab71072
parent6a7100c760030feff14a4821c773a11812068ab0 (diff)
downloadupstream-743e9e70091ccbf3eefc5419c6432fe06be30c7d.tar.gz
upstream-743e9e70091ccbf3eefc5419c6432fe06be30c7d.tar.bz2
upstream-743e9e70091ccbf3eefc5419c6432fe06be30c7d.zip
ep93xx: account for sound soc directory rename in 3.7
sound/soc/ep93xx -> sound/soc/cirrus Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 36071
-rw-r--r--target/linux/ep93xx/modules.mk11
1 files changed, 8 insertions, 3 deletions
diff --git a/target/linux/ep93xx/modules.mk b/target/linux/ep93xx/modules.mk
index 2c62582d0e..60197e1814 100644
--- a/target/linux/ep93xx/modules.mk
+++ b/target/linux/ep93xx/modules.mk
@@ -39,13 +39,18 @@ endef
$(eval $(call KernelPackage,input-keyboard-ep93xx))
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.8.0)),1)
+SND_EP93XX_SOC_DIR:=cirrus
+else
+SND_EP93XX_SOC_DIR:=ep93xx
+endif
define KernelPackage/sound-soc-ep93xx
SUBMENU:=$(SOUND_MENU)
TITLE:=EP93xx SoC sound support
DEPENDS:=@TARGET_ep93xx +kmod-sound-soc-ac97
KCONFIG:=CONFIG_SND_EP93XX_SOC
- FILES:=$(LINUX_DIR)/sound/soc/ep93xx/snd-soc-ep93xx.ko
+ FILES:=$(LINUX_DIR)/sound/soc/$(SND_EP93XX_SOC_DIR)/snd-soc-ep93xx.ko
AUTOLOAD:=$(call AutoLoad,57,snd-soc-ep93xx)
endef
@@ -62,7 +67,7 @@ define KernelPackage/sound-soc-ep93xx-ac97
TITLE:=EP93xx SoC AC97 support
DEPENDS:=@TARGET_ep93xx +kmod-sound-soc-ep93xx
KCONFIG:=CONFIG_SND_EP93XX_SOC_AC97
- FILES:=$(LINUX_DIR)/sound/soc/ep93xx/snd-soc-ep93xx-ac97.ko
+ FILES:=$(LINUX_DIR)/sound/soc/$(SND_EP93XX_SOC_DIR)/snd-soc-ep93xx-ac97.ko
AUTOLOAD:=$(call AutoLoad,56,snd-soc-ep93xx-ac97)
endef
@@ -77,7 +82,7 @@ define KernelPackage/sound-soc-ep93xx-simone
TITLE:=Sim.One EP93xx Soc sound support
DEPENDS:=@TARGET_ep93xx +kmod-sound-soc-ep93xx +kmod-sound-soc-ep93xx-ac97
KCONFIG:=CONFIG_SND_EP93XX_SOC_SIMONE
- FILES:=$(LINUX_DIR)/sound/soc/ep93xx/snd-soc-simone.ko
+ FILES:=$(LINUX_DIR)/sound/soc/$(SND_EP93XX_SOC_DIR)/snd-soc-simone.ko
AUTOLOAD:=$(call AutoLoad,59,snd-soc-ep93xx)
endef