aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-21 16:53:22 +0000
committerJohn Crispin <john@openwrt.org>2013-06-21 16:53:22 +0000
commit740d7c103f0c17bd1ee96186184e4585cf587ec9 (patch)
treebfaf364115b193766232552a319d78e0cac3ad56
parentb0bb503c20c53f65b437b989dcb84d25f1256c09 (diff)
downloadupstream-740d7c103f0c17bd1ee96186184e4585cf587ec9.tar.gz
upstream-740d7c103f0c17bd1ee96186184e4585cf587ec9.tar.bz2
upstream-740d7c103f0c17bd1ee96186184e4585cf587ec9.zip
procd: update to latest git revision
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36995
-rw-r--r--package/procd/Makefile18
1 files changed, 3 insertions, 15 deletions
diff --git a/package/procd/Makefile b/package/procd/Makefile
index 160c222cf4..b94cd2e78b 100644
--- a/package/procd/Makefile
+++ b/package/procd/Makefile
@@ -1,21 +1,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2013-06-10
+PKG_VERSION:=2013-06-19
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=c261d39c1ae2db872495c2129c05d1154f46b5c3
+PKG_SOURCE_VERSION:=c23413feeb5179911d623e6ffb84b36671652788
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
PKG_LICENSE:=GPLv2
PKG_LICENSE_FILES:=
-PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
-
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
include $(INCLUDE_DIR)/package.mk
@@ -26,11 +24,10 @@ TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
define Package/procd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus +libjson-script +USE_EGLIBC:librt +PROCD_INIT:ubox
+ DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_EGLIBC:librt
TITLE:=OpenWrt system process manager
endef
-ifneq ($(CONFIG_PROCD_INIT),)
define Package/procd/install
$(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc
@@ -39,14 +36,5 @@ define Package/procd/install
$(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
ln -s /sbin/procd $(1)/sbin/init
endef
-else
-define Package/procd/install
- $(INSTALL_DIR) $(1)/sbin $(1)/lib/functions $(1)/etc/init.d
-
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/procd $(1)/sbin/
- $(INSTALL_BIN) ./files/procd.init $(1)/etc/init.d/procd
- $(INSTALL_DATA) ./files/procd.sh $(1)/lib/functions/
-endef
-endif
$(eval $(call BuildPackage,procd))