aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-11 22:58:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-11 22:58:44 +0000
commit71ca530e8a06b6ea9f225b00e9db1ba8f5fffce9 (patch)
treea50a443311c7382520fe1d9d6bd0c70197abc012
parent3a22d8eb298c7601047fcecab0f54d23d2310b73 (diff)
downloadupstream-71ca530e8a06b6ea9f225b00e9db1ba8f5fffce9.tar.gz
upstream-71ca530e8a06b6ea9f225b00e9db1ba8f5fffce9.tar.bz2
upstream-71ca530e8a06b6ea9f225b00e9db1ba8f5fffce9.zip
fix rb532 squashfs support (patch by Jens Muecke)
SVN-Revision: 7577
-rw-r--r--target/linux/rb532-2.6/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 149a7e2734..f53c5e4ac3 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -49,6 +49,10 @@ define Image/cmdline/ext2
root=/dev/cfa2 rootfstype=ext2 init=/etc/preinit
endef
+define Image/cmdline/squashfs
+root=/dev/cfa2 rootfstype=squashfs init=/etc/preinit
+endef
+
define Image/Build
$(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)