aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-02-22 17:26:41 +0100
committerFelix Fietkau <nbd@nbd.name>2019-08-12 11:43:38 +0200
commit6fa0e07758524eddf20c9b66dfcb55c490e1961e (patch)
treef5b77016f74c1f0bd9edb91a662afcb30e518d36
parent200f2666fb1c8d9d128824dc5586e0e66386971f (diff)
downloadupstream-6fa0e07758524eddf20c9b66dfcb55c490e1961e.tar.gz
upstream-6fa0e07758524eddf20c9b66dfcb55c490e1961e.tar.bz2
upstream-6fa0e07758524eddf20c9b66dfcb55c490e1961e.zip
build: allow overriding the filename on the remote server when downloading
Github releases usually don't contain the project name in the release filename, which makes them very inconvenient to use from the build system. Add support for naming the local file differently. Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--include/download.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/download.mk b/include/download.mk
index 09794e155e..14d68bf8f5 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -289,6 +289,7 @@ endef
define Download/default
FILE:=$(PKG_SOURCE)
URL:=$(PKG_SOURCE_URL)
+ URL_FILE:=$(PKG_SOURCE_URL_FILE)
SUBDIR:=$(PKG_SOURCE_SUBDIR)
PROTO:=$(PKG_SOURCE_PROTO)
$(if $(PKG_SOURCE_MIRROR),MIRROR:=$(filter 1,$(PKG_MIRROR)))