aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2020-04-11 15:44:14 +0200
committerPetr Štetiar <ynezz@true.cz>2020-04-20 16:37:56 +0200
commit6cafea5c5ea92be0152f475467a2434c90d01891 (patch)
tree13610a020ede958cac6f25b0b9ca2f70587aa800
parent29a458b0cae3435bce41136ee3b4132b4103ffae (diff)
downloadupstream-6cafea5c5ea92be0152f475467a2434c90d01891.tar.gz
upstream-6cafea5c5ea92be0152f475467a2434c90d01891.tar.bz2
upstream-6cafea5c5ea92be0152f475467a2434c90d01891.zip
uboot-kirkwood: update to 2020.04
Update U-Boot to current 2020.04 release for kirkwood platform. Catch up with upstream and move some configuration options from the header files to the corresponding defconfig files. Compile tested: all devices Run tested: nsa310, pogoplugv4 Tested-by: Cezary Jackiewicz <cezary@eko.one.pl> [nsa310] Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
-rw-r--r--package/boot/uboot-kirkwood/Makefile4
-rw-r--r--package/boot/uboot-kirkwood/patches/007-nsa310-uboot-generic.patch28
-rw-r--r--package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch34
-rw-r--r--package/boot/uboot-kirkwood/patches/010-pogoplug_v4.patch32
-rw-r--r--package/boot/uboot-kirkwood/patches/110-dockstar.patch22
-rw-r--r--package/boot/uboot-kirkwood/patches/120-iconnect.patch21
-rw-r--r--package/boot/uboot-kirkwood/patches/130-ib62x0.patch4
-rw-r--r--package/boot/uboot-kirkwood/patches/140-pogoplug_e02.patch20
-rw-r--r--package/boot/uboot-kirkwood/patches/150-goflexhome.patch4
-rw-r--r--package/boot/uboot-kirkwood/patches/200-openwrt-config.patch50
10 files changed, 101 insertions, 118 deletions
diff --git a/package/boot/uboot-kirkwood/Makefile b/package/boot/uboot-kirkwood/Makefile
index 4ce1485a13..c1b33b4a82 100644
--- a/package/boot/uboot-kirkwood/Makefile
+++ b/package/boot/uboot-kirkwood/Makefile
@@ -7,10 +7,10 @@
include $(TOPDIR)/rules.mk
-PKG_VERSION:=2019.01
+PKG_VERSION:=2020.04
PKG_RELEASE:=1
-PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
+PKG_HASH:=fe732aaf037d9cc3c0909bad8362af366ae964bbdac6913a34081ff4ad565372
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-kirkwood/patches/007-nsa310-uboot-generic.patch b/package/boot/uboot-kirkwood/patches/007-nsa310-uboot-generic.patch
index 25d252d13f..09dc587bf7 100644
--- a/package/boot/uboot-kirkwood/patches/007-nsa310-uboot-generic.patch
+++ b/package/boot/uboot-kirkwood/patches/007-nsa310-uboot-generic.patch
@@ -25,7 +25,7 @@ NOTE: this patch is ready for upstream, LEDE-specific parts are in
--- a/arch/arm/mach-kirkwood/Kconfig
+++ b/arch/arm/mach-kirkwood/Kconfig
-@@ -56,6 +56,9 @@ config TARGET_GOFLEXHOME
+@@ -53,6 +53,9 @@ config TARGET_GOFLEXHOME
config TARGET_NAS220
bool "BlackArmor NAS220"
@@ -505,8 +505,10 @@ NOTE: this patch is ready for upstream, LEDE-specific parts are in
+#endif /* __NSA310_H */
--- /dev/null
+++ b/configs/nsa310_defconfig
-@@ -0,0 +1,40 @@
+@@ -0,0 +1,48 @@
+CONFIG_ARM=y
++CONFIG_SYS_DCACHE_OFF=y
++CONFIG_ARCH_CPU_INIT=y
+CONFIG_KIRKWOOD=y
+CONFIG_SYS_TEXT_BASE=0x600000
+CONFIG_TARGET_NSA310=y
@@ -533,12 +535,18 @@ NOTE: this patch is ready for upstream, LEDE-specific parts are in
+CONFIG_CMD_EXT4=y
+CONFIG_CMD_FAT=y
+CONFIG_CMD_JFFS2=y
++CONFIG_MTD=y
++CONFIG_MTD_RAW_NAND=y
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0x0c0000(uboot),0x80000(uboot_env),0x7ec0000(ubi)"
+CONFIG_CMD_MTDPARTS=y
+CONFIG_CMD_ENV=y
+CONFIG_CMD_NAND=y
+CONFIG_EFI_PARTITION=y
+CONFIG_ENV_IS_IN_NAND=y
++CONFIG_ENV_SIZE=0x20000
++CONFIG_ENV_OFFSET=0xC0000
++CONFIG_ENV_SECT_SIZE=0x20000
++CONFIG_ENV_ADDR=0xC0000
+CONFIG_CMD_UBI=y
+CONFIG_USB=y
+CONFIG_USB_EHCI_HCD=y
@@ -548,7 +556,7 @@ NOTE: this patch is ready for upstream, LEDE-specific parts are in
+CONFIG_SYS_LONGHELP=y
--- /dev/null
+++ b/include/configs/nsa310.h
-@@ -0,0 +1,117 @@
+@@ -0,0 +1,103 @@
+/* Copyright (C) 2015-2016 bodhi <mibodhi@gmail.com>
+ *
+ * Based on
@@ -606,20 +614,6 @@ NOTE: this patch is ready for upstream, LEDE-specific parts are in
+#include "mv-common.h"
+
+/*
-+ * Environment variables configurations
-+ */
-+#ifdef CONFIG_CMD_NAND
-+#define CONFIG_ENV_SECT_SIZE 0x20000 /* 128K */
-+#endif
-+
-+/* max 4k env size is enough, but in case of nand
-+ * it has to be rounded to sector size
-+ */
-+#define CONFIG_ENV_SIZE 0x20000 /* 128k */
-+#define CONFIG_ENV_ADDR 0xc0000
-+#define CONFIG_ENV_OFFSET 0xc0000 /* env starts here */
-+
-+/*
+ * Default environment variables
+ */
+#define CONFIG_BOOTCOMMAND \
diff --git a/package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch b/package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch
index d0bef45f88..db9a7a6fb2 100644
--- a/package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch
+++ b/package/boot/uboot-kirkwood/patches/008-nsa325-uboot-generic.patch
@@ -1,8 +1,8 @@
--- a/arch/arm/mach-kirkwood/Kconfig
+++ b/arch/arm/mach-kirkwood/Kconfig
-@@ -68,6 +68,9 @@ config TARGET_SBx81LIFKW
- config TARGET_SBx81LIFXCAT
- bool "Allied Telesis SBx81GP24/SBx81GT24"
+@@ -68,6 +68,9 @@ config TARGET_SBx81LIFXCAT
+ config TARGET_DB_88F6281_BP
+ bool "Marvell DB-88F6281-BP"
+config TARGET_NSA325
+ bool "Zyxel NSA325 board"
@@ -17,7 +17,7 @@
+source "board/zyxel/nsa325/Kconfig"
source "board/alliedtelesis/SBx81LIFKW/Kconfig"
source "board/alliedtelesis/SBx81LIFXCAT/Kconfig"
-
+ source "board/Marvell/db-88f6281-bp/Kconfig"
--- /dev/null
+++ b/board/zyxel/nsa325/Kconfig
@@ -0,0 +1,12 @@
@@ -489,8 +489,10 @@
+#endif /* __NSA325_H */
--- /dev/null
+++ b/configs/nsa325_defconfig
-@@ -0,0 +1,40 @@
+@@ -0,0 +1,48 @@
+CONFIG_ARM=y
++CONFIG_SYS_DCACHE_OFF=y
++CONFIG_ARCH_CPU_INIT=y
+CONFIG_KIRKWOOD=y
+CONFIG_SYS_TEXT_BASE=0x600000
+CONFIG_TARGET_NSA325=y
@@ -518,12 +520,18 @@
+CONFIG_CMD_EXT4=y
+CONFIG_CMD_FAT=y
+CONFIG_CMD_JFFS2=y
++CONFIG_MTD=y
++CONFIG_MTD_RAW_NAND=y
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0x0c0000(uboot),0x80000(uboot_env),0x7ec0000(ubi)"
+CONFIG_CMD_MTDPARTS=y
+CONFIG_CMD_ENV=y
+CONFIG_CMD_NAND=y
+CONFIG_EFI_PARTITION=y
+CONFIG_ENV_IS_IN_NAND=y
++CONFIG_ENV_SIZE=0x20000
++CONFIG_ENV_OFFSET=0xC0000
++CONFIG_ENV_SECT_SIZE=0x20000
++CONFIG_ENV_ADDR=0xC0000
+CONFIG_CMD_UBI=y
+CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_STORAGE=y
@@ -532,7 +540,7 @@
+CONFIG_SYS_LONGHELP=y
--- /dev/null
+++ b/include/configs/nsa325.h
-@@ -0,0 +1,120 @@
+@@ -0,0 +1,106 @@
+/*
+ * (C) Copyright 2016 bodhi <mibodhi@gmail.com>
+ *
@@ -593,20 +601,6 @@
+#include "mv-common.h"
+
+/*
-+ * Environment variables configurations
-+ */
-+#ifdef CONFIG_CMD_NAND
-+#define CONFIG_ENV_SECT_SIZE 0x20000 /* 128K */
-+#endif
-+/*
-+ * max 4k env size is enough, but in case of nand
-+ * it has to be rounded to sector size
-+ */
-+#define CONFIG_ENV_SIZE 0x20000 /* 128k */
-+#define CONFIG_ENV_ADDR 0xc0000
-+#define CONFIG_ENV_OFFSET 0xc0000 /* env starts here */
-+
-+/*
+ * Default environment variables
+ */
+#define CONFIG_BOOTCOMMAND \
diff --git a/package/boot/uboot-kirkwood/patches/010-pogoplug_v4.patch b/package/boot/uboot-kirkwood/patches/010-pogoplug_v4.patch
index 8aed96ad18..58bf664238 100644
--- a/package/boot/uboot-kirkwood/patches/010-pogoplug_v4.patch
+++ b/package/boot/uboot-kirkwood/patches/010-pogoplug_v4.patch
@@ -17,7 +17,7 @@
+source "board/cloudengines/pogoplugv4/Kconfig"
source "board/d-link/dns325/Kconfig"
source "board/iomega/iconnect/Kconfig"
- source "board/keymile/km_arm/Kconfig"
+ source "board/keymile/Kconfig"
--- a/arch/arm/mach-kirkwood/include/mach/kw88f6192.h
+++ b/arch/arm/mach-kirkwood/include/mach/kw88f6192.h
@@ -15,6 +15,6 @@
@@ -532,8 +532,10 @@
+#endif /* __POGOPLUGV4_H */
--- /dev/null
+++ b/configs/pogoplugv4_defconfig
-@@ -0,0 +1,43 @@
+@@ -0,0 +1,51 @@
+CONFIG_ARM=y
++CONFIG_SYS_DCACHE_OFF=y
++CONFIG_ARCH_CPU_INIT=y
+CONFIG_KIRKWOOD=y
+CONFIG_SYS_TEXT_BASE=0x600000
+CONFIG_TARGET_POGOPLUGV4=y
@@ -561,6 +563,8 @@
+CONFIG_CMD_EXT4=y
+CONFIG_CMD_FAT=y
+CONFIG_CMD_JFFS2=y
++CONFIG_MTD=y
++CONFIG_MTD_RAW_NAND=y
+CONFIG_MTDPARTS_DEFAULT="mtdparts=orion_nand:0x1c0000(uboot),0x40000(uboot_env),0x7e00000(ubi)"
+CONFIG_CMD_MTDPARTS=y
+CONFIG_CMD_ENV=y
@@ -569,6 +573,10 @@
+CONFIG_CMD_GPIO=y
+CONFIG_EFI_PARTITION=y
+CONFIG_ENV_IS_IN_NAND=y
++CONFIG_ENV_SIZE=0x20000
++CONFIG_ENV_OFFSET=0x1C0000
++CONFIG_ENV_SECT_SIZE=0x20000
++CONFIG_ENV_ADDR=0x1C0000
+CONFIG_CMD_UBI=y
+CONFIG_USB=y
+CONFIG_USB_EHCI_HCD=y
@@ -617,7 +625,7 @@
+}
--- a/drivers/mmc/Makefile
+++ b/drivers/mmc/Makefile
-@@ -61,6 +61,7 @@ obj-$(CONFIG_MMC_SDHCI_TANGIER) += tang
+@@ -66,6 +66,7 @@ obj-$(CONFIG_MMC_SDHCI_TANGIER) += tang
obj-$(CONFIG_MMC_SDHCI_TEGRA) += tegra_mmc.o
obj-$(CONFIG_MMC_SDHCI_XENON) += xenon_sdhci.o
obj-$(CONFIG_MMC_SDHCI_ZYNQ) += zynq_sdhci.o
@@ -1112,7 +1120,7 @@
+}
--- a/include/configs/mv-common.h
+++ b/include/configs/mv-common.h
-@@ -77,4 +77,10 @@
+@@ -75,4 +75,10 @@
#define CONFIG_SYS_MAX_NAND_DEVICE 1
#endif
@@ -1125,7 +1133,7 @@
#endif /* _MV_COMMON_H */
--- /dev/null
+++ b/include/configs/pogoplugv4.h
-@@ -0,0 +1,127 @@
+@@ -0,0 +1,113 @@
+/*
+ * Copyright (C) 2014-2016 bodhi <mibodhi@gmail.com>
+ * Based on
@@ -1188,20 +1196,6 @@
+#include "mv-common.h"
+
+/*
-+ * Environment variables configurations
-+ */
-+#ifdef CONFIG_CMD_NAND
-+
-+#define CONFIG_ENV_SECT_SIZE 0x20000 /* 128K */
-+
-+
-+#endif
-+
-+#define CONFIG_ENV_SIZE 0x20000 /* 128k */
-+#define CONFIG_ENV_ADDR 0x1c0000
-+#define CONFIG_ENV_OFFSET 0x1c0000 /* env starts here */
-+
-+/*
+ * Default environment variables
+ */
+#define CONFIG_BOOTCOMMAND \
diff --git a/package/boot/uboot-kirkwood/patches/110-dockstar.patch b/package/boot/uboot-kirkwood/patches/110-dockstar.patch
index f060c33c63..b3837956bc 100644
--- a/package/boot/uboot-kirkwood/patches/110-dockstar.patch
+++ b/package/boot/uboot-kirkwood/patches/110-dockstar.patch
@@ -8,16 +8,7 @@
/*
* mv-common.h should be defined after CMD configs since it used them
-@@ -35,27 +36,22 @@
- * it has to be rounded to sector size
- */
- #define CONFIG_ENV_SIZE 0x20000 /* 128k */
--#define CONFIG_ENV_ADDR 0x80000
--#define CONFIG_ENV_OFFSET 0x80000 /* env starts here */
-+#define CONFIG_ENV_OFFSET 0xe0000 /* env starts here */
-
- /*
- * Default environment variables
+@@ -37,19 +38,15 @@
*/
#define CONFIG_BOOTCOMMAND \
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
@@ -46,7 +37,16 @@
* Ethernet Driver configuration
--- a/configs/dockstar_defconfig
+++ b/configs/dockstar_defconfig
-@@ -18,7 +18,7 @@ CONFIG_CMD_PING=y
+@@ -5,7 +5,7 @@ CONFIG_KIRKWOOD=y
+ CONFIG_SYS_TEXT_BASE=0x600000
+ CONFIG_TARGET_DOCKSTAR=y
+ CONFIG_ENV_SIZE=0x20000
+-CONFIG_ENV_OFFSET=0x80000
++CONFIG_ENV_OFFSET=0xE0000
+ CONFIG_NR_DRAM_BANKS=2
+ CONFIG_IDENT_STRING="\nSeagate FreeAgent DockStar"
+ CONFIG_BOOTDELAY=3
+@@ -23,7 +23,7 @@ CONFIG_CMD_EXT2=y
CONFIG_CMD_FAT=y
CONFIG_CMD_JFFS2=y
CONFIG_CMD_MTDPARTS=y
diff --git a/package/boot/uboot-kirkwood/patches/120-iconnect.patch b/package/boot/uboot-kirkwood/patches/120-iconnect.patch
index e7acf1a27f..770a52f737 100644
--- a/package/boot/uboot-kirkwood/patches/120-iconnect.patch
+++ b/package/boot/uboot-kirkwood/patches/120-iconnect.patch
@@ -1,14 +1,6 @@
--- a/include/configs/iconnect.h
+++ b/include/configs/iconnect.h
-@@ -42,24 +42,22 @@
- #define CONFIG_ENV_SECT_SIZE 0x20000
- #endif
- #define CONFIG_ENV_SIZE 0x20000
--#define CONFIG_ENV_OFFSET 0x80000
-+#define CONFIG_ENV_OFFSET 0xe0000
-
- /*
- * Default environment variables
+@@ -44,17 +44,15 @@
*/
#define CONFIG_BOOTCOMMAND \
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
@@ -32,7 +24,16 @@
* Ethernet driver configuration
--- a/configs/iconnect_defconfig
+++ b/configs/iconnect_defconfig
-@@ -11,13 +11,14 @@ CONFIG_SYS_PROMPT="iconnect => "
+@@ -5,7 +5,7 @@ CONFIG_KIRKWOOD=y
+ CONFIG_SYS_TEXT_BASE=0x600000
+ CONFIG_TARGET_ICONNECT=y
+ CONFIG_ENV_SIZE=0x20000
+-CONFIG_ENV_OFFSET=0x80000
++CONFIG_ENV_OFFSET=0xE0000
+ CONFIG_NR_DRAM_BANKS=2
+ CONFIG_IDENT_STRING=" Iomega iConnect"
+ CONFIG_BOOTDELAY=3
+@@ -16,13 +16,14 @@ CONFIG_SYS_PROMPT="iconnect => "
CONFIG_CMD_NAND=y
CONFIG_CMD_USB=y
# CONFIG_CMD_SETEXPR is not set
diff --git a/package/boot/uboot-kirkwood/patches/130-ib62x0.patch b/package/boot/uboot-kirkwood/patches/130-ib62x0.patch
index 2327c4a910..0092d989e1 100644
--- a/package/boot/uboot-kirkwood/patches/130-ib62x0.patch
+++ b/package/boot/uboot-kirkwood/patches/130-ib62x0.patch
@@ -1,6 +1,6 @@
--- a/include/configs/ib62x0.h
+++ b/include/configs/ib62x0.h
-@@ -47,21 +47,15 @@
+@@ -39,21 +39,15 @@
*/
#define CONFIG_BOOTCOMMAND \
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
@@ -29,7 +29,7 @@
* Ethernet driver configuration
--- a/configs/ib62x0_defconfig
+++ b/configs/ib62x0_defconfig
-@@ -21,7 +21,7 @@ CONFIG_CMD_PING=y
+@@ -26,7 +26,7 @@ CONFIG_CMD_EXT2=y
CONFIG_CMD_FAT=y
CONFIG_CMD_JFFS2=y
CONFIG_CMD_MTDPARTS=y
diff --git a/package/boot/uboot-kirkwood/patches/140-pogoplug_e02.patch b/package/boot/uboot-kirkwood/patches/140-pogoplug_e02.patch
index 69e21e60f7..d077915c93 100644
--- a/package/boot/uboot-kirkwood/patches/140-pogoplug_e02.patch
+++ b/package/boot/uboot-kirkwood/patches/140-pogoplug_e02.patch
@@ -1,13 +1,6 @@
--- a/include/configs/pogo_e02.h
+++ b/include/configs/pogo_e02.h
-@@ -42,23 +42,23 @@
- #endif
-
- #define CONFIG_ENV_SIZE 0x20000 /* 128k */
--#define CONFIG_ENV_OFFSET 0x60000 /* env starts here */
-+#define CONFIG_ENV_OFFSET 0xe0000 /* env starts here */
-
- /*
+@@ -42,17 +42,17 @@
* Default environment variables
*/
#define CONFIG_BOOTCOMMAND \
@@ -36,7 +29,16 @@
* Ethernet Driver configuration
--- a/configs/pogo_e02_defconfig
+++ b/configs/pogo_e02_defconfig
-@@ -18,6 +18,7 @@ CONFIG_CMD_PING=y
+@@ -5,7 +5,7 @@ CONFIG_KIRKWOOD=y
+ CONFIG_SYS_TEXT_BASE=0x600000
+ CONFIG_TARGET_POGO_E02=y
+ CONFIG_ENV_SIZE=0x20000
+-CONFIG_ENV_OFFSET=0x60000
++CONFIG_ENV_OFFSET=0xE0000
+ CONFIG_NR_DRAM_BANKS=2
+ CONFIG_IDENT_STRING="\nPogo E02"
+ CONFIG_BOOTDELAY=3
+@@ -23,6 +23,7 @@ CONFIG_CMD_EXT2=y
CONFIG_CMD_FAT=y
CONFIG_CMD_JFFS2=y
CONFIG_CMD_MTDPARTS=y
diff --git a/package/boot/uboot-kirkwood/patches/150-goflexhome.patch b/package/boot/uboot-kirkwood/patches/150-goflexhome.patch
index 854a1800c3..55d69b81d5 100644
--- a/package/boot/uboot-kirkwood/patches/150-goflexhome.patch
+++ b/package/boot/uboot-kirkwood/patches/150-goflexhome.patch
@@ -1,6 +1,6 @@
--- a/include/configs/goflexhome.h
+++ b/include/configs/goflexhome.h
-@@ -66,17 +66,15 @@
+@@ -60,17 +60,15 @@
*/
#define CONFIG_BOOTCOMMAND \
"setenv bootargs ${console} ${mtdparts} ${bootargs_root}; " \
@@ -24,7 +24,7 @@
* Ethernet Driver configuration
--- a/configs/goflexhome_defconfig
+++ b/configs/goflexhome_defconfig
-@@ -23,7 +23,7 @@ CONFIG_CMD_EXT4=y
+@@ -28,7 +28,7 @@ CONFIG_CMD_FAT=y
CONFIG_CMD_JFFS2=y
CONFIG_CMD_MTDPARTS=y
CONFIG_MTDIDS_DEFAULT="nand0=orion_nand"
diff --git a/package/boot/uboot-kirkwood/patches/200-openwrt-config.patch b/package/boot/uboot-kirkwood/patches/200-openwrt-config.patch
index f26675182a..2ff4f2f184 100644
--- a/package/boot/uboot-kirkwood/patches/200-openwrt-config.patch
+++ b/package/boot/uboot-kirkwood/patches/200-openwrt-config.patch
@@ -1,37 +1,37 @@
--- a/arch/arm/mach-kirkwood/Kconfig
+++ b/arch/arm/mach-kirkwood/Kconfig
-@@ -102,4 +102,7 @@ source "board/zyxel/nsa310/Kconfig"
- source "board/alliedtelesis/SBx81LIFKW/Kconfig"
+@@ -103,4 +103,7 @@ source "board/alliedtelesis/SBx81LIFKW/K
source "board/alliedtelesis/SBx81LIFXCAT/Kconfig"
-
+ source "board/Marvell/db-88f6281-bp/Kconfig"
+
+config SECOND_STAGE
+ bool "OpenWrt second stage hack"
+
endif
--- a/include/configs/dockstar.h
+++ b/include/configs/dockstar.h
-@@ -65,4 +65,6 @@
+@@ -60,4 +60,6 @@
* File system
*/
-
+
+#include "openwrt-kirkwood-common.h"
+
#endif /* _CONFIG_DOCKSTAR_H */
--- a/include/configs/ib62x0.h
+++ b/include/configs/ib62x0.h
-@@ -85,4 +85,6 @@
+@@ -77,4 +77,6 @@
#define CONFIG_RTC_MV
#endif /* CONFIG_CMD_DATE */
-
+
+#include "openwrt-kirkwood-common.h"
+
#endif /* _CONFIG_IB62x0_H */
--- a/include/configs/iconnect.h
+++ b/include/configs/iconnect.h
-@@ -72,4 +72,6 @@
+@@ -67,4 +67,6 @@
* File system
*/
-
+
+#include "openwrt-kirkwood-common.h"
+
#endif /* _CONFIG_ICONNECT_H */
@@ -71,34 +71,34 @@
+#endif /* __OPENWRT_KIRKWOOD_COMMON_H */
--- a/include/configs/pogo_e02.h
+++ b/include/configs/pogo_e02.h
-@@ -72,4 +72,6 @@
+@@ -66,4 +66,6 @@
* File system
*/
-
+
+#include "openwrt-kirkwood-common.h"
+
#endif /* _CONFIG_POGO_E02_H */
--- a/include/configs/goflexhome.h
+++ b/include/configs/goflexhome.h
-@@ -91,4 +91,6 @@
+@@ -85,4 +85,6 @@
#define CONFIG_SYS_ATA_IDE0_OFFSET MV_SATA_PORT0_OFFSET
#endif /*CONFIG_MVSATA_IDE*/
-
+
+#include "openwrt-kirkwood-common.h"
+
#endif /* _CONFIG_GOFLEXHOME_H */
--- a/include/configs/nsa310.h
+++ b/include/configs/nsa310.h
-@@ -114,4 +114,6 @@
+@@ -100,4 +100,6 @@
#define CONFIG_RTC_MV
#endif /* CONFIG_CMD_DATE */
-
+
+#include "openwrt-kirkwood-common.h"
+
#endif /* _CONFIG_NSA310_H */
--- a/configs/dockstar_defconfig
+++ b/configs/dockstar_defconfig
-@@ -31,3 +31,8 @@ CONFIG_USB=y
+@@ -38,3 +38,8 @@ CONFIG_SYS_NS16550=y
CONFIG_USB=y
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_STORAGE=y
@@ -109,8 +109,8 @@
+CONFIG_LZO=y
--- a/configs/goflexhome_defconfig
+++ b/configs/goflexhome_defconfig
-@@ -40,3 +40,8 @@ CONFIG_USB=y
- CONFIG_USB=y
+@@ -49,3 +49,8 @@ CONFIG_USB=y
+ CONFIG_DM_USB=y
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_STORAGE=y
+CONFIG_CMD_BOOTZ=y
@@ -120,30 +120,28 @@
+CONFIG_LZO=y
--- a/configs/ib62x0_defconfig
+++ b/configs/ib62x0_defconfig
-@@ -35,4 +35,7 @@ CONFIG_SYS_NS16550=y
+@@ -43,4 +43,7 @@ CONFIG_SYS_NS16550=y
CONFIG_USB=y
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_STORAGE=y
--CONFIG_LZMA=y
+CONFIG_FIT=y
+CONFIG_FIT_VERBOSE=y
-+CONFIG_LZMA=y
+ CONFIG_LZMA=y
+CONFIG_LZO=y
--- a/configs/iconnect_defconfig
+++ b/configs/iconnect_defconfig
-@@ -31,4 +31,8 @@ CONFIG_SYS_NS16550=y
+@@ -39,4 +39,8 @@ CONFIG_SYS_NS16550=y
CONFIG_USB=y
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_STORAGE=y
--CONFIG_LZMA=y
+CONFIG_CMD_BOOTZ=y
+CONFIG_FIT=y
+CONFIG_FIT_VERBOSE=y
-+CONFIG_LZMA=y
+ CONFIG_LZMA=y
+CONFIG_LZO=y
--- a/configs/nsa310_defconfig
+++ b/configs/nsa310_defconfig
-@@ -35,6 +35,9 @@ CONFIG_CMD_UBI=y
+@@ -43,6 +43,9 @@ CONFIG_CMD_UBI=y
CONFIG_USB=y
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_STORAGE=y
@@ -155,7 +153,7 @@
CONFIG_SYS_LONGHELP=y
--- a/configs/pogo_e02_defconfig
+++ b/configs/pogo_e02_defconfig
-@@ -31,3 +31,8 @@ CONFIG_USB=y
+@@ -39,3 +39,8 @@ CONFIG_SYS_NS16550=y
CONFIG_USB=y
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_STORAGE=y