aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-02-17 21:00:34 +0100
committerStijn Tintel <stijn@linux-ipv6.be>2018-02-17 21:00:49 +0100
commit6c2e1ff80f52b939405fe0c14577c584602ae432 (patch)
tree75baf58ce751ec13cd49f3818b74392e730ed6c4
parent81ccf24c09d31ee4630d477c50a646e22a0fd34b (diff)
downloadupstream-6c2e1ff80f52b939405fe0c14577c584602ae432.tar.gz
upstream-6c2e1ff80f52b939405fe0c14577c584602ae432.tar.bz2
upstream-6c2e1ff80f52b939405fe0c14577c584602ae432.zip
brcm2708: fix sdcard image
The gzip step in the sdcard image build fails because the image filename already has the gzip extension. This results in an empty image file, to which the metadata is finally appended. Remove the .gz extension from the image filename to fix this. Fixes: e79b096ee175 ("brcm2708: convert to metadata") Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
-rw-r--r--target/linux/brcm2708/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 9ea9a07a9d..2d606e5649 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -50,8 +50,8 @@ define Device/Default
FILESYSTEMS := ext4
KERNEL := kernel-bin | kernel-img
KERNEL_IMG := kernel.img
- IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-img | sdcard-img | gzip | append-metadata
+ IMAGES := sdcard.img
+ IMAGE/sdcard.img := boot-img | sdcard-img | gzip | append-metadata
endef
define Device/rpi