aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2020-04-12 00:09:46 +0200
committerJo-Philipp Wich <jo@mein.io>2020-04-12 00:10:30 +0200
commit6c16d64b2a0bb063a89225dcaabd50c00bce7aa2 (patch)
tree3ef4f18994069e38ea4c3e22980cbe965a9d8882
parentfbc01f2a4c072dafb3a6ef73e6f3f2ef1433575f (diff)
downloadupstream-6c16d64b2a0bb063a89225dcaabd50c00bce7aa2.tar.gz
upstream-6c16d64b2a0bb063a89225dcaabd50c00bce7aa2.tar.bz2
upstream-6c16d64b2a0bb063a89225dcaabd50c00bce7aa2.zip
Revert "build: add option to warn on recursive dependency"
This reverts commit 3204430e38f1a2ba7fda9471720a2a1042adf5e0. Reverting this commit in preparation for reverting dcf3e63a35 ("build: scripts/config - update to kconfig-v5.6") which introduces various unaddressed build breakages. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--include/toplevel.mk2
-rw-r--r--scripts/config/README4
-rw-r--r--scripts/config/symbol.c5
3 files changed, 1 insertions, 10 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index def80503dd..2965f75c7c 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -102,7 +102,7 @@ prepare-tmpinfo: FORCE
ifneq ($(DISTRO_PKG_CONFIG),)
scripts/config/%onf: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
endif
-scripts/config/%onf: CFLAGS+= -O2 $(if $(WARN_RECURSIVE_DEP),-DWARN_RECURSIVE_DEP)
+scripts/config/%onf: CFLAGS+= -O2
scripts/config/%onf:
@$(_SINGLE)$(SUBMAKE) -s -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
diff --git a/scripts/config/README b/scripts/config/README
index 81243e8016..ac5f094ff2 100644
--- a/scripts/config/README
+++ b/scripts/config/README
@@ -16,10 +16,6 @@ OpenWrt Buildroot:
- reverted an upstream change that avoids writing symbols that are not
visible to .config, which breaks OpenWrt busybox's '.config' generation
logic.
- - add a compilation option (-DWARN_RECURSIVE_DEP) to treat recursive deps
- as a warning, avoiding a complete build failure because of unrelated or
- minor recursive deps, or making a scrict check before commiting a change
- that may cause one.
- use pre-built *.lex.c *.tab.[ch] files by default, to avoid depending on
flex & bison. Rebuild/remove these files only if running make with
BUILD_SHIPPED_FILES defined
diff --git a/scripts/config/symbol.c b/scripts/config/symbol.c
index 5c6f540314..b1dd9be29d 100644
--- a/scripts/config/symbol.c
+++ b/scripts/config/symbol.c
@@ -1250,11 +1250,6 @@ struct symbol *sym_check_deps(struct symbol *sym)
sym->flags &= ~SYMBOL_CHECK;
}
-#ifdef WARN_RECURSIVE_DEP
- if (sym2 && sym2 == sym)
- sym2 = NULL;
-#endif
-
return sym2;
}