aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-07-04 13:49:14 +0000
committerNicolas Thill <nico@openwrt.org>2005-07-04 13:49:14 +0000
commit6c0eacad74056fad5a269621c291f68eb32ee81d (patch)
tree53949ac36cb4f4a1dae498926bd5aa559cc9f35b
parent518fab9488b667c6ddb9e97558450ee855ab1059 (diff)
downloadupstream-6c0eacad74056fad5a269621c291f68eb32ee81d.tar.gz
upstream-6c0eacad74056fad5a269621c291f68eb32ee81d.tar.bz2
upstream-6c0eacad74056fad5a269621c291f68eb32ee81d.zip
Add sqlite2 package
SVN-Revision: 1332
-rw-r--r--openwrt/package/Config.in1
-rw-r--r--openwrt/package/Makefile2
-rw-r--r--openwrt/package/sqlite2/Config.in77
-rw-r--r--openwrt/package/sqlite2/Makefile98
-rw-r--r--openwrt/package/sqlite2/ipkg/libsqlite2.control6
-rw-r--r--openwrt/package/sqlite2/ipkg/sqlite2-cli.control7
6 files changed, 191 insertions, 0 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 0e5d5a8d66..00ffb9fbea 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -123,6 +123,7 @@ source "package/readline/Config.in" # libreadline
source "package/cyrus-sasl/Config.in" # libsasl2
source "package/speex/Config.in" # libspeex
source "package/sqlite/Config.in" # libsqlite
+source "package/sqlite2/Config.in" # libsqlite2
source "package/libtasn1/Config.in"
source "package/libusb/Config.in"
source "package/uclibc++/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 751b5e5e0e..4e8f5de966 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -111,6 +111,7 @@ package-$(BR2_PACKAGE_SIPSAK) += sipsak
package-$(BR2_PACKAGE_SNORT) += snort
package-$(BR2_PACKAGE_SPEEX) += speex
package-$(BR2_PACKAGE_SQLITE) += sqlite
+package-$(BR2_PACKAGE_SQLITE2) += sqlite2
package-$(BR2_PACKAGE_SSMTP) += ssmtp
package-$(BR2_PACKAGE_STRACE) += strace
package-$(BR2_PACKAGE_TCPDUMP) += tcpdump
@@ -174,6 +175,7 @@ screen-compile: ncurses-compile
siproxd-compile: libosip2-compile
sipsak-compile: openssl-compile
sqlite-compile: ncurses-compile readline-compile
+sqlite2-compile: ncurses-compile readline-compile
tcpdump-compile: libpcap-compile
tinc-compile: zlib-compile openssl-compile lzo-compile
tor-compile: libevent-compile openssl-compile zlib-compile
diff --git a/openwrt/package/sqlite2/Config.in b/openwrt/package/sqlite2/Config.in
new file mode 100644
index 0000000000..3be1bb34a3
--- /dev/null
+++ b/openwrt/package/sqlite2/Config.in
@@ -0,0 +1,77 @@
+config BR2_PACKAGE_SQLITE2
+ bool
+ default n
+ depends BR2_PACKAGE_LIBSQLITE2
+
+config BR2_PACKAGE_LIBSQLITE2
+ prompt "libsqlite2 - Self-contained, embeddable, zero-configuration SQL database engine (v2.x)"
+ tristate
+# default m if CONFIG_DEVEL
+ default n
+ select BR2_PACKAGE_SQLITE2
+ select BR2_PACKAGE_LIBNCURSES
+ select BR2_PACKAGE_LIBREADLINE
+ help
+ SQLite is a small C library that implements a self-contained, embeddable,
+ zero-configuration SQL database engine. Features include:
+
+ * Transactions are atomic, consistent, isolated, and durable (ACID)
+ even after system crashes and power failures.
+ * Zero-configuration - no setup or administration needed.
+ * Implements most of SQL92. (Features not supported)
+ * A complete database is stored in a single disk file.
+ * Database files can be freely shared between machines with different
+ byte orders.
+ * Supports databases up to 2 terabytes (241 bytes) in size.
+ * Sizes of strings and BLOBs limited only by available memory.
+ * Small code footprint: less than 30K lines of C code, less than 250KB
+ code space (gcc on i486)
+ * Faster than popular client/server database engines for most common
+ operations.
+ * Simple, easy to use API.
+ * TCL bindings included. Bindings for many other languages available
+ separately.
+ * Well-commented source code with over 95% test coverage.
+ * Self-contained: no external dependencies.
+ * Sources are in the public domain. Use for any purpose.
+
+ http://www.sqlite.org/
+
+ This package contains the shared library, needed by other programs.
+
+config BR2_PACKAGE_SQLITE2_CLI
+ prompt "sqlite2-cli - Command line interface for SQLite (v2.x)"
+ tristate
+# default m if CONFIG_DEVEL
+ default n
+ depends BR2_PACKAGE_LIBSQLITE2
+ help
+ SQLite is a small C library that implements a self-contained, embeddable,
+ zero-configuration SQL database engine. Features include:
+
+ * Transactions are atomic, consistent, isolated, and durable (ACID)
+ even after system crashes and power failures.
+ * Zero-configuration - no setup or administration needed.
+ * Implements most of SQL92. (Features not supported)
+ * A complete database is stored in a single disk file.
+ * Database files can be freely shared between machines with different
+ byte orders.
+ * Supports databases up to 2 terabytes (241 bytes) in size.
+ * Sizes of strings and BLOBs limited only by available memory.
+ * Small code footprint: less than 30K lines of C code, less than 250KB
+ code space (gcc on i486)
+ * Faster than popular client/server database engines for most common
+ operations.
+ * Simple, easy to use API.
+ * TCL bindings included. Bindings for many other languages available
+ separately.
+ * Well-commented source code with over 95% test coverage.
+ * Self-contained: no external dependencies.
+ * Sources are in the public domain. Use for any purpose.
+
+ http://www.sqlite.org/
+
+ This package contains a terminal-based front-end to the SQLite library
+ that can evaluate queries interactively and display the results in
+ multiple formats.
+ \ No newline at end of file
diff --git a/openwrt/package/sqlite2/Makefile b/openwrt/package/sqlite2/Makefile
new file mode 100644
index 0000000000..6fb490cc37
--- /dev/null
+++ b/openwrt/package/sqlite2/Makefile
@@ -0,0 +1,98 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sqlite2
+PKG_VERSION:=2.8.16
+PKG_RELEASE:=1
+PKG_MD5SUM:=9c79b461ff30240a6f9d70dd67f8faea
+
+PKG_SOURCE_URL:=http://www.sqlite.org/
+PKG_SOURCE:=sqlite-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/sqlite-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LIBSQLITE2,libsqlite2,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,SQLITE2_CLI,sqlite2-cli,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ config_BUILD_CC="$(HOSTCC)" \
+ config_BUILD_CFLAGS="-O2" \
+ config_TARGET_CC="$(TARGET_CC)" \
+ config_TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+ config_TARGET_READLINE_INC="-I$(STAGING_DIR)/usr/include" \
+ config_TARGET_READLINE_LIBS="-L$(STAGING_DIR)/usr/lib -lreadline -lncurses" \
+ config_TARGET_TCL_INC="-DNO_TCL=1" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
+ $(DISABLE_NLS) \
+ --enable-shared \
+ --enable-static \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ rm -rf $(PKG_INSTALL_DIR)
+ mkdir -p $(PKG_INSTALL_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ all install
+ touch $@
+
+$(IPKG_LIBSQLITE2):
+ install -d -m0755 $(IDIR_LIBSQLITE2)/usr/lib
+ cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libsqlite.so.* $(IDIR_LIBSQLITE2)/usr/lib/
+ $(RSTRIP) $(IDIR_LIBSQLITE2)
+ $(IPKG_BUILD) $(IDIR_LIBSQLITE2) $(PACKAGE_DIR)
+
+$(IPKG_SQLITE2_CLI):
+ install -d -m0755 $(IDIR_SQLITE2_CLI)/usr/bin
+ cp -fpR $(PKG_INSTALL_DIR)/usr/bin/sqlite $(IDIR_SQLITE2_CLI)/usr/bin/
+ $(RSTRIP) $(IDIR_SQLITE2_CLI)
+ $(IPKG_BUILD) $(IDIR_SQLITE2_CLI) $(PACKAGE_DIR)
+
+$(STAGING_DIR)/usr/lib/libsqlite.so: $(PKG_BUILD_DIR)/.built
+ mkdir -p $(STAGING_DIR)/usr/include
+ cp -fpR $(PKG_INSTALL_DIR)/usr/include/sqlite.h $(STAGING_DIR)/usr/include/
+ mkdir -p $(STAGING_DIR)/usr/lib
+ cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libsqlite.{a,so*} $(STAGING_DIR)/usr/lib/
+ mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
+ cp -fpR $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sqlite.pc $(STAGING_DIR)/usr/lib/pkgconfig/
+ touch $@
+
+install-dev: $(STAGING_DIR)/usr/lib/libsqlite.so
+
+uninstall-dev:
+ rm -rf \
+ $(STAGING_DIR)/usr/include/sqlite.h \
+ $(STAGING_DIR)/usr/lib/libsqlite.{a,so*} \
+ $(STAGING_DIR)/usr/lib/pkgconfig/sqlite.pc \
+
+compile: install-dev
+clean: uninstall-dev
diff --git a/openwrt/package/sqlite2/ipkg/libsqlite2.control b/openwrt/package/sqlite2/ipkg/libsqlite2.control
new file mode 100644
index 0000000000..9bdb2d9046
--- /dev/null
+++ b/openwrt/package/sqlite2/ipkg/libsqlite2.control
@@ -0,0 +1,6 @@
+Package: libsqlite2
+Priority: optional
+Section: libs
+Maintainer: Nico <nthill@free.fr>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/sqlite2/
+Description: Self-contained, embeddable, zero-configuration SQL database engine (v2.x)
diff --git a/openwrt/package/sqlite2/ipkg/sqlite2-cli.control b/openwrt/package/sqlite2/ipkg/sqlite2-cli.control
new file mode 100644
index 0000000000..a8c40c6fa5
--- /dev/null
+++ b/openwrt/package/sqlite2/ipkg/sqlite2-cli.control
@@ -0,0 +1,7 @@
+Package: sqlite2-cli
+Priority: optional
+Section: libs
+Maintainer: Nico <nthill@free.fr>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/sqlite2/
+Description: Command Line Interface (CLI) for SQLite (v2.x)
+Depends: libsqlite2, libncurses, libreadline