aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-07-05 08:26:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-07-05 08:26:51 +0000
commit6bd692c4d630ba8b6bd7b281bf72fa690ba835cd (patch)
treedd9b0a70e42beae8c57e9a130cefb73bf396b33d
parent085697d0bd6b9a80541167540f61b1d11938bc7d (diff)
downloadupstream-6bd692c4d630ba8b6bd7b281bf72fa690ba835cd.tar.gz
upstream-6bd692c4d630ba8b6bd7b281bf72fa690ba835cd.tar.bz2
upstream-6bd692c4d630ba8b6bd7b281bf72fa690ba835cd.zip
ar71xx: add profile and build image for the Atheros AP136 reference board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32609 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/generic/profiles/atheros.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile8
2 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/atheros.mk b/target/linux/ar71xx/generic/profiles/atheros.mk
index 4ce4cd5129..8e79f4cd5a 100644
--- a/target/linux/ar71xx/generic/profiles/atheros.mk
+++ b/target/linux/ar71xx/generic/profiles/atheros.mk
@@ -38,6 +38,17 @@ endef
$(eval $(call Profile,AP121MINI))
+define Profile/AP136
+ NAME:=Atheros AP136 reference board
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage
+endef
+
+define Profile/AP136/Description
+ Package set optimized for the Atheros AP136 reference board.
+endef
+
+$(eval $(call Profile,AP136))
+
define Profile/AP81
NAME:=Atheros AP81 reference board
PACKAGES:=kmod-usb-core kmod-usb2
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 108f836c9a..a398242265 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -709,6 +709,13 @@ define Image/Build/Profile/DB120
$(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,db120,$(db120_cmdline),$(db120_mtdlayout),1441792,6488064,RKuImage)
endef
+ap136_cmdline=board=AP136 console=ttyS0,115200
+ap136_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6336k(rootfs),1408k(kernel),64k(mib0),64k(art)ro,7744k@0x50000(firmware)
+define Image/Build/Profile/AP136
+ $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,ap136,$(ap136_cmdline),$(ap136_mtdlayout),1441792,6488064,RKuImage)
+endef
+
+
pb42_cmdline=board=PB42 console=ttyS0,115200
define Image/Build/Profile/PB42
$(call Image/Build/Template/$(fs_64k)/$(1),PB4X,pb42,$(pb42_cmdline))
@@ -1070,6 +1077,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/AP113,$(1))
$(call Image/Build/Profile/AP121,$(1))
$(call Image/Build/Profile/AP121MINI,$(1))
+ $(call Image/Build/Profile/AP136,$(1))
$(call Image/Build/Profile/AP81,$(1))
$(call Image/Build/Profile/AP83,$(1))
$(call Image/Build/Profile/A02RBW300N,$(1))