aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Lippers-Hollmann <s.l-h@gmx.de>2018-12-16 21:04:15 +0100
committerChristian Lamparter <chunkeey@gmail.com>2018-12-17 00:21:34 +0100
commit6b63595fec8170d0193c093fa68bd46dd6bf475f (patch)
treec7c39e8a404abed417edf29eed3073f7539be2ed
parent6c3c4436ee1af0742de7c29bd9c4f10990ed2019 (diff)
downloadupstream-6b63595fec8170d0193c093fa68bd46dd6bf475f.tar.gz
upstream-6b63595fec8170d0193c093fa68bd46dd6bf475f.tar.bz2
upstream-6b63595fec8170d0193c093fa68bd46dd6bf475f.zip
ipq806x: drop kernel/ rootfs partition images for the ZyXEL NBG6817
Since commit 8e9a59a6b924469c0061d4bd945ae0c6dbfdecfe (build: add mkrasimage) a proper factory image can be provided for the ZyXEL NBG6817, which can be flashed from the OEM firmware or used for tftp based push-button recovery, therefore the previously used partition images for mmcblk0p5-rootfs.bin and mmcblk0p4-kernel.bin are no longer required (and using them properly has always been slightly difficult and risky) and can now be dropped from the image generation code. Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
-rw-r--r--target/linux/ipq806x/image/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index 5902eee6ac..6109765041 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -67,11 +67,9 @@ define Device/ZyXELImage
KERNEL_SUFFIX := -uImage
KERNEL = kernel-bin | append-dtb | uImage none | pad-to $${KERNEL_SIZE}
KERNEL_NAME := zImage
- IMAGES := factory.bin sysupgrade.bin mmcblk0p5-rootfs.bin mmcblk0p4-kernel.bin
+ IMAGES := factory.bin sysupgrade.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to $$$$(BLOCKSIZE) | zyxel-ras-image separate-kernel
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to $$$${BLOCKSIZE} | sysupgrade-tar rootfs=$$$$@ | append-metadata
- IMAGE/mmcblk0p5-rootfs.bin := append-rootfs | pad-rootfs | pad-to $$$${BLOCKSIZE}
- IMAGE/mmcblk0p4-kernel.bin := append-kernel
endef
define Device/compex_wpq864