aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-27 15:35:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-27 15:35:00 +0000
commit6afd1725f1be2b83947d91ac5b5044cee1e5c3db (patch)
tree6707bef9a79be240859c3ffbdb7a61bfebcdbdfe
parent4acdbb1d87e11843409ceacd08d3477c1976c583 (diff)
downloadupstream-6afd1725f1be2b83947d91ac5b5044cee1e5c3db.tar.gz
upstream-6afd1725f1be2b83947d91ac5b5044cee1e5c3db.tar.bz2
upstream-6afd1725f1be2b83947d91ac5b5044cee1e5c3db.zip
base-files: fix detection of standalone ldd
When standalone ldd is selected in config the binary is installed in /usr/bin/ldd. Signed-off-by: Michael Heimpold <mhei@heimpold.de> SVN-Revision: 32891
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/etc/profile2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 67e17111cf..a9102104bf 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=111
+PKG_RELEASE:=112
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/profile b/package/base-files/files/etc/profile
index 4bdfa5787a..282a747e52 100644
--- a/package/base-files/files/etc/profile
+++ b/package/base-files/files/etc/profile
@@ -12,4 +12,4 @@ export PS1='\u@\h:\w\$ '
[ -z "$KSH_VERSION" -o \! -s /etc/mkshrc ] || . /etc/mkshrc
[ -x /usr/bin/arp ] || arp() { cat /proc/net/arp; }
-[ -z /bin/ldd ] || ldd() { LD_TRACE_LOADED_OBJECTS=1 $*; }
+[ -z /usr/bin/ldd ] || ldd() { LD_TRACE_LOADED_OBJECTS=1 $*; }