aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2017-02-23 05:18:39 +0100
committerJohn Crispin <john@phrozen.org>2017-03-06 07:16:50 +0100
commit6a772cb953c4c36dfdf49365937b71017652562a (patch)
treea04abe3b65fb527f7b3264b274cb71a37c760171
parentcbfaba8f3f0f78275b9c0ca3d7f655d5abc1f1be (diff)
downloadupstream-6a772cb953c4c36dfdf49365937b71017652562a.tar.gz
upstream-6a772cb953c4c36dfdf49365937b71017652562a.tar.bz2
upstream-6a772cb953c4c36dfdf49365937b71017652562a.zip
mountd: drop in favour of blockd
Signed-off-by: John Crispin <john@phrozen.org>
-rw-r--r--package/system/mountd/Makefile45
-rw-r--r--package/system/mountd/files/mountd.config3
-rwxr-xr-xpackage/system/mountd/files/mountd.init22
3 files changed, 0 insertions, 70 deletions
diff --git a/package/system/mountd/Makefile b/package/system/mountd/Makefile
deleted file mode 100644
index 70275617fa..0000000000
--- a/package/system/mountd/Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright (C) 2009-2012 OpenWrt.org
-# All rights reserved.
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=mountd
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL=$(LEDE_GIT)/project/mountd.git
-PKG_SOURCE_DATE:=2016-12-19
-PKG_SOURCE_VERSION:=dd5799c9f8cc7a01c0572c067bf907b37cdd7d04
-PKG_MIRROR_HASH:=cdc9f61bf4ad4b5d02b7cad435de1566b53306ed532fe39d099ed91eec6c405c
-CMAKE_INSTALL:=1
-
-PKG_MAINTAINER:=John Crispin <john@phrozen.org>
-PKG_LICENSE:=GPL-2.0
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-define Package/mountd
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=OpenWrt automount daemon
- DEPENDS:=+uci +kmod-fs-autofs4
- URL:=http://www.openwrt.org
-endef
-
-define Package/mountd/description
- openwrt automount daemon
-endef
-
-define Package/mountd/conffiles
-/etc/config/mountd
-endef
-
-define Package/mountd/install
- $(INSTALL_DIR) $(1)/sbin/ $(1)/etc/config/ $(1)/etc/init.d/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/mountd $(1)/sbin/
- $(INSTALL_DATA) ./files/mountd.config $(1)/etc/config/mountd
- $(INSTALL_BIN) ./files/mountd.init $(1)/etc/init.d/mountd
-endef
-
-$(eval $(call BuildPackage,mountd))
diff --git a/package/system/mountd/files/mountd.config b/package/system/mountd/files/mountd.config
deleted file mode 100644
index 5610129501..0000000000
--- a/package/system/mountd/files/mountd.config
+++ /dev/null
@@ -1,3 +0,0 @@
-config mountd mountd
- option timeout 60
- option path /tmp/mounts/
diff --git a/package/system/mountd/files/mountd.init b/package/system/mountd/files/mountd.init
deleted file mode 100755
index 772bd6ed5a..0000000000
--- a/package/system/mountd/files/mountd.init
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=80
-
-SERVICE_DAEMONIZE=1
-SERVICE_WRITE_PID=1
-SERVICE_PID_FILE=/var/run/mountd.pid
-
-MOUNTD_BIN=/sbin/mountd
-
-start()
-{
- P="$(uci get mountd.mountd.path)"
- [ -n "$P" -a ! -f "$P" ] && mkdir -p $P
-
- service_start $MOUNTD_BIN -f
-}
-
-stop()
-{
- service_stop $MOUNTD_BIN
-}