aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Bazalevsky <rvb@rvb.name>2019-12-05 17:21:28 +0300
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 12:20:09 +0100
commit69fff339e965d508b4fc12ffdc2a170efe9c98b1 (patch)
tree1d3127a3aa48f9710f27d990f6ab87d5c98e7a73
parent3a4ad758f537bd4cc24163f76d2865179484541c (diff)
downloadupstream-69fff339e965d508b4fc12ffdc2a170efe9c98b1.tar.gz
upstream-69fff339e965d508b4fc12ffdc2a170efe9c98b1.tar.bz2
upstream-69fff339e965d508b4fc12ffdc2a170efe9c98b1.zip
sunxi: add support for FriendlyARM Nano PI NEO Air dev board
Hardware: Allwinner H3 upto 1.2GHz 512MB DDR3 RAM 8GB on-board eMMC - mountable, can be used as boot with custom boot.scr microSD-card slot WiFi 802.11n (AP6212A) - working Bluetooth (AP6212A) - not working for now Micro-USB OTG + 2*USB headers UART 3.3V - working GPIO/I2C/SPI 2.54mm headers Standard sunxi SD-card installation procedure - copy image to SD card, insert in into slot and boot. First time you will need UART adapter to enable on-board wireless (or just build custom image with enabled WiFi). To boot from eMMC: - boot from SD - copy SD image to emmc (dd bs=... if=.... of=/dev/mmcblk2) - mount eMMC boot partition and replace boot script on it - unmount, reboot To use i2c, spi and more uarts - replace dtb on boot partition with fixed one (use dtc or fdt-tools). Signed-off-by: Roman Bazalevsky <rvb@rvb.name> [rebase onto device name consolidation patches] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--package/boot/uboot-sunxi/Makefile7
-rw-r--r--target/linux/sunxi/image/cortex-a7.mk12
2 files changed, 19 insertions, 0 deletions
diff --git a/package/boot/uboot-sunxi/Makefile b/package/boot/uboot-sunxi/Makefile
index ce39fe792d..eef4c56f53 100644
--- a/package/boot/uboot-sunxi/Makefile
+++ b/package/boot/uboot-sunxi/Makefile
@@ -138,6 +138,12 @@ define U-Boot/nanopi_m1_plus
BUILD_DEVICES:=friendlyarm_nanopi-m1-plus
endef
+define U-Boot/nanopi_neo_air
+ BUILD_SUBTARGET:=cortexa7
+ NAME:=U-Boot for NanoPi NEO Air (H3)
+ BUILD_DEVICES:=friendlyarm_nanopi-neo-air
+endef
+
define U-Boot/nanopi_neo
BUILD_SUBTARGET:=cortexa7
NAME:=U-Boot for NanoPi NEO (H3)
@@ -274,6 +280,7 @@ UBOOT_TARGETS := \
Lamobo_R1 \
nanopi_m1_plus \
nanopi_neo \
+ nanopi_neo_air \
nanopi_neo_plus2 \
nanopi_neo2 \
orangepi_zero \
diff --git a/target/linux/sunxi/image/cortex-a7.mk b/target/linux/sunxi/image/cortex-a7.mk
index 90a355fd3a..83b313a378 100644
--- a/target/linux/sunxi/image/cortex-a7.mk
+++ b/target/linux/sunxi/image/cortex-a7.mk
@@ -160,6 +160,18 @@ endef
TARGET_DEVICES += friendlyarm_nanopi-neo
+define Device/friendlyarm_nanopi-neo-air
+ DEVICE_VENDOR := FriendlyARM
+ DEVICE_MODEL := NanoPi NEO Air
+ DEVICE_PACKAGES := kmod-rtc-sunxi \
+ kmod-leds-gpio kmod-ledtrig-heartbeat \
+ kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
+ SUNXI_SOC := sun8i-h3
+endef
+
+TARGET_DEVICES += friendlyarm_nanopi-neo-air
+
+
define Device/xunlong_orangepi-one
DEVICE_VENDOR := Xunlong
DEVICE_MODEL := Orange Pi One