aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2008-03-31 08:05:30 +0000
committerAndy Boyett <agb@openwrt.org>2008-03-31 08:05:30 +0000
commit698aeff1cb571abdb41c1ccfa213a63f03d4dae7 (patch)
treef846a89a86dd504c902754e4b69a2b04624b4201
parentceb7720c8dd3f47f7682a16be606745866a7cdbe (diff)
downloadupstream-698aeff1cb571abdb41c1ccfa213a63f03d4dae7.tar.gz
upstream-698aeff1cb571abdb41c1ccfa213a63f03d4dae7.tar.bz2
upstream-698aeff1cb571abdb41c1ccfa213a63f03d4dae7.zip
Add a generic Broadcom USB profile.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10695 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/brcm-2.4/profiles/USBGeneric.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/brcm-2.4/profiles/USBGeneric.mk b/target/linux/brcm-2.4/profiles/USBGeneric.mk
new file mode 100644
index 0000000000..85bad87205
--- /dev/null
+++ b/target/linux/brcm-2.4/profiles/USBGeneric.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/USBGeneric
+ NAME:=Generic USB
+ PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 wlc nas kmod-wlcompat
+endef
+
+define Profile/USBGeneric/Description
+ Package set with for Broadcom routers with USB/USB2 (OHCI/EHCI) support.
+ Includes the WRTSL54GS, WL-520gU, WL-500gP v2, any other BCM5354 routers
+ with USB.
+endef
+$(eval $(call Profile,USBGeneric))
+