aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-11-26 15:39:25 +0100
committerMathias Kresin <dev@kresin.me>2018-11-27 21:11:54 +0100
commit68d77241cdb979eebb66549c242d5362adaaecdc (patch)
tree4c50a1e66be98810b5bea8bc90e03c87918f4506
parente0def989e8659cc130852f84f52607652bddb201 (diff)
downloadupstream-68d77241cdb979eebb66549c242d5362adaaecdc.tar.gz
upstream-68d77241cdb979eebb66549c242d5362adaaecdc.tar.bz2
upstream-68d77241cdb979eebb66549c242d5362adaaecdc.zip
ath79: rename glinet x750
The boardname is gl-x750 and is already used for the led names. Signed-off-by: Mathias Kresin <dev@kresin.me>
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds4
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network2
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata2
-rw-r--r--target/linux/ath79/dts/qca9533_glinet_gl-x750.dts (renamed from target/linux/ath79/dts/qca9533_glinet_x750.dts)0
-rw-r--r--target/linux/ath79/dts/qca9533_glinet_x750.dtsi2
-rw-r--r--target/linux/ath79/image/generic.mk6
6 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index 7945ecba1f..06fb8f4791 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -33,8 +33,8 @@ etactica,eg200)
ucidef_set_led_oneshot "modbus" "Modbus" "$boardname:red:modbus" "100" "33"
ucidef_set_led_default "etactica" "etactica" "$boardname:red:etactica" "ignore"
;;
-glinet,x750)
- ucidef_set_led_netdev "wan" "WAN" "gl-x750:green:wan" "eth0"
+glinet,gl-x750)
+ ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth0"
;;
netgear,wnr612-v2|\
on,n150r)
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index 202820d50b..f471882213 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -75,7 +75,7 @@ ath79_setup_interfaces()
;;
glinet,ar150|\
glinet,ar300m|\
- glinet,x750)
+ glinet,gl-x750)
ucidef_set_interfaces_lan_wan "eth1" "eth0"
;;
iodata,etg3-r|\
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index cbc5c96170..82c23e3079 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -87,7 +87,7 @@ board=$(board_name)
case "$FIRMWARE" in
"ath10k/cal-pci-0000:00:00.0.bin")
case $board in
- glinet,x750)
+ glinet,gl-x750)
ath10kcal_extract "art" 20480 2116
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
;;
diff --git a/target/linux/ath79/dts/qca9533_glinet_x750.dts b/target/linux/ath79/dts/qca9533_glinet_gl-x750.dts
index 7313f96d51..7313f96d51 100644
--- a/target/linux/ath79/dts/qca9533_glinet_x750.dts
+++ b/target/linux/ath79/dts/qca9533_glinet_gl-x750.dts
diff --git a/target/linux/ath79/dts/qca9533_glinet_x750.dtsi b/target/linux/ath79/dts/qca9533_glinet_x750.dtsi
index b84c332137..e1f95d5f04 100644
--- a/target/linux/ath79/dts/qca9533_glinet_x750.dtsi
+++ b/target/linux/ath79/dts/qca9533_glinet_x750.dtsi
@@ -4,7 +4,7 @@
#include "qca9533.dtsi"
/ {
- compatible = "glinet,x750", "qca,qca9533";
+ compatible = "glinet,gl-x750", "qca,qca9533";
model = "GL.iNet GL-X750";
keys {
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 9bdd8f6e35..48d477dd9e 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -183,13 +183,13 @@ define Device/glinet_ar300m_nor
endef
TARGET_DEVICES += glinet_ar300m_nor
-define Device/glinet_x750
+define Device/glinet_gl-x750
ATH_SOC := qca9533
- DEVICE_TITLE := GL.iNet GL-ARX750
+ DEVICE_TITLE := GL.iNet GL-X750
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k ath10k-firmware-qca9887
IMAGE_SIZE := 16000k
endef
-TARGET_DEVICES += glinet_x750
+TARGET_DEVICES += glinet_gl-x750
define Device/iodata_etg3-r
ATH_SOC := ar9342