aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-05 21:30:33 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-05 21:30:33 +0000
commit68087bf0e5ae900275a5cd29bd7a572332691a3f (patch)
tree6c1342225e2eec6a79ae0b80c76fc94497c4e41a
parent63b620b6f4ae27c8d4f057ecfb5e7e9603d1e217 (diff)
downloadupstream-68087bf0e5ae900275a5cd29bd7a572332691a3f.tar.gz
upstream-68087bf0e5ae900275a5cd29bd7a572332691a3f.tar.bz2
upstream-68087bf0e5ae900275a5cd29bd7a572332691a3f.zip
add libmissing (implementing functions missing from uClibc)
SVN-Revision: 2055
-rw-r--r--openwrt/toolchain/Makefile2
-rw-r--r--openwrt/toolchain/libmissing/Makefile30
-rw-r--r--openwrt/toolchain/libmissing/files/math.c35
3 files changed, 66 insertions, 1 deletions
diff --git a/openwrt/toolchain/Makefile b/openwrt/toolchain/Makefile
index 2b1358b123..c56f263bcc 100644
--- a/openwrt/toolchain/Makefile
+++ b/openwrt/toolchain/Makefile
@@ -1,6 +1,6 @@
# Main makefile for the toolchain
include $(TOPDIR)/rules.mk
-TARGETS:=sed utils binutils gcc uClibc ipkg-utils gdb
+TARGETS:=sed utils binutils gcc uClibc ipkg-utils gdb libmissing
TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS))
TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
diff --git a/openwrt/toolchain/libmissing/Makefile b/openwrt/toolchain/libmissing/Makefile
new file mode 100644
index 0000000000..bd3749dfb0
--- /dev/null
+++ b/openwrt/toolchain/libmissing/Makefile
@@ -0,0 +1,30 @@
+include $(TOPDIR)/rules.mk
+
+LIBMISSING_DIR:=$(TOOL_BUILD_DIR)/libmissing
+
+LIBMISSING_SRCS+=./files/math.c
+LIBMISSING_OBJS:=$(patsubst ./files/%.c,$(LIBMISSING_DIR)/%.o,$(LIBMISSING_SRCS))
+
+$(LIBMISSING_DIR)/.prepared:
+ mkdir -p $(LIBMISSING_DIR)
+ touch $@
+
+$(LIBMISSING_OBJS): $(LIBMISSING_DIR)/%.o : ./files/%.c
+ $(TARGET_CC) $(TARGET_CFLAGS) -c $< -o $@
+
+$(LIBMISSING_DIR)/libmissing.a: $(LIBMISSING_OBJS)
+ $(TARGET_CROSS)ar rc $(LIBMISSING_DIR)/libmissing.a $(LIBMISSING_OBJS)
+
+$(STAGING_DIR)/usr/lib/libmissing.a: $(LIBMISSING_DIR)/libmissing.a
+ mkdir -p $(STAGING_DIR)/usr/lib
+ cp -fpR $< $@
+ touch -c $@
+
+source:
+prepare: $(LIBMISSING_DIR)/.prepared
+compile: $(LIBMISSING_DIR)/libmissing.a
+install: $(STAGING_DIR)/usr/lib/libmissing.a
+clean:
+ rm -rf \
+ $(STAGING_DIR)/usr/lib/libmissing.a \
+ $(LIBMISSING_DIR) \
diff --git a/openwrt/toolchain/libmissing/files/math.c b/openwrt/toolchain/libmissing/files/math.c
new file mode 100644
index 0000000000..cc8a661ac5
--- /dev/null
+++ b/openwrt/toolchain/libmissing/files/math.c
@@ -0,0 +1,35 @@
+/* vi: set sw=4 ts=4: */
+
+/* cosf for uClibc
+ *
+ * wrapper for cos(x)
+ */
+
+#include "math.h"
+
+#ifdef __STDC__
+ float cosf(float x) /* wrapper cos */
+#else
+ float cosf(x) /* wrapper cos */
+ float x;
+#endif
+{
+ return (float) cos( (double)x );
+}
+
+/* sinf for uClibc
+ *
+ * wrapper for sin(x)
+ */
+
+#include "math.h"
+
+#ifdef __STDC__
+ float sinf(float x) /* wrapper sin */
+#else
+ float sinf(x) /* wrapper sin */
+ float x;
+#endif
+{
+ return (float) sin( (double)x );
+}