aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOldřich Jedlička <oldium.pro@gmail.com>2019-01-29 22:25:33 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-02-17 19:22:39 +0100
commit66e875a07033cdcfd8c4a16940d4acfe63c60202 (patch)
treec287ab4297b60ac3020e8d707f6ec216aca453e4
parente711fd48be0830d5acdecb75768d93c32940aff9 (diff)
downloadupstream-66e875a07033cdcfd8c4a16940d4acfe63c60202.tar.gz
upstream-66e875a07033cdcfd8c4a16940d4acfe63c60202.tar.bz2
upstream-66e875a07033cdcfd8c4a16940d4acfe63c60202.zip
kernel: Added required dependencies for socket match.
This applies to kernel 4.10 and newer. See https://github.com/torvalds/linux/commit/8db4c5be88f62ffd7a552f70687a10c614dc697b The above commit added to kernel 4.10 added new dependency for building the NETFILTER_XT_MATCH_SOCKET (xt_socket.ko) module. The NF_SOCKET_IPVx options (both of them) need to be enabled in order to build the NETFILTER_XT_MATCH_SOCKET module. Without the change the module is not built. Signed-off-by: Oldřich Jedlička <oldium.pro@gmail.com>
-rw-r--r--package/kernel/linux/modules/netfilter.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index ef8b5a33c1..6c78394297 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -647,6 +647,8 @@ define KernelPackage/ipt-tproxy
TITLE:=Transparent proxying support
DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-nf-conntrack6 +IPV6:kmod-ip6tables
KCONFIG:= \
+ CONFIG_NF_SOCKET_IPV4 \
+ CONFIG_NF_SOCKET_IPV6 \
CONFIG_NETFILTER_XT_MATCH_SOCKET \
CONFIG_NETFILTER_XT_TARGET_TPROXY
FILES:= \