aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-25 18:20:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-25 18:20:34 +0000
commit653f61fb3eb23d5cd30e1577190af038a6a47fbd (patch)
tree999ecb0f73415ee1aba71780780f271a384973ab
parent738ca6f6571b30c80c5e64d2c40b0b3630ec3c29 (diff)
downloadupstream-653f61fb3eb23d5cd30e1577190af038a6a47fbd.tar.gz
upstream-653f61fb3eb23d5cd30e1577190af038a6a47fbd.tar.bz2
upstream-653f61fb3eb23d5cd30e1577190af038a6a47fbd.zip
clean up a few things in image build makefiles and fix unnecessary grub rebuilds
SVN-Revision: 6360
-rw-r--r--target/Makefile2
-rw-r--r--target/linux/brcm-2.4/image/Makefile15
-rw-r--r--target/linux/brcm63xx-2.6/image/Makefile2
-rw-r--r--target/linux/magicbox-2.6/image/Makefile3
-rw-r--r--target/linux/rdc-2.6/image/Makefile3
-rw-r--r--target/linux/x86-2.6/image/grub/Makefile36
6 files changed, 18 insertions, 43 deletions
diff --git a/target/Makefile b/target/Makefile
index 3f97b9a14d..724ac4450d 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -20,7 +20,7 @@ IMAGE_DIR:=linux/$(BOARD)-$(KERNEL)/image
download: $(patsubst %,%-download,$(TARGETS-y))
prepare: linux-prepare
compile: linux-compile image_compile
-install: image_clean linux-install image_install
+install: linux-install image_install
ifeq ($(CONFIG_SDK),y)
install: sdk_install
diff --git a/target/linux/brcm-2.4/image/Makefile b/target/linux/brcm-2.4/image/Makefile
index 91cf60ce30..41bd1c89cd 100644
--- a/target/linux/brcm-2.4/image/Makefile
+++ b/target/linux/brcm-2.4/image/Makefile
@@ -7,21 +7,18 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Build/Compile
- rm -f $(KDIR)/loader.gz
- $(MAKE) -C lzma-loader \
- BUILD_DIR="$(KDIR)" \
- TARGET="$(KDIR)" \
- install
- echo -ne "\\x00" >> $(KDIR)/loader.gz
-endef
-
define Build/Clean
$(MAKE) -C lzma-loader clean
endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+ rm -f $(KDIR)/loader.gz
+ $(MAKE) -C lzma-loader \
+ BUILD_DIR="$(KDIR)" \
+ TARGET="$(KDIR)" \
+ clean install
+ echo -ne "\\x00" >> $(KDIR)/loader.gz
endef
ifneq ($(KERNEL),2.4)
diff --git a/target/linux/brcm63xx-2.6/image/Makefile b/target/linux/brcm63xx-2.6/image/Makefile
index 5c16f0541c..51c658a093 100644
--- a/target/linux/brcm63xx-2.6/image/Makefile
+++ b/target/linux/brcm63xx-2.6/image/Makefile
@@ -23,7 +23,7 @@ endef
define Image/Prepare
cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
- $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) compile
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
endef
define Image/Build
diff --git a/target/linux/magicbox-2.6/image/Makefile b/target/linux/magicbox-2.6/image/Makefile
index 77ff88f521..fe68f35d5e 100644
--- a/target/linux/magicbox-2.6/image/Makefile
+++ b/target/linux/magicbox-2.6/image/Makefile
@@ -7,9 +7,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Build/Clean
-endef
-
define Image/Prepare
cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(KDIR)/uImage
endef
diff --git a/target/linux/rdc-2.6/image/Makefile b/target/linux/rdc-2.6/image/Makefile
index 078e754e10..f8398baadb 100644
--- a/target/linux/rdc-2.6/image/Makefile
+++ b/target/linux/rdc-2.6/image/Makefile
@@ -7,9 +7,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Build/Clean
-endef
-
define Image/Prepare
$(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/bzImage
endef
diff --git a/target/linux/x86-2.6/image/grub/Makefile b/target/linux/x86-2.6/image/grub/Makefile
index 365b327622..d37803012c 100644
--- a/target/linux/x86-2.6/image/grub/Makefile
+++ b/target/linux/x86-2.6/image/grub/Makefile
@@ -23,34 +23,19 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/grub-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
ifeq ($(HOST_ARCH),x86_64)
- define Build/Configure
- (cd $(PKG_BUILD_DIR); \
- LDFLAGS="-static" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- $(DISABLE_NLS) \
- --disable-auto-linux-mem-opt \
- )
- endef
+CONFIGURE_FLAGS:= \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME)
else
- define Build/Configure
+CONFIGURE_FLAGS:=
+endif
+
+define Build/Configure
(cd $(PKG_BUILD_DIR); \
LDFLAGS="-static" \
./configure \
+ $(CONFIGURE_FLAGS) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
@@ -66,8 +51,7 @@ else
$(DISABLE_NLS) \
--disable-auto-linux-mem-opt \
)
- endef
-endif
+endef
#
# ./configure detects whether the host compiler supports