aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-15 13:04:57 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-15 13:04:57 +0000
commit611adf9b7af761ca2a9a781b6f92aa67a2d658b9 (patch)
tree58a7f6589c0a58ebaf90391a2af712f8dbc84ea1
parentb117fe7e0361b2513fbbb5075c70fb4a76bb05aa (diff)
downloadupstream-611adf9b7af761ca2a9a781b6f92aa67a2d658b9.tar.gz
upstream-611adf9b7af761ca2a9a781b6f92aa67a2d658b9.tar.bz2
upstream-611adf9b7af761ca2a9a781b6f92aa67a2d658b9.zip
Fix dhcp-forwarder build, move init-script to ./files/
SVN-Revision: 909
-rw-r--r--openwrt/package/Makefile2
-rw-r--r--openwrt/package/dhcp-forwarder/Config.in2
-rw-r--r--openwrt/package/dhcp-forwarder/Makefile4
-rw-r--r--openwrt/package/dhcp-forwarder/files/dhcp-fwd.init (renamed from openwrt/package/dhcp-forwarder/ipkg/dhcp-forwarder.init)0
4 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 7fc50c1be4..872489fb97 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -74,7 +74,7 @@ package-$(BR2_PACKAGE_USBUTILS) += usbutils
package-$(BR2_PACKAGE_WIRELESS_TOOLS) += wireless-tools
package-$(BR2_PACKAGE_WOL) += wol
package-$(BR2_PACKAGE_ZLIB) += zlib
-package-$(BR2_PACKAGE_DHCPFWD) += dhcp-forwarder
+package-$(BR2_PACKAGE_DHCP_FORWARDER) += dhcp-forwarder
package-$(BR2_PACKAGE_LIBGD) += libgd
package-$(BR2_PACKAGE_LIBNET) += libnet
package-$(BR2_PACKAGE_LIBMYSQLCLIENT) += mysql
diff --git a/openwrt/package/dhcp-forwarder/Config.in b/openwrt/package/dhcp-forwarder/Config.in
index 34ff1c0167..7cddf97478 100644
--- a/openwrt/package/dhcp-forwarder/Config.in
+++ b/openwrt/package/dhcp-forwarder/Config.in
@@ -1,5 +1,5 @@
config BR2_PACKAGE_DHCP_FORWARDER
- tristate "dhcp-forwarder (a DHCP relay agent)"
+ tristate "dhcp-forwarder - a DHCP relay agent"
default m if CONFIG_DEVEL
help
A DHCP relay agent
diff --git a/openwrt/package/dhcp-forwarder/Makefile b/openwrt/package/dhcp-forwarder/Makefile
index 7b9f23841f..7da1928982 100644
--- a/openwrt/package/dhcp-forwarder/Makefile
+++ b/openwrt/package/dhcp-forwarder/Makefile
@@ -56,10 +56,10 @@ $(PKG_BUILD_DIR)/.built:
touch $(PKG_BUILD_DIR)/.built
$(IPKG_DHCP_FORWARDER):
- install -m0755 -d $(IDIR_DHCP_FORWARDER)/etc/init.d
- install -m0755 ./ipkg/$(PKG_NAME).init $(IDIR_DHCP_FORWARDER)/etc/init.d/dhcp-fwd
install -m0755 -d $(IDIR_DHCP_FORWARDER)/etc
install -m0644 $(PKG_BUILD_DIR)/contrib/dhcp-fwd.conf $(IDIR_DHCP_FORWARDER)/etc/
+ install -m0755 -d $(IDIR_DHCP_FORWARDER)/etc/init.d
+ install -m0755 ./files/dhcp-fwd.init $(IDIR_DHCP_FORWARDER)/etc/init.d/dhcp-fwd
install -m0755 -d $(IDIR_DHCP_FORWARDER)/usr/bin
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/dhcp-fwd $(IDIR_DHCP_FORWARDER)/usr/bin/
$(RSTRIP) $(IDIR_DHCP_FORWARDER)
diff --git a/openwrt/package/dhcp-forwarder/ipkg/dhcp-forwarder.init b/openwrt/package/dhcp-forwarder/files/dhcp-fwd.init
index 6ad3858e89..6ad3858e89 100644
--- a/openwrt/package/dhcp-forwarder/ipkg/dhcp-forwarder.init
+++ b/openwrt/package/dhcp-forwarder/files/dhcp-fwd.init