aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-12-15 01:11:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-12-15 01:11:38 +0000
commit5d608ab146ff4c825212facfcd3cbea194e46163 (patch)
tree0ea104bd8d196c519509724eed4e15ad75f96b47
parent27b694c330b2f14e29a87ad0683db17827f60f8e (diff)
downloadupstream-5d608ab146ff4c825212facfcd3cbea194e46163.tar.gz
upstream-5d608ab146ff4c825212facfcd3cbea194e46163.tar.bz2
upstream-5d608ab146ff4c825212facfcd3cbea194e46163.zip
update gs v4 pattern so that the latest linksys firmware accepts it
SVN-Revision: 2678
-rw-r--r--openwrt/target/linux/image/brcm/Makefile4
-rw-r--r--openwrt/target/utils/src/addpattern.c2
2 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/target/linux/image/brcm/Makefile b/openwrt/target/linux/image/brcm/Makefile
index 530dd1e4e8..49c94f600f 100644
--- a/openwrt/target/linux/image/brcm/Makefile
+++ b/openwrt/target/linux/image/brcm/Makefile
@@ -54,7 +54,7 @@ $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$
$(STAGING_DIR)/bin/addpattern -4 -p W54G -v v4.20.6 -i $< -o $@ -g
$(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
- $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.0 -i $< -o $@ -g
+ $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.2 -i $< -o $@ -g
install: $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54g3g-$(KERNEL)-$(FSNAME).bin
endif
@@ -78,7 +78,7 @@ $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$
$(STAGING_DIR)/bin/addpattern -4 -p W54G -v v4.20.6 -i $< -o $@ -g
$(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
- $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.0 -i $< -o $@ -g
+ $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.2 -i $< -o $@ -g
install: $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54g3g-$(KERNEL)-$(FSNAME).bin
endif
diff --git a/openwrt/target/utils/src/addpattern.c b/openwrt/target/utils/src/addpattern.c
index 67f9da285e..9962a67920 100644
--- a/openwrt/target/utils/src/addpattern.c
+++ b/openwrt/target/utils/src/addpattern.c
@@ -138,7 +138,7 @@ int main(int argc, char **argv)
break;
case '4':
/* V4 firmware sets the flags to 0x1f */
- hdr->hw_ver = 1;
+ hdr->hw_ver = 0;
hdr->flags = 0x1f;
break;