aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-02-11 23:30:30 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-12 13:55:45 +0100
commit5c651b029e2dfb5cc68b8803bf550e62da643289 (patch)
tree8e60494056b8775a8a3d4a5350117798debb8bdb
parent0caffa60af0a1823fe62290334216a548d6b3e09 (diff)
downloadupstream-5c651b029e2dfb5cc68b8803bf550e62da643289.tar.gz
upstream-5c651b029e2dfb5cc68b8803bf550e62da643289.tar.bz2
upstream-5c651b029e2dfb5cc68b8803bf550e62da643289.zip
kernel: fix kmod-rxrpc with kernel 4.9
rxkad will be build into af-rxrpc now and is of type boolean. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/kernel/linux/modules/netsupport.mk4
-rw-r--r--target/linux/generic/config-4.93
2 files changed, 5 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index dc6e0cbfe0..b2764e5f6b 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -924,8 +924,8 @@ define KernelPackage/rxrpc
CONFIG_AF_RXRPC_DEBUG=n
FILES:= \
$(LINUX_DIR)/net/rxrpc/af-rxrpc.ko \
- $(LINUX_DIR)/net/rxrpc/rxkad.ko
- AUTOLOAD:=$(call AutoLoad,30,rxkad af-rxrpc)
+ $(LINUX_DIR)/net/rxrpc/rxkad.ko@lt4.7
+ AUTOLOAD:=$(call AutoLoad,30,rxkad@lt4.7 af-rxrpc)
DEPENDS:= +kmod-crypto-manager +kmod-crypto-pcbc +kmod-crypto-fcrypt
endef
diff --git a/target/linux/generic/config-4.9 b/target/linux/generic/config-4.9
index b762e3b080..9deac117e0 100644
--- a/target/linux/generic/config-4.9
+++ b/target/linux/generic/config-4.9
@@ -98,6 +98,8 @@ CONFIG_AEABI=y
# CONFIG_AFS_FS is not set
# CONFIG_AF_KCM is not set
# CONFIG_AF_RXRPC is not set
+# CONFIG_AF_RXRPC_IPV6 is not set
+# CONFIG_AF_RXRPC_INJECT_LOSS is not set
# CONFIG_AGP is not set
# CONFIG_AHCI_CEVA is not set
# CONFIG_AHCI_IMX is not set
@@ -3544,6 +3546,7 @@ CONFIG_RTC_SYSTOHC_DEVICE="rtc0"
# CONFIG_RTS5208 is not set
CONFIG_RT_MUTEXES=y
# CONFIG_RUNTIME_DEBUG is not set
+CONFIG_RXKAD=y
CONFIG_RWSEM_GENERIC_SPINLOCK=y
# CONFIG_S2IO is not set
# CONFIG_SAMPLES is not set