aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Wegener <sven.wegener@stealer.net>2015-12-17 11:59:24 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2022-07-01 19:17:36 +0200
commit5c04efd2d7d9432f75843c3fd472458ad37d203d (patch)
tree314fd66dc2b96bb1ef929e771e66a8709bb2138f
parent04071cb111f290417074de130d34ae5895fd3a7b (diff)
downloadupstream-5c04efd2d7d9432f75843c3fd472458ad37d203d.tar.gz
upstream-5c04efd2d7d9432f75843c3fd472458ad37d203d.tar.bz2
upstream-5c04efd2d7d9432f75843c3fd472458ad37d203d.zip
toolchain: fix dangling symlink to self in FixupLibdir
This avoids a dangling symlink to self when reinstalling the toolchain: ./staging_dir/toolchain-mips_24kc_gcc-9.3.0_musl/lib/lib -> lib This is caused by the fact that in the toolchain dir we have 'lib64 -> lib' and on executing 'ln lib ./staging_dir/toolchain-mips_24kc_gcc-9.3.0_musl/lib64' ln dereference the symbolic link 'lib64' to 'lib' so the REAL command is 'ln lib ./staging_dir/toolchain-mips_24kc_gcc-9.3.0_musl/lib' this results in the dangling symlink to self. Signed-off-by: Sven Wegener <sven.wegener@stealer.net> [ add more details to the commit description and fix title ] Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
-rw-r--r--include/toolchain-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/toolchain-build.mk b/include/toolchain-build.mk
index b7a253b71b..87ba8313df 100644
--- a/include/toolchain-build.mk
+++ b/include/toolchain-build.mk
@@ -18,6 +18,6 @@ define FixupLibdir
mkdir -p $(1)/lib; \
mv $(1)/lib64/* $(1)/lib/; \
rm -rf $(1)/lib64; \
+ ln -sf lib $(1)/lib64; \
fi
- ln -sf lib $(1)/lib64
endef