aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Azarenko <roman.azarenko@iopsys.eu>2022-01-25 18:16:30 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2022-01-28 22:12:18 +0100
commit5bd926efa99a0638e03e26ed50f1c44b196888da (patch)
tree2964d701fada2f933c1cd028d296e2f4de09e0ac
parent30cff7c3b076308fac13610c3c6ab9eb6bb04e6f (diff)
downloadupstream-5bd926efa99a0638e03e26ed50f1c44b196888da.tar.gz
upstream-5bd926efa99a0638e03e26ed50f1c44b196888da.tar.bz2
upstream-5bd926efa99a0638e03e26ed50f1c44b196888da.zip
util-linux: add lslocks
This change adds the "lslocks" utility from util-linux. Signed-off-by: Roman Azarenko <roman.azarenko@iopsys.eu>
-rw-r--r--package/utils/util-linux/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index ded653e2c0..bf8a67f074 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -317,6 +317,16 @@ define Package/lscpu/description
lscpu displays information about the CPU architecture
endef
+define Package/lslocks
+$(call Package/util-linux/Default)
+ TITLE:=list local system locks
+ DEPENDS:= +libmount +libsmartcols
+endef
+
+define Package/lslocks/description
+ lslocks lists information about all the currently held file locks in a Linux system
+endef
+
define Package/more
$(call Package/util-linux/Default)
TITLE:=filter for paging through text one screenful at a time
@@ -704,6 +714,11 @@ define Package/lscpu/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lscpu $(1)/usr/bin/
endef
+define Package/lslocks/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lslocks $(1)/usr/bin/
+endef
+
define Package/more/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/more $(1)/usr/bin/
@@ -831,6 +846,7 @@ $(eval $(call BuildPackage,look))
$(eval $(call BuildPackage,losetup))
$(eval $(call BuildPackage,lsblk))
$(eval $(call BuildPackage,lscpu))
+$(eval $(call BuildPackage,lslocks))
$(eval $(call BuildPackage,more))
$(eval $(call BuildPackage,mcookie))
$(eval $(call BuildPackage,mount-utils))