aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-25 20:29:13 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-29 12:08:16 +0200
commit55e2d5eb3b44e5a2c7e1b0bae4fcd738e45bfac9 (patch)
treee2637085bc14ba0e2bfdd48924fa766d18629c7c
parent01a3e891d745ea15b149483bde43d6dfe75cd1fa (diff)
downloadupstream-55e2d5eb3b44e5a2c7e1b0bae4fcd738e45bfac9.tar.gz
upstream-55e2d5eb3b44e5a2c7e1b0bae4fcd738e45bfac9.tar.bz2
upstream-55e2d5eb3b44e5a2c7e1b0bae4fcd738e45bfac9.zip
ath79: disable default build for devices with 4M flash
It has been decided that the 19.07 release will be last one to include 4/32 devices. This disables default build for the remaining devices with 4M flash on ath79. Note that this will leave exactly one enabled device for ath79/tiny subtarget, PQI Air-Pen, which was moved there due to kernel size restrictions. All 4M TP-Link devices have already been disabled in 8819faff47ff ("ath79: do not build TP-Link tiny images by default") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--target/linux/ath79/image/tiny-netgear.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ath79/image/tiny-netgear.mk b/target/linux/ath79/image/tiny-netgear.mk
index 0127e5bd97..8561f91ab8 100644
--- a/target/linux/ath79/image/tiny-netgear.mk
+++ b/target/linux/ath79/image/tiny-netgear.mk
@@ -10,6 +10,7 @@ define Device/netgear_wnr612-v2
NETGEAR_BOARD_ID := REALWNR612V2
IMAGE_SIZE := 3712k
SUPPORTED_DEVICES += wnr612-v2
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wnr612-v2
@@ -22,6 +23,7 @@ define Device/on_n150r
NETGEAR_BOARD_ID := N150R
IMAGE_SIZE := 3712k
SUPPORTED_DEVICES += n150r
+ DEFAULT := n
endef
TARGET_DEVICES += on_n150r
@@ -35,6 +37,7 @@ define Device/netgear_wnr1000-v2
NETGEAR_HW_ID := 29763331+4+32
IMAGE_SIZE := 3712k
SUPPORTED_DEVICES += wnr1000-v2
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wnr1000-v2
@@ -51,5 +54,6 @@ define Device/netgear_wnr2000-v3
IMAGE/factory-NA.img := $$(IMAGE/default) | netgear-dni NA | \
check-size
SUPPORTED_DEVICES += wnr2000-v3
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wnr2000-v3