aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Heimpold <mhei@heimpold.de>2019-01-16 22:07:16 +0100
committerMathias Kresin <dev@kresin.me>2019-01-26 21:46:32 +0100
commit52d7a1d3b2c940e9db26aaffc674afdd2f884463 (patch)
tree39ab776866dffd4e7272c168dde86c6868becc52
parent01dcd574a24864c10a9c4df4304a3ce0da5c11a9 (diff)
downloadupstream-52d7a1d3b2c940e9db26aaffc674afdd2f884463.tar.gz
upstream-52d7a1d3b2c940e9db26aaffc674afdd2f884463.tar.bz2
upstream-52d7a1d3b2c940e9db26aaffc674afdd2f884463.zip
uboot-mxs: bump to v2019.01
Also update the U-Boot BSP patch for I2SE Duckbill devices. Signed-off-by: Michael Heimpold <mhei@heimpold.de>
-rw-r--r--package/boot/uboot-mxs/Makefile4
-rw-r--r--package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch40
2 files changed, 35 insertions, 9 deletions
diff --git a/package/boot/uboot-mxs/Makefile b/package/boot/uboot-mxs/Makefile
index cd26704cb6..c4485f5b3d 100644
--- a/package/boot/uboot-mxs/Makefile
+++ b/package/boot/uboot-mxs/Makefile
@@ -8,10 +8,10 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
-PKG_VERSION:=2018.09
+PKG_VERSION:=2019.01
PKG_RELEASE:=1
-PKG_HASH:=839bf23cfe8ce613a77e583a60375179d0ad324e92c82fbdd07bebf0fd142268
+PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch b/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
index e5d3484d8e..9acb6a508d 100644
--- a/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
+++ b/package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch
@@ -1,4 +1,4 @@
-From 7b919a74c562ca33ae28c9214f225a79b57209e4 Mon Sep 17 00:00:00 2001
+From 6af0148a38b23ba761905f98a7211fab986033ce Mon Sep 17 00:00:00 2001
From: Michael Heimpold <mhei@heimpold.de>
Date: Thu, 13 Sep 2018 21:40:19 +0200
Subject: [PATCH] arm: mxs: add support for I2SE's Duckbill boards
@@ -43,6 +43,8 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
create mode 100644 configs/duckbill_defconfig
create mode 100644 include/configs/duckbill.h
+diff --git a/arch/arm/mach-imx/mxs/Kconfig b/arch/arm/mach-imx/mxs/Kconfig
+index 68072d5a1f..82aaa3ef76 100644
--- a/arch/arm/mach-imx/mxs/Kconfig
+++ b/arch/arm/mach-imx/mxs/Kconfig
@@ -50,6 +50,10 @@ config TARGET_APX4DEVKIT
@@ -64,6 +66,9 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
source "board/ppcag/bg0900/Kconfig"
source "board/schulercontrol/sc_sps_1/Kconfig"
source "board/technologic/ts4600/Kconfig"
+diff --git a/board/i2se/duckbill/Kconfig b/board/i2se/duckbill/Kconfig
+new file mode 100644
+index 0000000000..98c1e4689f
--- /dev/null
+++ b/board/i2se/duckbill/Kconfig
@@ -0,0 +1,15 @@
@@ -82,6 +87,9 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
+ default "duckbill"
+
+endif
+diff --git a/board/i2se/duckbill/MAINTAINERS b/board/i2se/duckbill/MAINTAINERS
+new file mode 100644
+index 0000000000..5496baa330
--- /dev/null
+++ b/board/i2se/duckbill/MAINTAINERS
@@ -0,0 +1,6 @@
@@ -91,12 +99,15 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
+F: board/i2se/duckbill/
+F: include/configs/duckbill.h
+F: configs/duckbill_defconfig
+diff --git a/board/i2se/duckbill/Makefile b/board/i2se/duckbill/Makefile
+new file mode 100644
+index 0000000000..0079eb413c
--- /dev/null
+++ b/board/i2se/duckbill/Makefile
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: GPL-2.0+
+#
-+# (C) Copyright 2014-2018
++# (C) Copyright 2014-2019
+# Michael Heimpold, mhei@heimpold.de.
+
+ifndef CONFIG_SPL_BUILD
@@ -104,6 +115,9 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
+else
+obj-y := iomux.o
+endif
+diff --git a/board/i2se/duckbill/duckbill.c b/board/i2se/duckbill/duckbill.c
+new file mode 100644
+index 0000000000..f93c372611
--- /dev/null
+++ b/board/i2se/duckbill/duckbill.c
@@ -0,0 +1,186 @@
@@ -111,7 +125,7 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
+/*
+ * I2SE Duckbill board
+ *
-+ * (C) Copyright 2014-2018 Michael Heimpold <mhei@heimpold.de>
++ * (C) Copyright 2014-2019 Michael Heimpold <mhei@heimpold.de>
+ */
+
+#include <common.h>
@@ -293,6 +307,9 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
+
+ return 0;
+}
+diff --git a/board/i2se/duckbill/iomux.c b/board/i2se/duckbill/iomux.c
+new file mode 100644
+index 0000000000..1db3c52c34
--- /dev/null
+++ b/board/i2se/duckbill/iomux.c
@@ -0,0 +1,156 @@
@@ -300,7 +317,7 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
+/*
+ * I2SE Duckbill IOMUX setup
+ *
-+ * Copyright (C) 2013-2018 Michael Heimpold <mhei@heimpold.de>
++ * Copyright (C) 2013-2019 Michael Heimpold <mhei@heimpold.de>
+ */
+
+#include <common.h>
@@ -452,6 +469,9 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
+ else
+ mxs_iomux_setup_multiple_pads(iomux_setup_v1, ARRAY_SIZE(iomux_setup_v1));
+}
+diff --git a/configs/duckbill_defconfig b/configs/duckbill_defconfig
+new file mode 100644
+index 0000000000..f92a67d53d
--- /dev/null
+++ b/configs/duckbill_defconfig
@@ -0,0 +1,38 @@
@@ -493,12 +513,15 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
+CONFIG_CONS_INDEX=0
+CONFIG_OF_LIBFDT=y
+# CONFIG_EFI_LOADER is not set
+diff --git a/include/configs/duckbill.h b/include/configs/duckbill.h
+new file mode 100644
+index 0000000000..e7fce8843e
--- /dev/null
+++ b/include/configs/duckbill.h
@@ -0,0 +1,179 @@
+/* SPDX-License-Identifier: GPL-2.0+ */
+/*
-+ * Copyright (C) 2014-2018 Michael Heimpold <mhei@heimpold.de>
++ * Copyright (C) 2014-2019 Michael Heimpold <mhei@heimpold.de>
+ *
+ */
+#ifndef __CONFIGS_DUCKBILL_H__
@@ -613,7 +636,7 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
+ "mmcroot=/dev/mmcblk0p2\0" \
+ "mmcargs=setenv bootargs console=${console},${baudrate} " \
+ "root=${mmcroot} " \
-+ "rootwait bootsys=${bootsys} panic=1\0" \
++ "rootwait bootsys=${bootsys} panic=1 ${extraargs}\0" \
+ "loadimage=ext4load mmc ${mmcdev}:${mmcpart} ${loadaddr} /boot/${image}\0" \
+ "loadfdt=ext4load mmc ${mmcdev}:${mmcpart} ${fdt_addr} /boot/${fdt_file}\0" \
+ "mmcboot=echo Booting from mmc ...; " \
@@ -636,7 +659,7 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
+ "nfsroot=/\0" \
+ "netargs=setenv bootargs console=${console},${baudrate} " \
+ "root=/dev/nfs " \
-+ "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
++ "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp ${extraargs}\0" \
+ "netboot=echo Booting from net ...; " \
+ "run netargs; " \
+ "if test ${ip_dyn} = yes; then " \
@@ -675,3 +698,6 @@ Signed-off-by: Stefan Wahren <stefan.wahren@i2se.com>
+#include <configs/mxs.h>
+
+#endif /* __CONFIGS_DUCKBILL_H__ */
+--
+2.17.1
+