aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-07-28 20:47:33 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-30 21:48:38 +0200
commit504000d520ac8699137bd6b8dbd55f723f34bfbe (patch)
tree27f16f08dad8c83fe989fac4a6f7f9d2b9be2ffb
parentbf5c56ba57c8b5d60d83f5d590e9b0f4f54c29a2 (diff)
downloadupstream-504000d520ac8699137bd6b8dbd55f723f34bfbe.tar.gz
upstream-504000d520ac8699137bd6b8dbd55f723f34bfbe.tar.bz2
upstream-504000d520ac8699137bd6b8dbd55f723f34bfbe.zip
treewide: use DEFAULT := n to disable non-broken devices
This uses DEFAULT := n on a bunch of devices that previously were "disabled" by commenting out TARGET_DEVICES. This will allow to build them without having to modify the code, but they will not be selected for default build or buildbots. The change is applied to all devices that are not "broken", but suffer from image site limitations or similar, or have been added in the past but never confirmed to run on the device properly: at91: at91-q5xr5: kernel image too big 31aeae077482 ("at91: do not build image for at91-q5xr5") bcm47xx: asus-rt-ac66u: disabled since it was added in 2015 69aefc771fd8 ("brcm47xx: build images for Asus devices") bcm47xx: netgear-wndr3400-vcna, netgear-wnr3500u, netgear-wnr3500-v2-vc added disabled in 2012, but never confirmed to work on devices 5dec9dd3b200 ("brcm47xx: add code to generate images for some netgear devices") bcm53xx: netgear-r8500 added disabled: "start working on Netgear R8500" 3b76c7cf0bdd ("bcm53xx: start working on Netgear R8500") Signed-off-by: Petr Štetiar <ynezz@true.cz> [limit to subset of devices, adjust commit message/title] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--target/linux/at91/image/sam9x.mk3
-rw-r--r--target/linux/bcm47xx/image/mips74k.mk12
-rw-r--r--target/linux/bcm53xx/image/Makefile3
3 files changed, 12 insertions, 6 deletions
diff --git a/target/linux/at91/image/sam9x.mk b/target/linux/at91/image/sam9x.mk
index 8fd6b4506f..beff346725 100644
--- a/target/linux/at91/image/sam9x.mk
+++ b/target/linux/at91/image/sam9x.mk
@@ -173,8 +173,9 @@ define Device/at91-q5xr5
DEVICE_VENDOR := Exegin
DEVICE_MODEL := Q5XR5
KERNEL_SIZE := 2048k
+ DEFAULT := n
endef
-#TARGET_DEVICES += at91-q5xr5
+TARGET_DEVICES += at91-q5xr5
define Device/wb45n
$(Device/evaluation-fit)
diff --git a/target/linux/bcm47xx/image/mips74k.mk b/target/linux/bcm47xx/image/mips74k.mk
index 6ca4d21e1f..fb3c594c03 100644
--- a/target/linux/bcm47xx/image/mips74k.mk
+++ b/target/linux/bcm47xx/image/mips74k.mk
@@ -15,8 +15,9 @@ define Device/asus-rt-ac66u
DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
$(Device/asus)
PRODUCTID := RT-AC66U
+ DEFAULT := n
endef
-# TARGET_DEVICES += asus-rt-ac66u
+TARGET_DEVICES += asus-rt-ac66u
define Device/asus-rt-n10
DEVICE_MODEL := RT-N10
@@ -399,8 +400,9 @@ define Device/netgear-wndr3400-vcna
$(Device/netgear)
NETGEAR_BOARD_ID := U12H155T01_NETGEAR
NETGEAR_REGION := 2
+ DEFAULT := n
endef
-# TARGET_DEVICES += netgear-wndr3400-vcna
+TARGET_DEVICES += netgear-wndr3400-vcna
define Device/netgear-wndr4000
DEVICE_MODEL := WNDR4000
@@ -467,8 +469,9 @@ define Device/netgear-wnr3500u
$(Device/netgear)
NETGEAR_BOARD_ID := U12H136T00_NETGEAR
NETGEAR_REGION := 2
+ DEFAULT := n
endef
-# TARGET_DEVICES += netgear-wnr3500u
+TARGET_DEVICES += netgear-wnr3500u
define Device/netgear-wnr3500-v2
DEVICE_MODEL := WNR3500
@@ -487,7 +490,8 @@ define Device/netgear-wnr3500-v2-vc
$(Device/netgear)
NETGEAR_BOARD_ID := U12H127T70_NETGEAR
NETGEAR_REGION := 2
+ DEFAULT := n
endef
-# TARGET_DEVICES += netgear-wnr3500-v2-vc
+TARGET_DEVICES += netgear-wnr3500-v2-vc
TARGET_DEVICES += standard standard-noloader-nodictionarylzma
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index b3ec1e99a2..5d4ae08513 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -370,8 +370,9 @@ define Device/netgear-r8500
DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(USB3_PACKAGES)
$(Device/netgear)
NETGEAR_BOARD_ID := U12H334T00_NETGEAR
+ DEFAULT := n
endef
-# TARGET_DEVICES += netgear-r8500
+TARGET_DEVICES += netgear-r8500
define Device/smartrg-sr400ac
DEVICE_VENDOR := SmartRG