aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-07-12 16:02:34 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-07-12 16:02:34 +0000
commit4e7d2ffce589a195c89e45b373717dbd0a00052e (patch)
treed1a6d5f02ec019759d6af4e293f127f1ec061533
parent51a243f3c112e6946575381ef5531fb1e51370e8 (diff)
downloadupstream-4e7d2ffce589a195c89e45b373717dbd0a00052e.tar.gz
upstream-4e7d2ffce589a195c89e45b373717dbd0a00052e.tar.bz2
upstream-4e7d2ffce589a195c89e45b373717dbd0a00052e.zip
CC: kernel: update 3.18 to 3.18.18
Changelog: * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.18 Backport of r46299, r46303 and r46308. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@46309 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/ar71xx/patches-3.18/902-unaligned_access_hacks.patch2
-rw-r--r--target/linux/bcm53xx/patches-3.18/332-ARM-BCM5301X-Add-power-button-for-Buffalo-WZR-1750DHP.patch2
-rw-r--r--target/linux/brcm2708/patches-3.18/0055-usb-core-make-overcurrent-messages-more-prominent.patch2
-rw-r--r--target/linux/generic/patches-3.18/051-02-bridge-allow-setting-hash_max-multicast_router-if-in.patch10
-rw-r--r--target/linux/generic/patches-3.18/259-regmap_dynamic.patch2
-rw-r--r--target/linux/generic/patches-3.18/630-packet_socket_type.patch16
-rw-r--r--target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch24
-rw-r--r--target/linux/generic/patches-3.18/653-disable_netlink_trim.patch2
-rw-r--r--target/linux/generic/patches-3.18/702-phy_add_aneg_done_function.patch2
-rw-r--r--target/linux/generic/patches-3.18/704-phy-no-genphy-soft-reset.patch6
-rw-r--r--target/linux/lantiq/patches-3.18/0001-MIPS-lantiq-add-pcie-driver.patch2
-rw-r--r--target/linux/lantiq/patches-3.18/0032-USB-fix-roothub-for-IFXHCD.patch2
-rw-r--r--target/linux/mvebu/patches-3.18/015-move_armada_370_xp_pinctrl_node_definition.patch4
-rw-r--r--target/linux/mvebu/patches-3.18/016-common_armada_xp_uart2_3_pinctrl.patch2
-rw-r--r--target/linux/mvebu/patches-3.18/017-define_and_use_common_armada_xp_spi_pinctrl_setting.patch2
-rw-r--r--target/linux/mvebu/patches-3.18/018-normalize_pinctrl_entries_for_armada_socs.patch6
-rw-r--r--target/linux/mvebu/patches-3.18/023-pinctrl-mvebu-a38x-Add-UART1-muxing-options.patch5
-rw-r--r--target/linux/mvebu/patches-3.18/140-alias_mdio_node.patch2
19 files changed, 48 insertions, 49 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 19d6333c2c..4306dfa555 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,9 +2,9 @@
LINUX_RELEASE?=1
-LINUX_VERSION-3.18 = .17
+LINUX_VERSION-3.18 = .18
-LINUX_KERNEL_MD5SUM-3.18.17 = f05d7620c587d8b0ab3cd944ff9dc9f7
+LINUX_KERNEL_MD5SUM-3.18.18 = 6fce868a56f2d83f80cdad5fed457110
ifdef KERNEL_PATCHVER
LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
diff --git a/target/linux/ar71xx/patches-3.18/902-unaligned_access_hacks.patch b/target/linux/ar71xx/patches-3.18/902-unaligned_access_hacks.patch
index 7e22859343..6b6c0f2d3f 100644
--- a/target/linux/ar71xx/patches-3.18/902-unaligned_access_hacks.patch
+++ b/target/linux/ar71xx/patches-3.18/902-unaligned_access_hacks.patch
@@ -342,7 +342,7 @@
#endif /* _LINUX_TYPES_H */
--- a/net/ipv4/af_inet.c
+++ b/net/ipv4/af_inet.c
-@@ -1324,8 +1324,8 @@ static struct sk_buff **inet_gro_receive
+@@ -1326,8 +1326,8 @@ static struct sk_buff **inet_gro_receive
if (unlikely(ip_fast_csum((u8 *)iph, 5)))
goto out_unlock;
diff --git a/target/linux/bcm53xx/patches-3.18/332-ARM-BCM5301X-Add-power-button-for-Buffalo-WZR-1750DHP.patch b/target/linux/bcm53xx/patches-3.18/332-ARM-BCM5301X-Add-power-button-for-Buffalo-WZR-1750DHP.patch
index d49af48afc..f9ca7eb7c1 100644
--- a/target/linux/bcm53xx/patches-3.18/332-ARM-BCM5301X-Add-power-button-for-Buffalo-WZR-1750DHP.patch
+++ b/target/linux/bcm53xx/patches-3.18/332-ARM-BCM5301X-Add-power-button-for-Buffalo-WZR-1750DHP.patch
@@ -5,7 +5,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
---
--- a/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
+++ b/arch/arm/boot/dts/bcm4708-buffalo-wzr-1750dhp.dts
-@@ -143,6 +143,12 @@
+@@ -123,6 +123,12 @@
#address-cells = <1>;
#size-cells = <0>;
diff --git a/target/linux/brcm2708/patches-3.18/0055-usb-core-make-overcurrent-messages-more-prominent.patch b/target/linux/brcm2708/patches-3.18/0055-usb-core-make-overcurrent-messages-more-prominent.patch
index 4a8f2fe201..0c339d3a2f 100644
--- a/target/linux/brcm2708/patches-3.18/0055-usb-core-make-overcurrent-messages-more-prominent.patch
+++ b/target/linux/brcm2708/patches-3.18/0055-usb-core-make-overcurrent-messages-more-prominent.patch
@@ -10,7 +10,7 @@ Hub overcurrent messages are more serious than "debug". Increase loglevel.
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
-@@ -4923,7 +4923,7 @@ static void port_event(struct usb_hub *h
+@@ -4907,7 +4907,7 @@ static void port_event(struct usb_hub *h
if (portchange & USB_PORT_STAT_C_OVERCURRENT) {
u16 status = 0, unused;
diff --git a/target/linux/generic/patches-3.18/051-02-bridge-allow-setting-hash_max-multicast_router-if-in.patch b/target/linux/generic/patches-3.18/051-02-bridge-allow-setting-hash_max-multicast_router-if-in.patch
index c899c10cff..f7f88f8134 100644
--- a/target/linux/generic/patches-3.18/051-02-bridge-allow-setting-hash_max-multicast_router-if-in.patch
+++ b/target/linux/generic/patches-3.18/051-02-bridge-allow-setting-hash_max-multicast_router-if-in.patch
@@ -26,7 +26,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
--- a/net/bridge/br_multicast.c
+++ b/net/bridge/br_multicast.c
-@@ -1949,11 +1949,9 @@ out:
+@@ -1948,11 +1948,9 @@ out:
int br_multicast_set_router(struct net_bridge *br, unsigned long val)
{
@@ -39,7 +39,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
switch (val) {
case 0:
-@@ -1964,13 +1962,8 @@ int br_multicast_set_router(struct net_b
+@@ -1963,13 +1961,8 @@ int br_multicast_set_router(struct net_b
br->multicast_router = val;
err = 0;
break;
@@ -53,7 +53,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
spin_unlock_bh(&br->multicast_lock);
return err;
-@@ -1979,11 +1972,9 @@ unlock:
+@@ -1978,11 +1971,9 @@ unlock:
int br_multicast_set_port_router(struct net_bridge_port *p, unsigned long val)
{
struct net_bridge *br = p->br;
@@ -66,7 +66,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
switch (val) {
case 0:
-@@ -2005,13 +1996,8 @@ int br_multicast_set_port_router(struct
+@@ -2004,13 +1995,8 @@ int br_multicast_set_port_router(struct
br_multicast_add_router(br, p);
break;
@@ -80,7 +80,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
spin_unlock(&br->multicast_lock);
return err;
-@@ -2116,15 +2102,11 @@ unlock:
+@@ -2115,15 +2101,11 @@ unlock:
int br_multicast_set_hash_max(struct net_bridge *br, unsigned long val)
{
diff --git a/target/linux/generic/patches-3.18/259-regmap_dynamic.patch b/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
index 44548ca8cc..63c85dd40a 100644
--- a/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
+++ b/target/linux/generic/patches-3.18/259-regmap_dynamic.patch
@@ -71,7 +71,7 @@
#include <linux/mutex.h>
#include <linux/err.h>
#include <linux/of.h>
-@@ -2631,3 +2632,5 @@ static int __init regmap_initcall(void)
+@@ -2630,3 +2631,5 @@ static int __init regmap_initcall(void)
return 0;
}
postcore_initcall(regmap_initcall);
diff --git a/target/linux/generic/patches-3.18/630-packet_socket_type.patch b/target/linux/generic/patches-3.18/630-packet_socket_type.patch
index 06bd167abf..fa057b264d 100644
--- a/target/linux/generic/patches-3.18/630-packet_socket_type.patch
+++ b/target/linux/generic/patches-3.18/630-packet_socket_type.patch
@@ -26,7 +26,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
#define PACKET_FANOUT_LB 1
--- a/net/packet/af_packet.c
+++ b/net/packet/af_packet.c
-@@ -1530,6 +1530,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1516,6 +1516,7 @@ static int packet_rcv_spkt(struct sk_buf
{
struct sock *sk;
struct sockaddr_pkt *spkt;
@@ -34,7 +34,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
/*
* When we registered the protocol we saved the socket in the data
-@@ -1537,6 +1538,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1523,6 +1524,7 @@ static int packet_rcv_spkt(struct sk_buf
*/
sk = pt->af_packet_priv;
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
/*
* Yank back the headers [hope the device set this
-@@ -1549,7 +1551,7 @@ static int packet_rcv_spkt(struct sk_buf
+@@ -1535,7 +1537,7 @@ static int packet_rcv_spkt(struct sk_buf
* so that this procedure is noop.
*/
@@ -51,7 +51,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
goto out;
if (!net_eq(dev_net(dev), sock_net(sk)))
-@@ -1756,12 +1758,12 @@ static int packet_rcv(struct sk_buff *sk
+@@ -1742,12 +1744,12 @@ static int packet_rcv(struct sk_buff *sk
int skb_len = skb->len;
unsigned int snaplen, res;
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -1881,12 +1883,12 @@ static int tpacket_rcv(struct sk_buff *s
+@@ -1867,12 +1869,12 @@ static int tpacket_rcv(struct sk_buff *s
BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h2)) != 32);
BUILD_BUG_ON(TPACKET_ALIGN(sizeof(*h.h3)) != 48);
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -2823,6 +2825,7 @@ static int packet_create(struct net *net
+@@ -2809,6 +2811,7 @@ static int packet_create(struct net *net
spin_lock_init(&po->bind_lock);
mutex_init(&po->pg_vec_lock);
po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt;
-@@ -3403,6 +3406,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3389,6 +3392,16 @@ packet_setsockopt(struct socket *sock, i
po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
return 0;
}
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
default:
return -ENOPROTOOPT;
}
-@@ -3454,6 +3467,13 @@ static int packet_getsockopt(struct sock
+@@ -3440,6 +3453,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR:
val = po->has_vnet_hdr;
break;
diff --git a/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch b/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch
index a7e320f8a0..00ad14f113 100644
--- a/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch
+++ b/target/linux/generic/patches-3.18/645-bridge_multicast_to_unicast.patch
@@ -133,7 +133,7 @@
if (err)
break;
}
-@@ -1407,7 +1434,8 @@ br_multicast_leave_group(struct net_brid
+@@ -1406,7 +1433,8 @@ br_multicast_leave_group(struct net_brid
struct net_bridge_port *port,
struct br_ip *group,
struct bridge_mcast_other_query *other_query,
@@ -143,7 +143,7 @@
{
struct net_bridge_mdb_htable *mdb;
struct net_bridge_mdb_entry *mp;
-@@ -1457,7 +1485,7 @@ br_multicast_leave_group(struct net_brid
+@@ -1456,7 +1484,7 @@ br_multicast_leave_group(struct net_brid
for (pp = &mp->ports;
(p = mlock_dereference(*pp, br)) != NULL;
pp = &p->next) {
@@ -152,7 +152,7 @@
continue;
rcu_assign_pointer(*pp, p->next);
-@@ -1491,7 +1519,7 @@ br_multicast_leave_group(struct net_brid
+@@ -1490,7 +1518,7 @@ br_multicast_leave_group(struct net_brid
for (p = mlock_dereference(mp->ports, br);
p != NULL;
p = mlock_dereference(p->next, br)) {
@@ -161,7 +161,7 @@
continue;
if (!hlist_unhashed(&p->mglist) &&
-@@ -1509,8 +1537,8 @@ out:
+@@ -1508,8 +1536,8 @@ out:
static void br_ip4_multicast_leave_group(struct net_bridge *br,
struct net_bridge_port *port,
@@ -172,7 +172,7 @@
{
struct br_ip br_group;
struct bridge_mcast_own_query *own_query;
-@@ -1525,14 +1553,14 @@ static void br_ip4_multicast_leave_group
+@@ -1524,14 +1552,14 @@ static void br_ip4_multicast_leave_group
br_group.vid = vid;
br_multicast_leave_group(br, port, &br_group, &br->ip4_other_query,
@@ -189,7 +189,7 @@
{
struct br_ip br_group;
struct bridge_mcast_own_query *own_query;
-@@ -1547,7 +1575,7 @@ static void br_ip6_multicast_leave_group
+@@ -1546,7 +1574,7 @@ static void br_ip6_multicast_leave_group
br_group.vid = vid;
br_multicast_leave_group(br, port, &br_group, &br->ip6_other_query,
@@ -198,7 +198,7 @@
}
#endif
-@@ -1556,6 +1584,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1555,6 +1583,7 @@ static int br_multicast_ipv4_rcv(struct
struct sk_buff *skb,
u16 vid)
{
@@ -206,7 +206,7 @@
struct sk_buff *skb2 = skb;
const struct iphdr *iph;
struct igmphdr *ih;
-@@ -1629,7 +1658,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1628,7 +1657,7 @@ static int br_multicast_ipv4_rcv(struct
case IGMP_HOST_MEMBERSHIP_REPORT:
case IGMPV2_HOST_MEMBERSHIP_REPORT:
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
@@ -215,7 +215,7 @@
break;
case IGMPV3_HOST_MEMBERSHIP_REPORT:
err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
-@@ -1638,7 +1667,7 @@ static int br_multicast_ipv4_rcv(struct
+@@ -1637,7 +1666,7 @@ static int br_multicast_ipv4_rcv(struct
err = br_ip4_multicast_query(br, port, skb2, vid);
break;
case IGMP_HOST_LEAVE_MESSAGE:
@@ -224,7 +224,7 @@
break;
}
-@@ -1656,6 +1685,7 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1655,6 +1684,7 @@ static int br_multicast_ipv6_rcv(struct
struct sk_buff *skb,
u16 vid)
{
@@ -232,7 +232,7 @@
struct sk_buff *skb2;
const struct ipv6hdr *ip6h;
u8 icmp6_type;
-@@ -1765,7 +1795,8 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1764,7 +1794,8 @@ static int br_multicast_ipv6_rcv(struct
}
mld = (struct mld_msg *)skb_transport_header(skb2);
BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
@@ -242,7 +242,7 @@
break;
}
case ICMPV6_MLD2_REPORT:
-@@ -1782,7 +1813,7 @@ static int br_multicast_ipv6_rcv(struct
+@@ -1781,7 +1812,7 @@ static int br_multicast_ipv6_rcv(struct
goto out;
}
mld = (struct mld_msg *)skb_transport_header(skb2);
diff --git a/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch b/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch
index f8bc1f44ed..b8fbe92378 100644
--- a/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch
+++ b/target/linux/generic/patches-3.18/653-disable_netlink_trim.patch
@@ -1,6 +1,6 @@
--- a/net/netlink/af_netlink.c
+++ b/net/netlink/af_netlink.c
-@@ -1693,27 +1693,7 @@ void netlink_detachskb(struct sock *sk,
+@@ -1690,27 +1690,7 @@ void netlink_detachskb(struct sock *sk,
static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
{
diff --git a/target/linux/generic/patches-3.18/702-phy_add_aneg_done_function.patch b/target/linux/generic/patches-3.18/702-phy_add_aneg_done_function.patch
index 42bddfee35..d20fc04cb0 100644
--- a/target/linux/generic/patches-3.18/702-phy_add_aneg_done_function.patch
+++ b/target/linux/generic/patches-3.18/702-phy_add_aneg_done_function.patch
@@ -15,7 +15,7 @@
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
-@@ -914,6 +914,9 @@ int genphy_update_link(struct phy_device
+@@ -915,6 +915,9 @@ int genphy_update_link(struct phy_device
{
int status;
diff --git a/target/linux/generic/patches-3.18/704-phy-no-genphy-soft-reset.patch b/target/linux/generic/patches-3.18/704-phy-no-genphy-soft-reset.patch
index c2554158e3..0350f9efe4 100644
--- a/target/linux/generic/patches-3.18/704-phy-no-genphy-soft-reset.patch
+++ b/target/linux/generic/patches-3.18/704-phy-no-genphy-soft-reset.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
-@@ -1132,7 +1132,7 @@ int genphy_config_init(struct phy_device
+@@ -1133,7 +1133,7 @@ int genphy_config_init(struct phy_device
return 0;
}
@@ -9,7 +9,7 @@
{
/* Do nothing for now */
return 0;
-@@ -1346,7 +1346,7 @@ static struct phy_driver genphy_driver[]
+@@ -1347,7 +1347,7 @@ static struct phy_driver genphy_driver[]
.phy_id = 0xffffffff,
.phy_id_mask = 0xffffffff,
.name = "Generic PHY",
@@ -18,7 +18,7 @@
.config_init = genphy_config_init,
.features = PHY_GBIT_FEATURES | SUPPORTED_MII |
SUPPORTED_AUI | SUPPORTED_FIBRE |
-@@ -1361,7 +1361,7 @@ static struct phy_driver genphy_driver[]
+@@ -1362,7 +1362,7 @@ static struct phy_driver genphy_driver[]
.phy_id = 0xffffffff,
.phy_id_mask = 0xffffffff,
.name = "Generic 10G PHY",
diff --git a/target/linux/lantiq/patches-3.18/0001-MIPS-lantiq-add-pcie-driver.patch b/target/linux/lantiq/patches-3.18/0001-MIPS-lantiq-add-pcie-driver.patch
index 85311c21f2..a123ce384f 100644
--- a/target/linux/lantiq/patches-3.18/0001-MIPS-lantiq-add-pcie-driver.patch
+++ b/target/linux/lantiq/patches-3.18/0001-MIPS-lantiq-add-pcie-driver.patch
@@ -5514,7 +5514,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
(transaction layer end-to-end CRC checking).
--- a/include/linux/pci.h
+++ b/include/linux/pci.h
-@@ -1160,6 +1160,8 @@ void pci_walk_bus(struct pci_bus *top, i
+@@ -1156,6 +1156,8 @@ void pci_walk_bus(struct pci_bus *top, i
void *userdata);
int pci_cfg_space_size(struct pci_dev *dev);
unsigned char pci_bus_max_busnr(struct pci_bus *bus);
diff --git a/target/linux/lantiq/patches-3.18/0032-USB-fix-roothub-for-IFXHCD.patch b/target/linux/lantiq/patches-3.18/0032-USB-fix-roothub-for-IFXHCD.patch
index 673e3de824..cf2c5cbd5b 100644
--- a/target/linux/lantiq/patches-3.18/0032-USB-fix-roothub-for-IFXHCD.patch
+++ b/target/linux/lantiq/patches-3.18/0032-USB-fix-roothub-for-IFXHCD.patch
@@ -20,7 +20,7 @@ Subject: [PATCH 32/36] USB: fix roothub for IFXHCD
choice
--- a/drivers/usb/core/hub.c
+++ b/drivers/usb/core/hub.c
-@@ -4319,7 +4319,7 @@ hub_port_init (struct usb_hub *hub, stru
+@@ -4303,7 +4303,7 @@ hub_port_init (struct usb_hub *hub, stru
udev->ttport = hdev->ttport;
} else if (udev->speed != USB_SPEED_HIGH
&& hdev->speed == USB_SPEED_HIGH) {
diff --git a/target/linux/mvebu/patches-3.18/015-move_armada_370_xp_pinctrl_node_definition.patch b/target/linux/mvebu/patches-3.18/015-move_armada_370_xp_pinctrl_node_definition.patch
index 5259e05ccb..ed36d680eb 100644
--- a/target/linux/mvebu/patches-3.18/015-move_armada_370_xp_pinctrl_node_definition.patch
+++ b/target/linux/mvebu/patches-3.18/015-move_armada_370_xp_pinctrl_node_definition.patch
@@ -387,7 +387,7 @@ Signed-off-by: Jason Cooper <jason@lakedaemon.net>
gpio0: gpio@18100 {
compatible = "marvell,orion-gpio";
reg = <0x18100 0x40>;
-@@ -306,3 +245,63 @@
+@@ -314,3 +253,63 @@
};
};
};
@@ -497,7 +497,7 @@ Signed-off-by: Jason Cooper <jason@lakedaemon.net>
system-controller@18200 {
compatible = "marvell,armada-370-xp-system-controller";
reg = <0x18200 0x500>;
-@@ -238,3 +201,38 @@
+@@ -246,3 +209,38 @@
};
};
};
diff --git a/target/linux/mvebu/patches-3.18/016-common_armada_xp_uart2_3_pinctrl.patch b/target/linux/mvebu/patches-3.18/016-common_armada_xp_uart2_3_pinctrl.patch
index 2d289706ad..4cccdb3b97 100644
--- a/target/linux/mvebu/patches-3.18/016-common_armada_xp_uart2_3_pinctrl.patch
+++ b/target/linux/mvebu/patches-3.18/016-common_armada_xp_uart2_3_pinctrl.patch
@@ -35,7 +35,7 @@ Signed-off-by: Jason Cooper <jason@lakedaemon.net>
reg = <0x12300 0x100>;
reg-shift = <2>;
interrupts = <44>;
-@@ -235,4 +239,14 @@
+@@ -243,4 +247,14 @@
"mpp33", "mpp34", "mpp35";
marvell,function = "sd0";
};
diff --git a/target/linux/mvebu/patches-3.18/017-define_and_use_common_armada_xp_spi_pinctrl_setting.patch b/target/linux/mvebu/patches-3.18/017-define_and_use_common_armada_xp_spi_pinctrl_setting.patch
index 668d55dd07..9085db00d2 100644
--- a/target/linux/mvebu/patches-3.18/017-define_and_use_common_armada_xp_spi_pinctrl_setting.patch
+++ b/target/linux/mvebu/patches-3.18/017-define_and_use_common_armada_xp_spi_pinctrl_setting.patch
@@ -54,7 +54,7 @@ Signed-off-by: Jason Cooper <jason@lakedaemon.net>
i2c0: i2c@11000 {
compatible = "marvell,mv78230-i2c", "marvell,mv64xxx-i2c";
reg = <0x11000 0x100>;
-@@ -240,6 +245,12 @@
+@@ -248,6 +253,12 @@
marvell,function = "sd0";
};
diff --git a/target/linux/mvebu/patches-3.18/018-normalize_pinctrl_entries_for_armada_socs.patch b/target/linux/mvebu/patches-3.18/018-normalize_pinctrl_entries_for_armada_socs.patch
index e8f9d308cb..ca7b13bed4 100644
--- a/target/linux/mvebu/patches-3.18/018-normalize_pinctrl_entries_for_armada_socs.patch
+++ b/target/linux/mvebu/patches-3.18/018-normalize_pinctrl_entries_for_armada_socs.patch
@@ -69,7 +69,7 @@ Signed-off-by: Jason Cooper <jason@lakedaemon.net>
};
--- a/arch/arm/boot/dts/armada-xp.dtsi
+++ b/arch/arm/boot/dts/armada-xp.dtsi
-@@ -212,7 +212,7 @@
+@@ -220,7 +220,7 @@
};
&pinctrl {
@@ -78,7 +78,7 @@ Signed-off-by: Jason Cooper <jason@lakedaemon.net>
marvell,pins =
"mpp0", "mpp1", "mpp2", "mpp3",
"mpp4", "mpp5", "mpp6", "mpp7",
-@@ -223,7 +223,7 @@
+@@ -231,7 +231,7 @@
marvell,function = "ge0";
};
@@ -87,7 +87,7 @@ Signed-off-by: Jason Cooper <jason@lakedaemon.net>
marvell,pins =
"mpp0", "mpp1", "mpp2", "mpp3",
"mpp4", "mpp5", "mpp6", "mpp7",
-@@ -231,7 +231,7 @@
+@@ -239,7 +239,7 @@
marvell,function = "ge0";
};
diff --git a/target/linux/mvebu/patches-3.18/023-pinctrl-mvebu-a38x-Add-UART1-muxing-options.patch b/target/linux/mvebu/patches-3.18/023-pinctrl-mvebu-a38x-Add-UART1-muxing-options.patch
index fd75366e38..07f8e2994d 100644
--- a/target/linux/mvebu/patches-3.18/023-pinctrl-mvebu-a38x-Add-UART1-muxing-options.patch
+++ b/target/linux/mvebu/patches-3.18/023-pinctrl-mvebu-a38x-Add-UART1-muxing-options.patch
@@ -17,9 +17,9 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
--- a/drivers/pinctrl/mvebu/pinctrl-armada-38x.c
+++ b/drivers/pinctrl/mvebu/pinctrl-armada-38x.c
-@@ -145,14 +145,16 @@ static struct mvebu_mpp_mode armada_38x_
+@@ -146,13 +146,15 @@ static struct mvebu_mpp_mode armada_38x_
MPP_VAR_FUNCTION(2, "ptp", "event_req", V_88F6810_PLUS),
- MPP_VAR_FUNCTION(3, "pcie0", "clkreq", V_88F6810_PLUS),
+ MPP_VAR_FUNCTION(3, "ge0", "txerr", V_88F6810_PLUS),
MPP_VAR_FUNCTION(4, "sata1", "prsnt", V_88F6810_PLUS),
- MPP_VAR_FUNCTION(5, "ua0", "cts", V_88F6810_PLUS)),
+ MPP_VAR_FUNCTION(5, "ua0", "cts", V_88F6810_PLUS),
@@ -28,7 +28,6 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
MPP_VAR_FUNCTION(0, "gpio", NULL, V_88F6810_PLUS),
MPP_VAR_FUNCTION(1, "ge0", "txclk", V_88F6810_PLUS),
MPP_VAR_FUNCTION(2, "ptp", "clk", V_88F6810_PLUS),
- MPP_VAR_FUNCTION(3, "pcie1", "rstout", V_88F6820_PLUS),
MPP_VAR_FUNCTION(4, "sata0", "prsnt", V_88F6810_PLUS),
- MPP_VAR_FUNCTION(5, "ua0", "rts", V_88F6810_PLUS)),
+ MPP_VAR_FUNCTION(5, "ua0", "rts", V_88F6810_PLUS),
diff --git a/target/linux/mvebu/patches-3.18/140-alias_mdio_node.patch b/target/linux/mvebu/patches-3.18/140-alias_mdio_node.patch
index baca023e05..818fae74e6 100644
--- a/target/linux/mvebu/patches-3.18/140-alias_mdio_node.patch
+++ b/target/linux/mvebu/patches-3.18/140-alias_mdio_node.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/boot/dts/armada-370-xp.dtsi
+++ b/arch/arm/boot/dts/armada-370-xp.dtsi
-@@ -237,7 +237,7 @@
+@@ -236,7 +236,7 @@
status = "disabled";
};