aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-17 08:57:13 +0100
committerFelix Fietkau <nbd@nbd.name>2017-12-04 10:52:52 +0100
commit4b5861c47d855adbeb44f30b641f69ecbd9835e4 (patch)
tree4eca9b6b8cc1b8c10b5d2abffd800ebeb77fc9f7
parentf19d47f8482691c54c5b5f363d064e21d2df3bb0 (diff)
downloadupstream-4b5861c47d855adbeb44f30b641f69ecbd9835e4.tar.gz
upstream-4b5861c47d855adbeb44f30b641f69ecbd9835e4.tar.bz2
upstream-4b5861c47d855adbeb44f30b641f69ecbd9835e4.zip
mt76: update to the latest version
Significant performance/stability improvements for MT76x2 and MT7603. Adds LED support. Changes: 2895775 mt76x2: mcu: remove unused parameter in mt76x2_mcu_msg_alloc signature 1dae8f0 mt7603: mcu: remove unused parameter in mt7603_mcu_msg_alloc() signature 5e49aa9 Fix errors found by cppcheck 1b8c8a0 mt7603: add LED definition registers 4d83561 mt76x2: add LED register definitions 2f40e4a mt76x2: Support using PCI ID as chip ID 27c64bc mt76: add led support using mac80211 led framework dfd64fc mt76x2: init: add ma80211 led callbacks 215edf1 mt7603: init: add ma80211 led callbacks 9d36ff2 mt76x2: Add PCI identifier for MT7602 0b7984e mt7603: remove unnecessary mcu register read function f5498d2 debugfs: add support for changing the LED pin 8e453b3 mac80211: move DT led configuration to the "led" child node 8f1673a mt76x2: limit client WCID entries to 0-127 f9d9c22 mt76x2: clear drop flag for all WCIDs on init 0dd8b68 mt76x2: clear per-WCID tx rate lookup register 3e5afe7 mt76x2: add helper function for setting drop mask 941555b mt76x2: clear drop mask when sending a PS response 7dfb354 mt76: increase rx ring size for mt76x2 73902dc mt76x2: add rx statistics registers fe79816 mt76x2: fix LNA gain register annotation cc588c5 mt76x2: sync channel gain value with latest reference driver 60a4d67 mt76x2: implement dynamic AGC tuning based on false packet detection count 4bc9aa9 mt76x2: add more gain tuning based on the latest reference driver 0a0d16f mt76x2: sync tx power related values with reference driver 8c821aa mac80211: add missing include 82acc85 mt7603: add missing include required on newer kernels 2c1a77c mt76x2: fix transmission of encrypted management frames 0532315 mt76x2: increase OFDM SIFS time 1acde21 mt76x2: add channel argument to eeprom tx power functions 58364a2 mt76x2: initialize channel power limits c2bd89e mt76x2: convert between per-chain tx power and combined output e7eaa7c mt7603: rename mt7603_mac_reset to mt7603_pse_reset ea4c2a1 mt7603: rename MT_PSE_RESET register c86c3a0 mt7603: remove watchdog reset on interface stop 4490f93 mt7603: remove WARN_ON_ONCE for workaround checks 3075059 mt7603: simplify PSE reset 4ed7e07 mt7603: warn if PSE reset fails 7dc8db1 mt7603: clean up dma debug reads 41e6a04 mt7603: make mt7603_mac_watchdog_reset() static dc7a351 mt7603: clear wtbl PS bit for powersave responses 123acf2 mt7603: set tx-skip flag for powersave clients 7dd2a9e mt7603: initialize wtbl ps flag on station add 86ddef3 mt76x2: remove some harmless WARN_ONs in tx status and rx path e326bc2 mt7603: remove some harmless WARN_ONs in rx path Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--package/kernel/mt76/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 06b9eb07f3..e436e9de17 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2017-10-12
-PKG_SOURCE_VERSION:=1be430fc8ae486e61f51f76925b30d6ff64c37dd
-PKG_MIRROR_HASH:=992e3d86d493b976ec23fb4f1179a72c3e34199c6ec5a93f37069555c9b19d9c
+PKG_SOURCE_DATE:=2017-12-03
+PKG_SOURCE_VERSION:=e326bc2ac4229220203c32e856dcb47d5ee5326d
+PKG_MIRROR_HASH:=0efdde435cc82f3dff0d8cfc5a1de6121998d5ff521f1ba694b15cefd8b0c951
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_BUILD_PARALLEL:=1