aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2013-01-27 21:15:13 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2013-01-27 21:15:13 +0000
commit4947dab66aee138c5e7f2dab2c23024a6392bc90 (patch)
tree26d8b1c718db7392a9fce3a2bcf75fdd8374df1c
parent8193bbe59a74d34d6a26d4a8cb857b1952905314 (diff)
downloadupstream-4947dab66aee138c5e7f2dab2c23024a6392bc90.tar.gz
upstream-4947dab66aee138c5e7f2dab2c23024a6392bc90.tar.bz2
upstream-4947dab66aee138c5e7f2dab2c23024a6392bc90.zip
acx-mac80211: use same config options as mac80211 package
Problem was missing CONFIG_MAC80211_DEBUGFS in the acx-mac80211 build, which broke subsequently the ABI in struct ieee80211_ops. Defect manifested in failing ieee80211_alloc_hw() and maybe also in other strange behaviour before. I added CONFIG_CFG80211_DEBUGFS, CONFIG_MAC80211_DEBUGFS and the same also for CONFIG_MAC80211_MESH, just to be inline on how it's done currently in package/mac80211/Makefile. Thank you Oliver Winker SVN-Revision: 35332
-rw-r--r--package/acx-mac80211/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/acx-mac80211/Makefile b/package/acx-mac80211/Makefile
index fa4b59cb76..d29cf407db 100644
--- a/package/acx-mac80211/Makefile
+++ b/package/acx-mac80211/Makefile
@@ -21,6 +21,10 @@ PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_MIRROR_MD5SUM:=8d6bc84239059fd938ff4d989579f622
PKG_BUILD_DEPENDS:=mac80211
+PKG_CONFIG_DEPENDS:= \
+ CONFIG_PACKAGE_MAC80211_DEBUGFS \
+ CONFIG_PACKAGE_MAC80211_MESH \
+
include $(INCLUDE_DIR)/package.mk
define KernelPackage/acx-mac80211
@@ -173,6 +177,9 @@ PKG_EXTRA_KCONFIG:= \
PKG_EXTRA_CFLAGS:= \
$(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=m,%,$(filter %=m,$(PKG_EXTRA_KCONFIG)))) \
$(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=y,%,$(filter %=y,$(PKG_EXTRA_KCONFIG)))) \
+ $(if $(CONFIG_LEDS_TRIGGERS), -DCONFIG_MAC80211_LEDS -DCONFIG_LEDS_TRIGGERS) \
+ $(if $(CONFIG_PACKAGE_MAC80211_DEBUGFS), -DCONFIG_CFG80211_DEBUGFS -DCONFIG_MAC80211_DEBUGFS) \
+ $(if $(CONFIG_PACKAGE_MAC80211_MESH), -DCONFIG_MAC80211_MESH) \
LINUX_AUTOCONF_FILE:= generated/autoconf.h