aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-06-14 18:08:25 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-06-14 18:08:25 +0000
commit49420e50c457c6ddb87f9937a0a3b1d8535999bb (patch)
tree58429579d5ad18fc0df48d0b45fb7854b6455b6f
parent0739e214021346a6c6d15874d0c9ce673f9027eb (diff)
downloadupstream-49420e50c457c6ddb87f9937a0a3b1d8535999bb.tar.gz
upstream-49420e50c457c6ddb87f9937a0a3b1d8535999bb.tar.bz2
upstream-49420e50c457c6ddb87f9937a0a3b1d8535999bb.zip
Move wget2nand to the base-files for adm5120 also fix default permission (#1812)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7633 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/wget2nand/Makefile37
-rwxr-xr-xtarget/linux/adm5120-2.6/base-files/default/sbin/wget2nand (renamed from package/wget2nand/src/wget2nand)1
-rw-r--r--target/linux/adm5120-2.6/profiles/RB1xx.mk2
3 files changed, 2 insertions, 38 deletions
diff --git a/package/wget2nand/Makefile b/package/wget2nand/Makefile
deleted file mode 100644
index e029a502e9..0000000000
--- a/package/wget2nand/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id: $
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=wget2nand
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/wget2nand
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=RouterOS to OpenWrt install script
- DEPENDS:=@LINUX_2_6_ADM5120
- DESCRIPTION:=\
- A tool to switch from RouterBoard RouterOS to OpenWrt
- URL:=https://dev.openwrt.org/browser/trunk/package/wget2nand/src/wget2nand
- VERSION:=1
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/wget2nand/install
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) ./src/$(PKG_NAME) $(1)/sbin/
-endef
-
-$(eval $(call BuildPackage,wget2nand))
diff --git a/package/wget2nand/src/wget2nand b/target/linux/adm5120-2.6/base-files/default/sbin/wget2nand
index 9588396fdf..1f7548aa06 100755
--- a/package/wget2nand/src/wget2nand
+++ b/target/linux/adm5120-2.6/base-files/default/sbin/wget2nand
@@ -58,6 +58,7 @@ echo "Patching the kernel command line"
chmod +x /tmp/wget2nand-boot/kernel
# make sure everything is written before we unmount the partitions
+echo "chmod ugo+x /" > /tmp/wget2nand/etc/uci-defaults/set_root_permission
sync
ls /tmp/wget2nand-boot/
ls /tmp/wget2nand/
diff --git a/target/linux/adm5120-2.6/profiles/RB1xx.mk b/target/linux/adm5120-2.6/profiles/RB1xx.mk
index d832523a26..8bede7a79a 100644
--- a/target/linux/adm5120-2.6/profiles/RB1xx.mk
+++ b/target/linux/adm5120-2.6/profiles/RB1xx.mk
@@ -7,7 +7,7 @@
define Profile/RouterBoard
NAME:=RouterBoard RB1xx
- PACKAGES:=kmod-madwifi patch-cmdline wget2nand
+ PACKAGES:=kmod-madwifi patch-cmdline
endef
define Profile/RouterBoard/Description