aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-08-16 13:26:23 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-08-27 10:32:44 +0200
commit491eaa898bc10b2f22c4b9b8d9cea4b860a0587f (patch)
treecc9a8182c368eedb48e764c8c7a9d70ff21652f5
parent5f013de786da7e7b28445927b538e9c7bf7f768a (diff)
downloadupstream-491eaa898bc10b2f22c4b9b8d9cea4b860a0587f.tar.gz
upstream-491eaa898bc10b2f22c4b9b8d9cea4b860a0587f.tar.bz2
upstream-491eaa898bc10b2f22c4b9b8d9cea4b860a0587f.zip
kernel: bump 4.19 to 4.19.67
Refreshed all patches. Also add a missing symbol for x86 which got used now in this bump. - ISCSI_IBFT Compile-tested on: cns3xxx Runtime-tested on: cns3xxx Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/hack-4.19/902-debloat_proc.patch2
-rw-r--r--target/linux/generic/pending-4.19/613-netfilter_optional_tcp_window_check.patch6
-rw-r--r--target/linux/x86/64/config-4.191
-rw-r--r--target/linux/x86/generic/config-4.191
-rw-r--r--target/linux/x86/geode/config-4.191
-rw-r--r--target/linux/x86/legacy/config-4.191
7 files changed, 10 insertions, 6 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 354b493236..87bf09f00d 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -8,11 +8,11 @@ endif
LINUX_VERSION-4.9 = .189
LINUX_VERSION-4.14 = .139
-LINUX_VERSION-4.19 = .66
+LINUX_VERSION-4.19 = .67
LINUX_KERNEL_HASH-4.9.189 = 93d945661246f726b694455c80c140717d2beff5a718445a51183439bbe5d0b3
LINUX_KERNEL_HASH-4.14.139 = 8c62d495444dba90200740ec770d274780b010e957cfc447f07999d717e37042
-LINUX_KERNEL_HASH-4.19.66 = c981abe15c4b9496cdadb04e4f4afb88b3a78f31ced8d07684ee9c58b3fadb64
+LINUX_KERNEL_HASH-4.19.67 = 5a1c3d60c38a7a0a086fcd6fdce5603c31c487852b1b64c071ee6de62c98a502
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/generic/hack-4.19/902-debloat_proc.patch b/target/linux/generic/hack-4.19/902-debloat_proc.patch
index a396ad0d12..e70f030cb8 100644
--- a/target/linux/generic/hack-4.19/902-debloat_proc.patch
+++ b/target/linux/generic/hack-4.19/902-debloat_proc.patch
@@ -232,7 +232,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (!pe)
--- a/mm/vmalloc.c
+++ b/mm/vmalloc.c
-@@ -2740,6 +2740,8 @@ static const struct seq_operations vmall
+@@ -2749,6 +2749,8 @@ static const struct seq_operations vmall
static int __init proc_vmalloc_init(void)
{
diff --git a/target/linux/generic/pending-4.19/613-netfilter_optional_tcp_window_check.patch b/target/linux/generic/pending-4.19/613-netfilter_optional_tcp_window_check.patch
index 2bc48f87cf..634218dfc3 100644
--- a/target/linux/generic/pending-4.19/613-netfilter_optional_tcp_window_check.patch
+++ b/target/linux/generic/pending-4.19/613-netfilter_optional_tcp_window_check.patch
@@ -18,7 +18,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
/* "Be conservative in what you do,
be liberal in what you accept from others."
If it's non-zero, we mark only out of window RST segments as INVALID. */
-@@ -483,6 +486,9 @@ static bool tcp_in_window(const struct n
+@@ -484,6 +487,9 @@ static bool tcp_in_window(const struct n
s32 receiver_offset;
bool res, in_recv_win;
@@ -28,7 +28,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
/*
* Get the required data from the packet.
*/
-@@ -1057,7 +1063,7 @@ static int tcp_packet(struct nf_conn *ct
+@@ -1059,7 +1065,7 @@ static int tcp_packet(struct nf_conn *ct
IP_CT_TCP_FLAG_DATA_UNACKNOWLEDGED &&
timeouts[new_state] > timeouts[TCP_CONNTRACK_UNACK])
timeout = timeouts[TCP_CONNTRACK_UNACK];
@@ -37,7 +37,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
timeouts[new_state] > timeouts[TCP_CONNTRACK_RETRANS])
timeout = timeouts[TCP_CONNTRACK_RETRANS];
else
-@@ -1506,6 +1512,13 @@ static struct ctl_table tcp_sysctl_table
+@@ -1508,6 +1514,13 @@ static struct ctl_table tcp_sysctl_table
.mode = 0644,
.proc_handler = proc_dointvec,
},
diff --git a/target/linux/x86/64/config-4.19 b/target/linux/x86/64/config-4.19
index 43642e5a66..ddbd818dfc 100644
--- a/target/linux/x86/64/config-4.19
+++ b/target/linux/x86/64/config-4.19
@@ -292,6 +292,7 @@ CONFIG_INTEL_SOC_DTS_THERMAL=y
CONFIG_IOMMU_HELPER=y
CONFIG_IOSF_MBI=y
# CONFIG_IOSF_MBI_DEBUG is not set
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_KALLSYMS_ABSOLUTE_PERCPU=y
# CONFIG_KVM_DEBUG_FS is not set
diff --git a/target/linux/x86/generic/config-4.19 b/target/linux/x86/generic/config-4.19
index e769835b73..4a689ca026 100644
--- a/target/linux/x86/generic/config-4.19
+++ b/target/linux/x86/generic/config-4.19
@@ -231,6 +231,7 @@ CONFIG_IRQ_BYPASS_MANAGER=y
CONFIG_ISA=y
CONFIG_ISAPNP=y
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_ISO9660_FS=y
# CONFIG_JOLIET is not set
diff --git a/target/linux/x86/geode/config-4.19 b/target/linux/x86/geode/config-4.19
index 9ee50f89f5..5b01ecf00a 100644
--- a/target/linux/x86/geode/config-4.19
+++ b/target/linux/x86/geode/config-4.19
@@ -68,6 +68,7 @@ CONFIG_IOSF_MBI=y
CONFIG_ISA=y
# CONFIG_ISAPNP is not set
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
# CONFIG_LANCE is not set
CONFIG_LEDS_GPIO=y
diff --git a/target/linux/x86/legacy/config-4.19 b/target/linux/x86/legacy/config-4.19
index 4fcbc05aef..2e5199185a 100644
--- a/target/linux/x86/legacy/config-4.19
+++ b/target/linux/x86/legacy/config-4.19
@@ -143,6 +143,7 @@ CONFIG_IOSF_MBI=y
CONFIG_ISA=y
CONFIG_ISAPNP=y
CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
# CONFIG_ISCSI_IBFT_FIND is not set
CONFIG_ISO9660_FS=y
# CONFIG_JOLIET is not set