aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-03-31 22:46:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-03-31 22:46:05 +0000
commit45b6ff6c9e2e6e8939cd58eb0077348421e713c1 (patch)
treea5094c64bbc2717a3fb145b1983e7331e883dd15
parent6e19c91f2a00a8deb6855a5e1513e8c2e3e9dd3e (diff)
downloadupstream-45b6ff6c9e2e6e8939cd58eb0077348421e713c1.tar.gz
upstream-45b6ff6c9e2e6e8939cd58eb0077348421e713c1.tar.bz2
upstream-45b6ff6c9e2e6e8939cd58eb0077348421e713c1.zip
add setserial
SVN-Revision: 495
-rw-r--r--openwrt/package/Config.in1
-rw-r--r--openwrt/package/Makefile1
-rw-r--r--openwrt/package/setserial/Config.in10
-rw-r--r--openwrt/package/setserial/Makefile58
-rwxr-xr-xopenwrt/package/setserial/ipkg/etc/init.d/S15serial2
-rw-r--r--openwrt/package/setserial/setserial.control6
6 files changed, 78 insertions, 0 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 28bfc3576d..9d8b4a775a 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -13,6 +13,7 @@ source "package/haserl/Config.in"
source "package/microperl/Config.in"
source "package/strace/Config.in"
source "package/lcd4linux/Config.in"
+source "package/setserial/Config.in"
comment "Networking"
source "package/tcpdump/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 0f1193db48..299a61245f 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -33,6 +33,7 @@ package-$(BR2_PACKAGE_PPTP) += pptp
package-$(BR2_PACKAGE_PPTPD) += pptpd
package-$(BR2_PACKAGE_QUAGGA) += quagga
package-$(BR2_PACKAGE_SER) += ser
+package-$(BR2_PACKAGE_SETSERIAL) += setserial
package-$(BR2_PACKAGE_STRACE) += strace
package-$(BR2_PACKAGE_TCPDUMP) += tcpdump
package-$(BR2_PACKAGE_WOL) += wol
diff --git a/openwrt/package/setserial/Config.in b/openwrt/package/setserial/Config.in
new file mode 100644
index 0000000000..477896769e
--- /dev/null
+++ b/openwrt/package/setserial/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_SETSERIAL
+ tristate "setserial"
+ default m
+ help
+ setserial is a program designed to set and/or report the
+ configuration information associated with a serial port. This
+ information includes what I/O port and IRQ a particular
+ serial port is using, and whether or not the break key should
+ be interpreted as the Secure Attention Key, and so on.
+
diff --git a/openwrt/package/setserial/Makefile b/openwrt/package/setserial/Makefile
new file mode 100644
index 0000000000..d42eaecafe
--- /dev/null
+++ b/openwrt/package/setserial/Makefile
@@ -0,0 +1,58 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=setserial
+PKG_VERSION:=2.17
+PKG_RELEASE:=1
+PKG_MD5SUM:=c4867d72c41564318e0107745eb7a0f2
+
+PKG_SOURCE_URL:=@SF/setserial
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+ $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+ $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
+ (cd $(PKG_BUILD_DIR); \
+ $(TARGET_CONFIGURE_OPTS) \
+ ./configure \
+ --prefix=/ \
+ --target=$(REAL_GNU_TARGET_NAME) --host=$(GNU_HOST_NAME) \
+ )
+ touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC=$(TARGET_CC) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ all
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
+ mkdir -p $(PKG_IPK_DIR)/usr/sbin
+ cp -a ./ipkg/* $(PKG_IPK_DIR)/
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+ chmod +x $(PKG_IPK_DIR)/etc/init.d/*
+ cp $(PKG_BUILD_DIR)/setserial $(PKG_IPK_DIR)/usr/sbin/
+ $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
+ mkdir -p $(PACKAGE_DIR)
+ find $(PKG_IPK_DIR) -name CVS | xargs rm -rf
+ $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/setserial.list: $(PKG_IPK)
+ $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+
+clean:
+ rm -rf $(PKG_BUILD_DIR)
+ rm -f $(PKG_IPK)
diff --git a/openwrt/package/setserial/ipkg/etc/init.d/S15serial b/openwrt/package/setserial/ipkg/etc/init.d/S15serial
new file mode 100755
index 0000000000..ffd729e1e7
--- /dev/null
+++ b/openwrt/package/setserial/ipkg/etc/init.d/S15serial
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/sbin/setserial /dev/tts/1 irq 3
diff --git a/openwrt/package/setserial/setserial.control b/openwrt/package/setserial/setserial.control
new file mode 100644
index 0000000000..e6f54d72f1
--- /dev/null
+++ b/openwrt/package/setserial/setserial.control
@@ -0,0 +1,6 @@
+Package: setserial
+Priority: optional
+Section: console
+Maintainer: Georg Lukas <georg@boerde.de>
+Source: buildroot internal
+Description: configuration utility for serial ports