aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-21 16:54:15 +0000
committerJohn Crispin <john@openwrt.org>2013-06-21 16:54:15 +0000
commit44b1688e6c7b4f16f7165fbd560e1183aef69090 (patch)
tree01c783c1dffc286ac0ed10aa7fc88f828007b78e
parent5d441ae7eaa46a351ca8ca32486b499dee9332e6 (diff)
downloadupstream-44b1688e6c7b4f16f7165fbd560e1183aef69090.tar.gz
upstream-44b1688e6c7b4f16f7165fbd560e1183aef69090.tar.bz2
upstream-44b1688e6c7b4f16f7165fbd560e1183aef69090.zip
lantiq: Tune the XWAY subtarget cflags
This patch sets the cflags -mtune=34kc -mdsp only in XWAY subtarget, while the others remain with mtune=mips32r2. Although the Danube has a Mips 24KEc core performs well with the above cflags. Signed-off-by: José Vázquez Fernández <ppvazquezfer@gmail.com> SVN-Revision: 37006
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/lantiq/ase/target.mk1
-rw-r--r--target/linux/lantiq/falcon/target.mk1
-rw-r--r--target/linux/lantiq/svip_be/target.mk1
-rw-r--r--target/linux/lantiq/svip_le/target.mk1
-rw-r--r--target/linux/lantiq/xway/target.mk1
6 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index d8c12ed3e5..25fea54080 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS=xway ase falcon
LINUX_VERSION:=3.8.13
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+CFLAGS=-Os -pipe -mips32r2 -fno-caller-saves -mno-branch-likely
define Target/Description
Build firmware images for Lantiq SoC
diff --git a/target/linux/lantiq/ase/target.mk b/target/linux/lantiq/ase/target.mk
index a052dd2ce7..f1f0c07eb3 100644
--- a/target/linux/lantiq/ase/target.mk
+++ b/target/linux/lantiq/ase/target.mk
@@ -2,6 +2,7 @@ ARCH:=mips
SUBTARGET:=ase
BOARDNAME:=Amazon-SE
FEATURES:=squashfs atm
+CFLAGS+= -mtune=mips32r2
DEFAULT_PACKAGES+=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl kmod-ltq-dsl-ase ltq-dsl-app
diff --git a/target/linux/lantiq/falcon/target.mk b/target/linux/lantiq/falcon/target.mk
index 14ac402473..b7af20c79c 100644
--- a/target/linux/lantiq/falcon/target.mk
+++ b/target/linux/lantiq/falcon/target.mk
@@ -3,6 +3,7 @@ SUBTARGET:=falcon
BOARDNAME:=Falcon
FEATURES:=squashfs
DEVICE_TYPE:=other
+CFLAGS+= -mtune=mips32r2
DEFAULT_PACKAGES+= kmod-ifxos gpon-base-files kmod-leds-gpio kmod-ledtrig-heartbeat \
kmod-gpon-optic-drv gpon-optic-drv kmod-gpon-onu-drv gpon-onu-drv \
diff --git a/target/linux/lantiq/svip_be/target.mk b/target/linux/lantiq/svip_be/target.mk
index 7cdd540590..ef8eeffa43 100644
--- a/target/linux/lantiq/svip_be/target.mk
+++ b/target/linux/lantiq/svip_be/target.mk
@@ -3,6 +3,7 @@ SUBTARGET:=svip_be
BOARDNAME:=SVIP Big Endian
FEATURES:=squashfs
DEVICE_TYPE:=other
+CFLAGS+= -mtune=mips32r2
DEFAULT_PACKAGES+= uboot-svip hostapd-mini
diff --git a/target/linux/lantiq/svip_le/target.mk b/target/linux/lantiq/svip_le/target.mk
index 2c1ed07a4e..d2ccdbcfe1 100644
--- a/target/linux/lantiq/svip_le/target.mk
+++ b/target/linux/lantiq/svip_le/target.mk
@@ -3,6 +3,7 @@ SUBTARGET:=svip_le
BOARDNAME:=SVIP Little Endian
FEATURES:=squashfs
DEVICE_TYPE:=other
+CFLAGS+= -mtune=mips32r2
DEFAULT_PACKAGES+= uboot-svip hostapd-mini
diff --git a/target/linux/lantiq/xway/target.mk b/target/linux/lantiq/xway/target.mk
index 540de14801..ffbc4eaefe 100644
--- a/target/linux/lantiq/xway/target.mk
+++ b/target/linux/lantiq/xway/target.mk
@@ -2,6 +2,7 @@ ARCH:=mips
SUBTARGET:=xway
BOARDNAME:=XWAY
FEATURES:=squashfs atm mips16
+CFLAGS+= -mtune=34kc -mdsp
DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug