aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2018-11-23 01:09:23 -0800
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2019-02-11 20:18:48 +0000
commit43e14a2f9e8b49ec73490eccb5c08209fffbe7ce (patch)
treeab02fa4f41d341b8c24057022b05dd8c25f825b4
parentd741b31eb8bbb7a6aa1151c55b3d2506662bf6a8 (diff)
downloadupstream-43e14a2f9e8b49ec73490eccb5c08209fffbe7ce.tar.gz
upstream-43e14a2f9e8b49ec73490eccb5c08209fffbe7ce.tar.bz2
upstream-43e14a2f9e8b49ec73490eccb5c08209fffbe7ce.zip
iproute2: fix broken configuration patch
Since v4.13, iproute2 switched to a config.mk file with greater use of pkg-config for library/feature detection. Replace the old Config patch with one modifying the configure script but enabling the same changes: - explicitly disable TC_CONFIG_ATM - rely on feature detection for IP_CONFIG_SETNS and TC_CONFIG_XT Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
-rw-r--r--package/network/utils/iproute2/patches/100-config.patch7
-rw-r--r--package/network/utils/iproute2/patches/100-configure.patch12
2 files changed, 12 insertions, 7 deletions
diff --git a/package/network/utils/iproute2/patches/100-config.patch b/package/network/utils/iproute2/patches/100-config.patch
deleted file mode 100644
index 7f23cfc35e..0000000000
--- a/package/network/utils/iproute2/patches/100-config.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- /dev/null
-+++ b/Config
-@@ -0,0 +1,4 @@
-+# Fixed config to disable ATM support even if present on host system
-+IP_CONFIG_SETNS:=y
-+TC_CONFIG_ATM:=n
-+TC_CONFIG_XT:=y
diff --git a/package/network/utils/iproute2/patches/100-configure.patch b/package/network/utils/iproute2/patches/100-configure.patch
new file mode 100644
index 0000000000..248b1c0e01
--- /dev/null
+++ b/package/network/utils/iproute2/patches/100-configure.patch
@@ -0,0 +1,12 @@
+--- a/configure
++++ b/configure
+@@ -32,7 +32,8 @@ int main(int argc, char **argv) {
+ }
+ EOF
+
+- if $CC -I$INCLUDE -o $TMPDIR/atmtest $TMPDIR/atmtest.c -latm >/dev/null 2>&1; then
++# OpenWrt: disable ATM support even if present on host system
++ if [ 1 -eq 0 ]; then
+ echo "TC_CONFIG_ATM:=y" >>$CONFIG
+ echo yes
+ else