aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-06-27 10:40:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-06-27 10:40:44 +0000
commit42bc2c49aef36b48c7b5a5f7b25b66c5bbca1d9d (patch)
tree2d7154562983ea8e8f824562c28e2a4ba7943b21
parent4255b2fde576ee47ac75a71d6fc3f1fed04fb596 (diff)
downloadupstream-42bc2c49aef36b48c7b5a5f7b25b66c5bbca1d9d.tar.gz
upstream-42bc2c49aef36b48c7b5a5f7b25b66c5bbca1d9d.tar.bz2
upstream-42bc2c49aef36b48c7b5a5f7b25b66c5bbca1d9d.zip
6in4: send password unhashed
The preferred he.net /nic/update endpoint expects the password or updatekey in plain text and not as md5 sum, therfore remove the hashing operation from the script. This effectively renders the "updatekey" option redundant but we keep it around for backwards compatibility. Both "option password" and "option updatekey" will have end up in the "&password=" parameter of the update url and are passed through unmodified. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 41358
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh6
2 files changed, 2 insertions, 6 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index bd999721d8..1235ce5335 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=16
+PKG_VERSION:=17
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index f9434936e3..5309cc4a5f 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -1,6 +1,6 @@
#!/bin/sh
# 6in4.sh - IPv6-in-IPv4 tunnel backend
-# Copyright (c) 2010-2012 OpenWrt.org
+# Copyright (c) 2010-2014 OpenWrt.org
[ -n "$INCLUDE_ONLY" ] || {
. /lib/functions.sh
@@ -63,10 +63,6 @@ proto_6in4_setup() {
proto_send_update "$cfg"
[ -n "$tunnelid" -a -n "$username" -a \( -n "$password" -o -n "$updatekey" \) ] && {
- [ "${#password}" == 32 -a -z "${password//[a-fA-F0-9]/}" ] || {
- password="$(echo -n "$password" | md5sum)"; password="${password%% *}"
- }
-
[ -n "$updatekey" ] && password="$updatekey"
local url="http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"