aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:16 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 15:50:16 +0000
commit4000de357e4b41f4978fe2344b3ff2073cc6c812 (patch)
tree1b02247234704ea99720b256da66adbd4501896c
parenta282e37c094fa3f634c2418a69069722dd439261 (diff)
downloadupstream-4000de357e4b41f4978fe2344b3ff2073cc6c812.tar.gz
upstream-4000de357e4b41f4978fe2344b3ff2073cc6c812.tar.bz2
upstream-4000de357e4b41f4978fe2344b3ff2073cc6c812.zip
move crypto module to target specific modules.mk
SVN-Revision: 32856
-rw-r--r--package/kernel/modules/crypto.mk17
-rw-r--r--target/linux/ixp4xx/modules.mk17
2 files changed, 17 insertions, 17 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index f9ce8f96da..1e22142148 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -154,23 +154,6 @@ endef
$(eval $(call KernelPackage,crypto-hw-hifn-795x))
-define KernelPackage/crypto-hw-ixp4xx
- TITLE:=Intel IXP4xx hardware crypto module
- DEPENDS:=@TARGET_ixp4xx
- KCONFIG:= \
- CONFIG_CRYPTO_DEV_IXP4XX
- FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
- AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
- $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
-endef
-
-define KernelPackage/crypto-hw-ixp4xx/description
- Kernel support for the Intel IXP4xx HW crypto engine.
-endef
-
-$(eval $(call KernelPackage,crypto-hw-ixp4xx))
-
-
define KernelPackage/crypto-hw-ppc4xx
TITLE:=AMCC PPC4xx hardware crypto module
DEPENDS:=@TARGET_ppc40x||TARGET_ppc44x
diff --git a/target/linux/ixp4xx/modules.mk b/target/linux/ixp4xx/modules.mk
index e088497793..8bf6e693b7 100644
--- a/target/linux/ixp4xx/modules.mk
+++ b/target/linux/ixp4xx/modules.mk
@@ -39,3 +39,20 @@ define KernelPackage/ixp4xx-beeper/description
endef
$(eval $(call KernelPackage,ixp4xx-beeper))
+
+
+define KernelPackage/crypto-hw-ixp4xx
+ TITLE:=Intel IXP4xx hardware crypto module
+ DEPENDS:=@TARGET_ixp4xx
+ KCONFIG:= \
+ CONFIG_CRYPTO_DEV_IXP4XX
+ FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
+ AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
+ $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
+endef
+
+define KernelPackage/crypto-hw-ixp4xx/description
+ Kernel support for the Intel IXP4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ixp4xx))