aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2015-04-07 20:03:24 +0000
committerGabor Juhos <juhosg@openwrt.org>2015-04-07 20:03:24 +0000
commit3fa90854cf48c32690ae5196b2e0a69d668e33e9 (patch)
tree6c87144e7e7c0cd584ad21e7913f6ca03a5e57c1
parentcb2fd1e2ecd6b85404dbd1c24796ff35ee4a3efe (diff)
downloadupstream-3fa90854cf48c32690ae5196b2e0a69d668e33e9.tar.gz
upstream-3fa90854cf48c32690ae5196b2e0a69d668e33e9.tar.bz2
upstream-3fa90854cf48c32690ae5196b2e0a69d668e33e9.zip
ar71xx: select RLE_DECOMPRESS directly by the RouterBOOT helper code
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45296 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch19
-rw-r--r--target/linux/ar71xx/patches-3.18/707-MIPS-ath79-add-support-for-QCA953x-SoC.patch4
-rw-r--r--target/linux/ar71xx/patches-3.18/735-MIPS-ath79-add-support-for-QCA956x-SoC.patch4
-rw-r--r--target/linux/ar71xx/patches-3.18/737-MIPS-ath79-add-om5p-an-support.patch2
4 files changed, 14 insertions, 15 deletions
diff --git a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
index fa4074eb87..3555de3a44 100644
--- a/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
+++ b/target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
@@ -264,7 +264,7 @@
config ATH79_MACH_AP121
bool "Atheros AP121 reference board"
select SOC_AR933X
-@@ -11,62 +75,980 @@ config ATH79_MACH_AP121
+@@ -11,62 +75,976 @@ config ATH79_MACH_AP121
select ATH79_DEV_M25P80
select ATH79_DEV_USB
select ATH79_DEV_WMAC
@@ -735,7 +735,6 @@
+ select ATH79_DEV_ETH
+ select ATH79_DEV_USB
+ select ATH79_ROUTERBOOT
-+ select RLE_DECOMPRESS
+
+config ATH79_MACH_RB91X
+ bool "MikroTik RouterBOARD 91X support"
@@ -745,7 +744,6 @@
+ select ATH79_DEV_WMAC
+ select ATH79_DEV_USB
+ select ATH79_ROUTERBOOT
-+ select RLE_DECOMPRESS
+
+config ATH79_MACH_RB95X
+ bool "MikroTik RouterBOARD 95X support"
@@ -755,7 +753,6 @@
+ select ATH79_DEV_WMAC
+ select ATH79_DEV_USB
+ select ATH79_ROUTERBOOT
-+ select RLE_DECOMPRESS
+
+config ATH79_MACH_RB2011
+ bool "MikroTik RouterBOARD 2011 support"
@@ -766,7 +763,6 @@
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+ select ATH79_ROUTERBOOT
-+ select RLE_DECOMPRESS
+
+config ATH79_MACH_RBSXTLITE
+ bool "MikroTik RouterBOARD SXT Lite"
@@ -1273,7 +1269,7 @@
config ATH79_MACH_UBNT_XM
bool "Ubiquiti Networks XM/UniFi boards"
-@@ -83,6 +1065,97 @@ config ATH79_MACH_UBNT_XM
+@@ -83,6 +1061,97 @@ config ATH79_MACH_UBNT_XM
Say 'Y' here if you want your kernel to support the
Ubiquiti Networks XM (rev 1.0) board.
@@ -1371,7 +1367,7 @@
endmenu
config SOC_AR71XX
-@@ -124,7 +1197,10 @@ config ATH79_DEV_DSA
+@@ -124,7 +1193,10 @@ config ATH79_DEV_DSA
config ATH79_DEV_ETH
def_bool n
@@ -1383,13 +1379,16 @@
def_bool n
config ATH79_DEV_GPIO_BUTTONS
-@@ -156,4 +1232,7 @@ config ATH79_PCI_ATH9K_FIXUP
- config ATH79_ROUTERBOOT
+@@ -154,6 +1226,10 @@ config ATH79_PCI_ATH9K_FIXUP
def_bool n
-+config PCI_AR724X
+ config ATH79_ROUTERBOOT
++ select RLE_DECOMPRESS
+ def_bool n
+
++config PCI_AR724X
+ def_bool n
+
endif
--- a/arch/mips/ath79/Makefile
+++ b/arch/mips/ath79/Makefile
diff --git a/target/linux/ar71xx/patches-3.18/707-MIPS-ath79-add-support-for-QCA953x-SoC.patch b/target/linux/ar71xx/patches-3.18/707-MIPS-ath79-add-support-for-QCA953x-SoC.patch
index 9b69869143..1f6a4d23ba 100644
--- a/target/linux/ar71xx/patches-3.18/707-MIPS-ath79-add-support-for-QCA953x-SoC.patch
+++ b/target/linux/ar71xx/patches-3.18/707-MIPS-ath79-add-support-for-QCA953x-SoC.patch
@@ -22,7 +22,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
-@@ -1178,6 +1178,10 @@ config SOC_AR934X
+@@ -1174,6 +1174,10 @@ config SOC_AR934X
select PCI_AR724X if PCI
def_bool n
@@ -33,7 +33,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
config SOC_QCA955X
select HW_HAS_PCI
select PCI_AR724X if PCI
-@@ -1220,7 +1224,7 @@ config ATH79_DEV_USB
+@@ -1216,7 +1220,7 @@ config ATH79_DEV_USB
def_bool n
config ATH79_DEV_WMAC
diff --git a/target/linux/ar71xx/patches-3.18/735-MIPS-ath79-add-support-for-QCA956x-SoC.patch b/target/linux/ar71xx/patches-3.18/735-MIPS-ath79-add-support-for-QCA956x-SoC.patch
index da5126aaaa..2e1ae29e58 100644
--- a/target/linux/ar71xx/patches-3.18/735-MIPS-ath79-add-support-for-QCA956x-SoC.patch
+++ b/target/linux/ar71xx/patches-3.18/735-MIPS-ath79-add-support-for-QCA956x-SoC.patch
@@ -445,7 +445,7 @@
}
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
-@@ -1187,6 +1187,12 @@ config SOC_QCA955X
+@@ -1183,6 +1183,12 @@ config SOC_QCA955X
select PCI_AR724X if PCI
def_bool n
@@ -458,7 +458,7 @@
config ATH79_DEV_M25P80
select ATH79_DEV_SPI
def_bool n
-@@ -1224,7 +1230,7 @@ config ATH79_DEV_USB
+@@ -1220,7 +1226,7 @@ config ATH79_DEV_USB
def_bool n
config ATH79_DEV_WMAC
diff --git a/target/linux/ar71xx/patches-3.18/737-MIPS-ath79-add-om5p-an-support.patch b/target/linux/ar71xx/patches-3.18/737-MIPS-ath79-add-om5p-an-support.patch
index 42d17fe8b4..0d493f6f95 100644
--- a/target/linux/ar71xx/patches-3.18/737-MIPS-ath79-add-om5p-an-support.patch
+++ b/target/linux/ar71xx/patches-3.18/737-MIPS-ath79-add-om5p-an-support.patch
@@ -10,7 +10,7 @@
ATH79_MACH_PB92, /* Atheros PB92 */
--- a/arch/mips/ath79/Kconfig
+++ b/arch/mips/ath79/Kconfig
-@@ -671,6 +671,7 @@ config ATH79_MACH_OM2P
+@@ -677,6 +677,7 @@ config ATH79_MACH_OM2P
config ATH79_MACH_OM5P
bool "OpenMesh OM5P board support"
select SOC_AR934X