aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-10-02 10:40:00 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-10-23 12:37:51 +0200
commit3f8adcb215edaa22448bdbf7cb12de9d95316671 (patch)
treebf3bfee7a178012e498c8c8d20d836cfc4c2ecb8
parent249478ec48509ba42827867fd15372478f9f42d2 (diff)
downloadupstream-3f8adcb215edaa22448bdbf7cb12de9d95316671.tar.gz
upstream-3f8adcb215edaa22448bdbf7cb12de9d95316671.tar.bz2
upstream-3f8adcb215edaa22448bdbf7cb12de9d95316671.zip
wolfssl: remove --enable-sha512 configure switch
It's the default anyway and this just looks confusing, as if it wasn't. Switch to AUTORELEASE while at it. The binary size is unchanged. Signed-off-by: Andre Heider <a.heider@gmail.com> (cherry picked from commit 7cb5af30f48d6788cd471138820a772610a7f8e0)
-rw-r--r--package/libs/wolfssl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/libs/wolfssl/Makefile b/package/libs/wolfssl/Makefile
index 937828c9a0..47501306c8 100644
--- a/package/libs/wolfssl/Makefile
+++ b/package/libs/wolfssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=wolfssl
PKG_VERSION:=4.8.1-stable
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION)
@@ -102,7 +102,7 @@ endif
ifeq ($(CONFIG_WOLFSSL_HAS_WPAS),y)
CONFIGURE_ARGS += \
- --enable-wpas --enable-sha512 --enable-fortress --enable-fastmath
+ --enable-wpas --enable-fortress --enable-fastmath
endif
define Build/InstallDev